aboutsummaryrefslogtreecommitdiff
path: root/editors/psgml/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2005-05-04 20:51:25 +0000
committerHiroki Sato <hrs@FreeBSD.org>2005-05-04 20:51:25 +0000
commit400af70d3908fa5597dec337410621572c483c91 (patch)
treea3ba28c0f6ea4eba9efd82ae0efe45448779c435 /editors/psgml/Makefile
parent54efbb875415fc88786d610c8b1ac6fb9d0ba520 (diff)
downloadports-400af70d3908fa5597dec337410621572c483c91.tar.gz
ports-400af70d3908fa5597dec337410621572c483c91.zip
Notes
Diffstat (limited to 'editors/psgml/Makefile')
-rw-r--r--editors/psgml/Makefile30
1 files changed, 12 insertions, 18 deletions
diff --git a/editors/psgml/Makefile b/editors/psgml/Makefile
index 31007bbaa59b..0868a7bd7947 100644
--- a/editors/psgml/Makefile
+++ b/editors/psgml/Makefile
@@ -7,24 +7,26 @@
PORTNAME= psgml
PORTVERSION= ${PSGML_VER}
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= editors elisp
-MASTER_SITES= ftp://ftp.lysator.liu.se/pub/sgml/ \
- ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= psgml
PKGNAMESUFFIX= -${EMACS_PORT_NAME}
-PATCH_SITES= http://dist.bsdlab.org/
-PATCHFILES= psgml-symbol-conflict-041015.gz
+PATCH_SITES= ${MASTER_SITE_LOCAL}
+PATCH_SITE_SUBDIR= hrs
+PATCHFILES= psgml-symbol-conflict-050503.diff.gz
-MAINTAINER?= ports@FreeBSD.org
+MAINTAINER?= hrs@FreeBSD.org
COMMENT?= A major mode for editing SGML and XML documents for emacs21
+INFO= psgml psgml-api
+
# distfile version
-PSGML_VER= 1.2.5
+PSGML_VER= 1.3.2
PSGML_STARTUPEL= psgml-startup.el
-SCRIPTS_ENV= TARGETS="${PSGML_STARTUPEL}"
+SCRIPTS_ENV= TARGETS="${PSGML_STARTUPEL}" SED=${SED}
PLIST_SUB= PSGML_STARTUPEL=${PSGML_STARTUPEL}
# This is a master port.
@@ -52,19 +54,11 @@ CONFIGURE_ENV= EMACS=${EMACS_CMD}
.endif
pre-configure:
- (cd ${WRKSRC} ; \
- for i in psgml.el psgml.texi ; do \
- ${RM} -f $${i}.in; \
- ${MV} $${i} $${i}.in; \
- ${CAT} $${i}.in | ${SED} -e "s;@prefix@;${LOCALBASE};g" > $${i}; \
- done)
${CP} ${FILESDIR}/${PSGML_STARTUPEL}.in ${WRKDIR}
post-install:
- @(cd ${WRKSRC} ; \
- ${MAKE} install-info ; \
- )
- @${INSTALL_DATA} ${WRKDIR}/${PSGML_STARTUPEL} \
+ cd ${WRKSRC} && ${MAKE} install-info
+ ${INSTALL_DATA} ${WRKDIR}/${PSGML_STARTUPEL} \
${LOCALBASE}/${EMACS_LIBDIR}/site-lisp
.include <bsd.port.post.mk>