aboutsummaryrefslogtreecommitdiff
path: root/editors/rospell/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-25 03:08:43 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-25 03:08:43 +0000
commit11a3d6086495828b34a24a0083d2d0f20df1a70a (patch)
tree197269a93abf46409b055911a2da600438c1a4e4 /editors/rospell/Makefile
parentbd3ccd2ee1654bcc2a92d5688b2ddd44ea6296a1 (diff)
downloadports-11a3d6086495828b34a24a0083d2d0f20df1a70a.tar.gz
ports-11a3d6086495828b34a24a0083d2d0f20df1a70a.zip
Notes
Diffstat (limited to 'editors/rospell/Makefile')
-rw-r--r--editors/rospell/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/editors/rospell/Makefile b/editors/rospell/Makefile
new file mode 100644
index 000000000000..9c546d5cd4dc
--- /dev/null
+++ b/editors/rospell/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: rospell
+# Date created: 2005-11-04
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.1 2005/11/20 18:17:56 itetcu Rel $
+#
+
+PORTNAME= rospell
+PORTVERSION= 2005.03.b1
+CATEGORIES= editors textproc # this should/will be romanian ;)
+MASTER_SITES= http://people.tecnik93.com/~itetcu/FreeBSD/ports/${PORTNAME}/sources/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= itetcu@people.tecnik93.com
+COMMENT= QT-based editor with support for romanian charsets and spell checking
+
+USE_XLIB= yes
+USE_QT_VER= 3
+MAKE_ENV+= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}
+
+MAN1= rospell.1
+
+do-build:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE}
+
+do-install:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} install
+
+.include <bsd.port.mk>