aboutsummaryrefslogtreecommitdiff
path: root/editors/scite/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-03-13 07:44:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-03-13 07:44:03 +0000
commitcfe7aad96a82f0b6a3211555f1c5024651157b69 (patch)
tree3dd65bde02c44aa40977975acacc83c6a1d80929 /editors/scite/Makefile
parent207ce60e94b8a8d0ba65afd0ed0d8971d8d1413d (diff)
Notes
Diffstat (limited to 'editors/scite/Makefile')
-rw-r--r--editors/scite/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/editors/scite/Makefile b/editors/scite/Makefile
index 8982a2caff2e..97a547fc7647 100644
--- a/editors/scite/Makefile
+++ b/editors/scite/Makefile
@@ -7,6 +7,7 @@
PORTNAME= scite
PORTVERSION= 2.03
+PORTREVISION= 1
CATEGORIES= editors gnome
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
@@ -16,6 +17,7 @@ MAINTAINER= cyberbotx@cyberbotx.com
COMMENT= A full-featured SCIntilla based Text Editor for GTK/GNOME
LIB_DEPENDS= scintilla.2:${PORTSDIR}/x11-toolkits/scintilla
+RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
@@ -23,8 +25,6 @@ USE_GMAKE= yes
USE_GNOME= gtk20
MAKEFILE= makefile
-SUB_FILES= pkg-message
-
MAN1= scite.1
post-patch:
@@ -33,6 +33,8 @@ post-patch:
.if defined(WITH_FULL_BUFFER_MENU)
@${REINPLACE_CMD} -e 's|30, "/Buffers|props.GetInt("buffers") > 30 ? props.GetInt("buffers") - 10 : 30, "/Buffers|g' ${WRKSRC}/SciTEGTK.cxx
.endif
+ @${REINPLACE_CMD} -e 's|netscape "file://$$(SciteDefaultHome)|xdg-open "file://${DOCSDIR}|' \
+ ${WRKSRC}/../src/SciTEGlobal.properties
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/../bin/SciTE ${PREFIX}/bin
@@ -50,9 +52,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/../doc/*.png ${DOCSDIR}
.endif
-.if !defined(NOPORTDOCS)
-post-install:
- @${CAT} ${PKGMESSAGE}
-.endif
-
.include <bsd.port.mk>