aboutsummaryrefslogtreecommitdiff
path: root/editors/setedit
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-27 11:01:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-27 11:01:32 +0000
commit3fbea6477da0d85c22838896d9f0ce3a72ec0334 (patch)
tree474ef05e75a2f9ac03dd466e7b27c85250cb1160 /editors/setedit
parentc1c8dd1f5cc35bac899f9833f5a804483c41aef5 (diff)
Notes
Diffstat (limited to 'editors/setedit')
-rw-r--r--editors/setedit/Makefile2
-rw-r--r--editors/setedit/files/patch-Makefile21
-rw-r--r--editors/setedit/files/patch-config.pl93
-rw-r--r--editors/setedit/files/patch-conflib.pl72
4 files changed, 188 insertions, 0 deletions
diff --git a/editors/setedit/Makefile b/editors/setedit/Makefile
index 7f131ecefe71..443dd809c1d3 100644
--- a/editors/setedit/Makefile
+++ b/editors/setedit/Makefile
@@ -17,6 +17,8 @@ COMMENT= Programmer's editor with a nice Text User Interface (TUI)
LIB_DEPENDS= rhtv.2:${PORTSDIR}/devel/rhtvision
HAS_CONFIGURE= yes
+CONFIGURE_ENV= LOCALBASE="${LOCALBASE}" \
+ X11BASE="${X11BASE}"
USE_PERL5_BUILD=yes
USE_GMAKE= yes
diff --git a/editors/setedit/files/patch-Makefile b/editors/setedit/files/patch-Makefile
new file mode 100644
index 000000000000..eadf737564c5
--- /dev/null
+++ b/editors/setedit/files/patch-Makefile
@@ -0,0 +1,21 @@
+*** libmigdb/src/Makefile.orig Thu Oct 27 12:18:57 2005
+--- libmigdb/src/Makefile Thu Oct 27 12:19:34 2005
+***************
+*** 3,10 ****
+
+ all: libmigdb.a
+
+! CFLAGS=-O2 -Wall -gstabs+3 -I.
+! CXXFLAGS=-O2 -Wall -gstabs+3
+ LDLIBS=
+
+ connect.o: mi_gdb.h
+--- 3,10 ----
+
+ all: libmigdb.a
+
+! CFLAGS=-O2 -Wall -I.
+! CXXFLAGS=-O2 -Wall
+ LDLIBS=
+
+ connect.o: mi_gdb.h
diff --git a/editors/setedit/files/patch-config.pl b/editors/setedit/files/patch-config.pl
new file mode 100644
index 000000000000..cd88b05bde79
--- /dev/null
+++ b/editors/setedit/files/patch-config.pl
@@ -0,0 +1,93 @@
+*** config.pl.orig Tue Oct 12 22:00:54 2004
+--- config.pl Thu Oct 27 12:06:23 2005
+***************
+*** 169,175 ****
+ }
+ elsif ($OS eq 'UNIX')
+ {
+! $MakeDefsRHIDE[0]='RHIDE_STDINC=/usr/include /usr/local/include /usr/include/g++ /usr/local/include/g++ /usr/lib/gcc-lib /usr/local/lib/gcc-lib';
+ if (@conf{'static'} eq 'yes')
+ { $libs=TVConfigOption('slibs'); }
+ else
+--- 169,175 ----
+ }
+ elsif ($OS eq 'UNIX')
+ {
+! $MakeDefsRHIDE[0]='RHIDE_STDINC=/usr/include ' . $ENV{'LOCALBASE'} . '/include /usr/include/g++ ' . $ENV{'LOCALBASE'} . '/include/g++ /usr/lib/gcc-lib ' . $ENV{'LOCALBASE'} . '/lib/gcc-lib';
+ if (@conf{'static'} eq 'yes')
+ { $libs=TVConfigOption('slibs'); }
+ else
+***************
+*** 456,464 ****
+ elsif ($i eq '--debug')
+ {
+ $conf{'XCFLAGS'}=
+! $conf{'XCXXFLAGS'}='-O3 -fomit-frame-pointer -ffast-math -gstabs+3';
+ $conf{'CFLAGS'}=
+! $conf{'CXXFLAGS'}='-O2 -Wall -Werror -gstabs+3';
+ }
+ elsif ($i eq '--with-mixer')
+ {
+--- 456,464 ----
+ elsif ($i eq '--debug')
+ {
+ $conf{'XCFLAGS'}=
+! $conf{'XCXXFLAGS'}='-O3 -fomit-frame-pointer -ffast-math';
+ $conf{'CFLAGS'}=
+! $conf{'CXXFLAGS'}='-O2 -Wall -Werror';
+ }
+ elsif ($i eq '--with-mixer')
+ {
+***************
+*** 783,790 ****
+ }
+ elsif ($OS eq 'UNIX')
+ {
+! @dirsI=("$parent/tvision/include",'/usr/include/rhtvision','/usr/local/include/rhtvision');
+! @dirsL=("$parent/tvision/makes",'/usr/lib','/usr/local/lib');
+ }
+ elsif ($OS eq 'Win32')
+ {
+--- 783,790 ----
+ }
+ elsif ($OS eq 'UNIX')
+ {
+! @dirsI=("$parent/tvision/include",'/usr/include/rhtvision',$ENV{'LOCALBASE'} . '/include/rhtvision');
+! @dirsL=("$parent/tvision/makes",'/usr/lib',$ENV{'LOCALBASE'} . '/lib');
+ }
+ elsif ($OS eq 'Win32')
+ {
+***************
+*** 1856,1862 ****
+ return 0;
+ }
+ ';
+! $conf{'X11LibPath'}='/usr/X11R6/lib' unless $conf{'X11LibPath'};
+ $conf{'X11Lib'}='X11 Xmu' unless $conf{'X11Lib'};
+ $libs=$conf{'X11Lib'};
+ $libs=~s/(\S+)/-l$1/g;
+--- 1856,1862 ----
+ return 0;
+ }
+ ';
+! $conf{'X11LibPath'}=$ENV{'X11BASE'} . '/lib' unless $conf{'X11LibPath'};
+ $conf{'X11Lib'}='X11 Xmu' unless $conf{'X11Lib'};
+ $libs=$conf{'X11Lib'};
+ $libs=~s/(\S+)/-l$1/g;
+***************
+*** 1873,1879 ****
+ {
+ if (!$conf{'X11IncludePath'})
+ {
+! $conf{'X11IncludePath'}='/usr/X11R6/include';
+ $o.="-I$conf{'X11IncludePath'} -L$conf{'X11LibPath'} $libs";
+ if ($test=~/OK, (\d+)\.(\d+)/)
+ {
+--- 1873,1879 ----
+ {
+ if (!$conf{'X11IncludePath'})
+ {
+! $conf{'X11IncludePath'}=$ENV{'X11BASE'} . '/include';
+ $o.="-I$conf{'X11IncludePath'} -L$conf{'X11LibPath'} $libs";
+ if ($test=~/OK, (\d+)\.(\d+)/)
+ {
diff --git a/editors/setedit/files/patch-conflib.pl b/editors/setedit/files/patch-conflib.pl
new file mode 100644
index 000000000000..b3baeba9d1dd
--- /dev/null
+++ b/editors/setedit/files/patch-conflib.pl
@@ -0,0 +1,72 @@
+*** conflib.pl.orig Wed Oct 26 21:55:24 2005
+--- conflib.pl Wed Oct 26 21:57:36 2005
+***************
+*** 246,252 ****
+ else
+ {
+ if ($OSf eq 'FreeBSD')
+! { $prefix='/usr/local'; }
+ else
+ { $prefix='/usr'; }
+ }
+--- 246,252 ----
+ else
+ {
+ if ($OSf eq 'FreeBSD')
+! { $prefix=$ENV{'PREFIX'}; }
+ else
+ { $prefix='/usr'; }
+ }
+***************
+*** 567,573 ****
+ $ret.=' -pipe' if $UsePipe;
+ # Looks like that's common and some sysadmins doesn't configure gcc to
+ # look there:
+! $conf{'EXTRA_INCLUDE_DIRS'}.=' /usr/local/include' if ($OSf eq 'FreeBSD');
+ }
+ }
+ print "$ret\n";
+--- 567,573 ----
+ $ret.=' -pipe' if $UsePipe;
+ # Looks like that's common and some sysadmins doesn't configure gcc to
+ # look there:
+! $conf{'EXTRA_INCLUDE_DIRS'}.=' ' . $ENV{'LOCALBASE'} . '/include' if ($OSf eq 'FreeBSD');
+ }
+ }
+ print "$ret\n";
+***************
+*** 596,602 ****
+ return $ret;
+ }
+ $ret='';
+! $ret.='/usr/local/lib' if ($OSf eq 'FreeBSD');
+ $conf{'LDExtraDirs'}=$ret;
+ $ret;
+ }
+--- 596,602 ----
+ return $ret;
+ }
+ $ret='';
+! $ret.=$ENV{'LOCALBASE'} . '/lib' if ($OSf eq 'FreeBSD');
+ $conf{'LDExtraDirs'}=$ret;
+ $ret;
+ }
+***************
+*** 639,646 ****
+ {
+ $ret='-O2'; # -gstabs+3';
+ $ret.=' -pipe' if $UsePipe;
+! $ret.=' -L/usr/local/include' if ($OSf eq 'FreeBSD');
+! $conf{'EXTRA_INCLUDE_DIRS'}.=' /usr/local/include' if ($OSf eq 'FreeBSD');
+ }
+ }
+ print "$ret\n";
+--- 639,646 ----
+ {
+ $ret='-O2'; # -gstabs+3';
+ $ret.=' -pipe' if $UsePipe;
+! $ret.=' -L' . $ENV{'LOCALBASE'} . '/include' if ($OSf eq 'FreeBSD');
+! $conf{'EXTRA_INCLUDE_DIRS'}.=' ' . $ENV{'LOCALBASE'} . '/include' if ($OSf eq 'FreeBSD');
+ }
+ }
+ print "$ret\n";