aboutsummaryrefslogtreecommitdiff
path: root/editors/ssed/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-26 09:07:25 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-26 09:07:25 +0000
commit8147eac3747c2054d9e00ac0df3a15a99319eb50 (patch)
tree17e959572dd74db1c46fc8d067012c5dc31719ee /editors/ssed/Makefile
parent277e81269496e957cd50f53498e8e18be712a098 (diff)
downloadports-8147eac3747c2054d9e00ac0df3a15a99319eb50.tar.gz
ports-8147eac3747c2054d9e00ac0df3a15a99319eb50.zip
Notes
Diffstat (limited to 'editors/ssed/Makefile')
-rw-r--r--editors/ssed/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/editors/ssed/Makefile b/editors/ssed/Makefile
index beacd5d3c6ab..230e413f77c7 100644
--- a/editors/ssed/Makefile
+++ b/editors/ssed/Makefile
@@ -5,29 +5,30 @@
# $FreeBSD$
#
-PORTNAME= ssed
-PORTVERSION= 3.58
-PORTREVISION= 2
+PORTNAME= sed
+PORTVERSION= 3.61a
CATEGORIES= editors textproc
-MASTER_SITES= http://queen.rett.polimi.it/~paolob/seders/ssed/
-DISTNAME= sed-${PORTVERSION}
+MASTER_SITES= http://sed.sourceforge.net/grabbag/ssed/
+PKGNAMEPREFIX= s
MAINTAINER= ports@FreeBSD.org
-COMMENT= Super-sed is a heavily enhanced version of sed
+COMMENT= Super-sed - a heavily enhanced version of sed
-LIB_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} --program-prefix=s
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --program-prefix=s
-MAN1= ssed.1
+MAN1= ssed.1
-.if !defined(WITHOUT_NLS)
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
USE_GETTEXT= yes
+CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
.endif
.include <bsd.port.mk>