aboutsummaryrefslogtreecommitdiff
path: root/editors/staroffice70/Makefile
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2004-07-05 13:26:42 +0000
committerMartin Blapp <mbr@FreeBSD.org>2004-07-05 13:26:42 +0000
commitdb8bfc724900649cfbe148ad5559b9f47f2d2068 (patch)
treec6f6ad258f1aafb87652c294153fec3137cecfd7 /editors/staroffice70/Makefile
parentc9fa380d51d7c9d0009fac53ab951a15121d63dc (diff)
downloadports-db8bfc724900649cfbe148ad5559b9f47f2d2068.tar.gz
ports-db8bfc724900649cfbe148ad5559b9f47f2d2068.zip
Notes
Diffstat (limited to 'editors/staroffice70/Makefile')
-rw-r--r--editors/staroffice70/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/editors/staroffice70/Makefile b/editors/staroffice70/Makefile
index a313c3eda76f..4fa2e58156eb 100644
--- a/editors/staroffice70/Makefile
+++ b/editors/staroffice70/Makefile
@@ -7,7 +7,7 @@
PORTNAME= staroffice
PORTVERSION= 7.0
-PORTREVISION= 1
+PORTREVISION= 3
CATEGORIES= editors linux
MASTER_SITES= ftp://ftp.sun.co.uk/pub/patches/:patch \
ftp://ftp.sunsite.auc.dk/disk6/sun-patches/:patch \
@@ -16,15 +16,16 @@ MASTER_SITES= ftp://ftp.sun.co.uk/pub/patches/:patch \
ftp://ftp.cs.tu-berlin.de/pub/sun/sun-fixes/.../:patch
DISTNAME= so-7-ga-bin-linux-en.bin
.if !defined(USE_CDROM)
-DISTFILES= so-7-ga-bin-linux-en.bin 116518-03.tar:patch
+DISTFILES= so-7-ga-bin-linux-en.bin 116518-04.zip:patch
.else
-DISTFILES= 116518-03.tar:patch
+DISTFILES= 116518-04.zip:patch
.endif
.if defined(WITH_ADABAS)
DISTFILES+= soa-7-ga-bin-linux-en.bin
.endif
-EXTRACT_ONLY= 116518-03.tar
+USE_ZIP= YES
+EXTRACT_ONLY= 116518-04.zip
MAINTAINER= mbr@FreeBSD.org
COMMENT= Wordprocessor/dbase/spreadheet/drawing/chart
@@ -42,7 +43,7 @@ LD_PATH= ${TMPDIR}:${WRKSRC}:${LINUXBASE}/lib:${LINUXBASE}/usr/lib
INSTDB.INS= ${PREFIX}/${SOVERSION}/program/instdb.ins
SUNSOLVE= ${WRKDIR}/112887-04
ADABAS_DIST= soa-7-ga-bin-linux-en.bin
-PATCH_DIST= so-7-pp2-bin-linux.bin
+PATCH_DIST= so-7-pp3-bin-linux.bin
.include <bsd.port.pre.mk>
@@ -119,7 +120,7 @@ pre-fetch:
@${FALSE}
.endif
.if defined(USE_CDROM)
-DLTEST=116518-03.tar
+DLTEST=116518-04.zip
.else
.if exists(/cdrom/linux/office7/setup)
@${ECHO}
@@ -252,7 +253,7 @@ install-patch:
${WRKSRC}/patchsetup.resp
@-SAL_IGNOREXERRORS=1 PATH="/bin:${PATH}" LD_LIBRARY_PATH=${LD_PATH} \
TEMP=${TMPDIR} ${LINUXBASE}/bin/sh -c 'umask 022 && \
- ${WRKSRC}/../116518-03/${PATCH_DIST} -patch:${PREFIX}/${SOVERSION}\
+ ${WRKSRC}/../116518-04/${PATCH_DIST} -patch:${PREFIX}/${SOVERSION}\
-r:${WRKSRC}/patchsetup.resp'
install-update: