aboutsummaryrefslogtreecommitdiff
path: root/editors/sted/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-08-08 08:07:22 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-08-08 08:07:22 +0000
commit1e83f4f9ce1053a682845732664ce34adfca0639 (patch)
treec7a2c0caae0b6a89fb60b58ba68c46b86144d20a /editors/sted/Makefile
parentb7698fc60b943a220b9ae0185a79905185299fae (diff)
Notes
Diffstat (limited to 'editors/sted/Makefile')
-rw-r--r--editors/sted/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/editors/sted/Makefile b/editors/sted/Makefile
index 6d6ddcd5293a..6e4b451ca635 100644
--- a/editors/sted/Makefile
+++ b/editors/sted/Makefile
@@ -20,9 +20,15 @@ MAN1= sted.1
PORTDOCS= CHANGES COPYING README
PLIST_FILES= bin/sted
+post-patch:
+ @${REINPLACE_CMD} -e "s|CC = gcc|CC ?= gcc|" \
+ -e "s|C_OPTS = -Wall -O2|C_OPTS = ${CFLAGS}|" \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} "s|<curses.h>|<ncurses.h>|" ${WRKSRC}/sted.c
+
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/sted ${PREFIX}/bin
- @ ${INSTALL_MAN} ${WRKSRC}/sted.1 ${PREFIX}/man/man1
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/sted ${TARGETDIR}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/sted.1 ${TARGETDIR}/man/man1
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}