aboutsummaryrefslogtreecommitdiff
path: root/editors/sted
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-07-03 23:44:56 +0000
committerSteve Price <steve@FreeBSD.org>1998-07-03 23:44:56 +0000
commit591307035ffc77c77916e02a4ba46b9731cde0e0 (patch)
tree74ce2c812031459b68f19e8dc9cc187102060078 /editors/sted
parent74d96100ede3a93bd4c9fe074ad76092fda0c2a2 (diff)
downloadports-591307035ffc77c77916e02a4ba46b9731cde0e0.tar.gz
ports-591307035ffc77c77916e02a4ba46b9731cde0e0.zip
sted - A small text editor.
PR: 7037 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=11698
Diffstat (limited to 'editors/sted')
-rw-r--r--editors/sted/Makefile29
-rw-r--r--editors/sted/distinfo1
-rw-r--r--editors/sted/files/patch-aa15
-rw-r--r--editors/sted/files/patch-ab11
-rw-r--r--editors/sted/pkg-comment1
-rw-r--r--editors/sted/pkg-descr5
-rw-r--r--editors/sted/pkg-plist6
7 files changed, 68 insertions, 0 deletions
diff --git a/editors/sted/Makefile b/editors/sted/Makefile
new file mode 100644
index 000000000000..472d54b6811c
--- /dev/null
+++ b/editors/sted/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: sted
+# Version required: 0.2.2
+# Date created: 19 May 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= sted-0.2.2
+CATEGORIES= editors
+MASTER_SITES= http://user.tninet.se/~uxm165t/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+WRKSRC= ${WRKDIR}/sted
+
+MAN1= sted.1
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/sted ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/sted.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/sted
+.for file in CHANGES COPYING README
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/sted
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/editors/sted/distinfo b/editors/sted/distinfo
new file mode 100644
index 000000000000..f8690d6487a4
--- /dev/null
+++ b/editors/sted/distinfo
@@ -0,0 +1 @@
+MD5 (sted-0.2.2.tar.gz) = d16597d6ce5f723227a92b3cc99d8e9b
diff --git a/editors/sted/files/patch-aa b/editors/sted/files/patch-aa
new file mode 100644
index 000000000000..6f5d5c513a65
--- /dev/null
+++ b/editors/sted/files/patch-aa
@@ -0,0 +1,15 @@
+--- Makefile Sun May 17 13:09:10 1998
++++ /home/andy/tmp/wrk/Makefile Tue May 19 10:42:14 1998
+@@ -5,10 +5,10 @@
+
+
+ #Compiler, change if you're using some other compiler
+-CC = gcc
++#CC = gcc
+
+ #Compiler and linker options
+-C_OPTS = -Wall -O2
++C_OPTS = ${CFLAGS}
+ L_OPTS = -lncurses
+
+ #Install directory
diff --git a/editors/sted/files/patch-ab b/editors/sted/files/patch-ab
new file mode 100644
index 000000000000..38b5dff8612f
--- /dev/null
+++ b/editors/sted/files/patch-ab
@@ -0,0 +1,11 @@
+--- sted.c Sun May 17 13:15:08 1998
++++ /home/andy/tmp/wrk/sted.c Tue May 19 10:42:21 1998
+@@ -34,7 +34,7 @@
+ **************************************************************************/
+
+
+-#include <curses.h>
++#include <ncurses.h>
+ #include <signal.h>
+ #include <string.h>
+ #include <stdlib.h>
diff --git a/editors/sted/pkg-comment b/editors/sted/pkg-comment
new file mode 100644
index 000000000000..f0cbfbab7c4d
--- /dev/null
+++ b/editors/sted/pkg-comment
@@ -0,0 +1 @@
+Simple/Small/Stupid Text Editor.
diff --git a/editors/sted/pkg-descr b/editors/sted/pkg-descr
new file mode 100644
index 000000000000..ae8c62a28c1b
--- /dev/null
+++ b/editors/sted/pkg-descr
@@ -0,0 +1,5 @@
+sted, which is an abbreviation for Small/Stupid (you choose) Text
+Editor, is a small and/or stupid text editor. So far it doesn't do
+much. You can edit files, load them and save them.
+
+http://user.tninet.se/~uxm165t/sted.html
diff --git a/editors/sted/pkg-plist b/editors/sted/pkg-plist
new file mode 100644
index 000000000000..d6be8cdba159
--- /dev/null
+++ b/editors/sted/pkg-plist
@@ -0,0 +1,6 @@
+bin/sted
+man/man1/sted.1.gz
+share/doc/sted/CHANGES
+share/doc/sted/COPYING
+share/doc/sted/README
+@dirrm share/doc/sted