aboutsummaryrefslogtreecommitdiff
path: root/editors/tamago
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2019-02-19 00:41:17 +0000
committerHiroki Sato <hrs@FreeBSD.org>2019-02-19 00:41:17 +0000
commita8df24dc58f1b18b74cfad66f39c07ad488ef2b9 (patch)
treeb7a1342df4636c7adad39ff3644fb9b3aa9dc5b7 /editors/tamago
parentcb1089bee66f832973370d4cfa2a9fc8c1831307 (diff)
downloadports-a8df24dc58f1b18b74cfad66f39c07ad488ef2b9.tar.gz
ports-a8df24dc58f1b18b74cfad66f39c07ad488ef2b9.zip
Notes
Diffstat (limited to 'editors/tamago')
-rw-r--r--editors/tamago/Makefile5
-rw-r--r--editors/tamago/files/patch-Makefile.in15
-rw-r--r--editors/tamago/files/patch-egg-Makefile.in15
-rw-r--r--editors/tamago/files/patch-its-Makefile.in15
4 files changed, 45 insertions, 5 deletions
diff --git a/editors/tamago/Makefile b/editors/tamago/Makefile
index dfe8d08f87dd..64bb067b13c5 100644
--- a/editors/tamago/Makefile
+++ b/editors/tamago/Makefile
@@ -13,11 +13,6 @@ COMMENT= Egg V4, Multilingual Input Method for Emacsen
LICENSE= GPLv2
-.if ${FLAVOR:U} != devel
-# http://pkg.awarnach.mathstat.dal.ca/data/11i386-default/2018-05-30_07h36m11s/logs/errors/tamago-emacs26-4.0.6.0.20041122.19.14_4.log
-BROKEN= fails to build
-.endif
-
USES= emacs
EMACS_FLAVORS_EXCLUDE= devel_full # fails to build
USE_GITHUB= yes
diff --git a/editors/tamago/files/patch-Makefile.in b/editors/tamago/files/patch-Makefile.in
new file mode 100644
index 000000000000..666ae26c41a5
--- /dev/null
+++ b/editors/tamago/files/patch-Makefile.in
@@ -0,0 +1,15 @@
+--- Makefile.in.orig 2016-05-15 21:22:18 UTC
++++ Makefile.in
+@@ -423,8 +423,11 @@ distclean-hdr:
+ $(EMACS) --batch \
+ $(AM_ELCFLAGS) $(ELCFLAGS) \
+ $$am__subdir_includes -L $(builddir) -L $(srcdir) \
+- --eval "(defun byte-compile-dest-file (f) \"$@\")" \
++ --eval "(defun byte-compile-dest-file (f) \"/tmp/$@\")" \
+ --eval "(unless (byte-compile-file \"$<\") (kill-emacs 1))"; \
++ if [ -f "/tmp/$@" ]; then \
++ cp /tmp/$@ $@ && rm -f /tmp/$@; \
++ fi; \
+ else :; fi
+
+ install-dist_lispLISP: $(dist_lisp_LISP) $(ELCFILES)
diff --git a/editors/tamago/files/patch-egg-Makefile.in b/editors/tamago/files/patch-egg-Makefile.in
new file mode 100644
index 000000000000..5f24565559c4
--- /dev/null
+++ b/editors/tamago/files/patch-egg-Makefile.in
@@ -0,0 +1,15 @@
+--- egg/Makefile.in.orig 2016-05-15 21:22:18 UTC
++++ egg/Makefile.in
+@@ -322,8 +322,11 @@ $(am__aclocal_m4_deps):
+ $(EMACS) --batch \
+ $(AM_ELCFLAGS) $(ELCFLAGS) \
+ $$am__subdir_includes -L $(builddir) -L $(srcdir) \
+- --eval "(defun byte-compile-dest-file (f) \"$@\")" \
++ --eval "(defun byte-compile-dest-file (f) \"/tmp/$@\")" \
+ --eval "(unless (byte-compile-file \"$<\") (kill-emacs 1))"; \
++ if [ -f "/tmp/$@" ]; then \
++ cp /tmp/$@ $@ && rm -f /tmp/$@; \
++ fi; \
+ else :; fi
+
+ install-dist_lispLISP: $(dist_lisp_LISP) $(ELCFILES)
diff --git a/editors/tamago/files/patch-its-Makefile.in b/editors/tamago/files/patch-its-Makefile.in
new file mode 100644
index 000000000000..d92978653283
--- /dev/null
+++ b/editors/tamago/files/patch-its-Makefile.in
@@ -0,0 +1,15 @@
+--- its/Makefile.in.orig 2016-05-15 21:22:18 UTC
++++ its/Makefile.in
+@@ -336,8 +336,11 @@ $(am__aclocal_m4_deps):
+ $(EMACS) --batch \
+ $(AM_ELCFLAGS) $(ELCFLAGS) \
+ $$am__subdir_includes -L $(builddir) -L $(srcdir) \
+- --eval "(defun byte-compile-dest-file (f) \"$@\")" \
++ --eval "(defun byte-compile-dest-file (f) \"/tmp/$@\")" \
+ --eval "(unless (byte-compile-file \"$<\") (kill-emacs 1))"; \
++ if [ -f "/tmp/$@" ]; then \
++ cp /tmp/$@ $@ && rm -f /tmp/$@; \
++ fi; \
+ else :; fi
+
+ install-dist_lispLISP: $(dist_lisp_LISP) $(ELCFILES)