aboutsummaryrefslogtreecommitdiff
path: root/editors/tamago
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-31 15:39:55 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-31 15:39:55 +0000
commit384042a3be3db9e0818e3195e101e53c9b8d8081 (patch)
tree7d5b9cafb698793dd40fe9b6f2ca1cfb39f7754e /editors/tamago
parent4eff3c82e58859249bedc49803397a668a11d5ab (diff)
downloadports-384042a3be3db9e0818e3195e101e53c9b8d8081.tar.gz
ports-384042a3be3db9e0818e3195e101e53c9b8d8081.zip
Unbreak by completing staging.
Notes
Notes: svn path=/head/; revision=366783
Diffstat (limited to 'editors/tamago')
-rw-r--r--editors/tamago/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/editors/tamago/Makefile b/editors/tamago/Makefile
index 04f24443a614..ab3ded92a0d2 100644
--- a/editors/tamago/Makefile
+++ b/editors/tamago/Makefile
@@ -41,23 +41,27 @@ PLIST_SUB+= HAS_JISX0213=""
PLIST_SUB+= HAS_JISX0213="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/^lispdir/s|@lispdir@|${STAGEDIR}&|' \
+ -e 's|mkdir|${MKDIR}|' \
+ ${WRKSRC}/Makefile.in
+
pre-configure:
@${REINPLACE_CMD} -e 's|emacs/site-lisp|${EMACS_NAME}/${EMACS_VER}/site-lisp|g' \
${WRKSRC}/configure
post-build:
- cd ${WRKSRC}/helper && \
+ (cd ${WRKSRC}/helper && \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
- ${_MAKE_JOBS} ${MAKE_ARGS} egg-helper
+ ${_MAKE_JOBS} ${MAKE_ARGS} egg-helper)
${INSTALL_DATA} ${WRKSRC}/debian/changelog ${WRKSRC}/changelog.Debian
${INSTALL_DATA} ${WRKSRC}/debian/README.Debian ${WRKSRC}
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/helper/egg-helper \
${STAGEDIR}${PREFIX}/bin/egg-helper
-.if ${PORT_OPTIONS:MDOCS}
+
${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.endif
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.post.mk>