aboutsummaryrefslogtreecommitdiff
path: root/editors/tea/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2008-03-14 05:23:32 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2008-03-14 05:23:32 +0000
commit785cd49df53f87b11ee81c52c93efbb55401bb98 (patch)
tree8225ca084ef703ce21880f6101e6a112d9e0ccbb /editors/tea/Makefile
parent08b7c02eaf446297acdaaf295cca55844810c248 (diff)
Notes
Diffstat (limited to 'editors/tea/Makefile')
-rw-r--r--editors/tea/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index bc58e0a0acbf..0c93624b5f01 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tea
-DISTVERSION= 17.5.4
+DISTVERSION= 17.6.0
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tea-editor
@@ -22,7 +22,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
OPTIONS= TEA_ONLY "Build original GTK-only version" on \
- ASPELL "Build with GNU aspell support" on
+ ASPELL "Build with GNU aspell support" on \
+ CURL "Build with libCURL support" off
.include <bsd.port.pre.mk>
@@ -32,10 +33,14 @@ CONFIGURE_ARGS+= --enable-legacy
USE_GNOME+= gtksourceview
.endif
-.if defined(WITH_ASPELL)
+.if defined(WITH_ASPELL) || exists(${LOCALBASE}/lib/libaspell.so)
LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
.endif
+.if defined(WITH_CURL) || exists(${LOCALBASE}/lib/libcurl.so)
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+.endif
+
post-patch: .SILENT
# Correct documentation location in FreeBSD world
${REINPLACE_CMD} -e 's|/tea/doc/|/doc/tea/|' \