aboutsummaryrefslogtreecommitdiff
path: root/editors/tea/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-17 07:59:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-17 07:59:33 +0000
commitd34eeb233a01700d6badcdea4715d85e775a43a7 (patch)
tree4660b4781bcf776e1b6416550c024daf2a6deaaf /editors/tea/Makefile
parentc9a8043cbb57e27c094fb20603a47ec3583f1e89 (diff)
downloadports-d34eeb233a01700d6badcdea4715d85e775a43a7.tar.gz
ports-d34eeb233a01700d6badcdea4715d85e775a43a7.zip
Notes
Diffstat (limited to 'editors/tea/Makefile')
-rw-r--r--editors/tea/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index 4fc62189f0ac..55b72522fb7f 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tea
-PORTVERSION= 0.9.1
+PORTVERSION= 2.0
CATEGORIES= editors
MASTER_SITES= http://tea.linux.kiev.ua/
DISTNAME= ${PORTNAME}
@@ -18,18 +18,16 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_X_PREFIX= yes
USE_BZIP2= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GCC= 3.3
USE_GNOME= gtk20
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.if !defined(NOPORTDOCS)
-post-install:
- ${MKDIR} ${DOCSDIR}/en
- ${MKDIR} ${DOCSDIR}/ru
- ${INSTALL_DATA} ${WRKSRC}/doc/EN/index.html ${DOCSDIR}/en
- ${INSTALL_DATA} ${WRKSRC}/doc/RU/index.html ${DOCSDIR}/ru
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/doc/tea|${DOCSDIR}|g' \
+ ${WRKSRC}/Makefile.in \
+ ${WRKSRC}/src/tea_funx.c
.include <bsd.port.mk>