aboutsummaryrefslogtreecommitdiff
path: root/editors/tea/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-13 16:10:46 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-13 16:10:46 +0000
commit5aacd41110b9bcda291fba346f28c97d2cf20614 (patch)
treea1a5ab998329853f5b9272ea7f90cde118a65229 /editors/tea/Makefile
parent98ec693f717acd68f67bc0537e8c13096beace54 (diff)
downloadports-5aacd41110b9bcda291fba346f28c97d2cf20614.tar.gz
ports-5aacd41110b9bcda291fba346f28c97d2cf20614.zip
Notes
Diffstat (limited to 'editors/tea/Makefile')
-rw-r--r--editors/tea/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
new file mode 100644
index 000000000000..4fc62189f0ac
--- /dev/null
+++ b/editors/tea/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: TEA
+# Date created: 13 Jul 2004
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tea
+PORTVERSION= 0.9.1
+CATEGORIES= editors
+MASTER_SITES= http://tea.linux.kiev.ua/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A simple GTK+ text editor
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GCC= 3.3
+USE_GNOME= gtk20
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}/en
+ ${MKDIR} ${DOCSDIR}/ru
+ ${INSTALL_DATA} ${WRKSRC}/doc/EN/index.html ${DOCSDIR}/en
+ ${INSTALL_DATA} ${WRKSRC}/doc/RU/index.html ${DOCSDIR}/ru
+.endif
+
+.include <bsd.port.mk>