aboutsummaryrefslogtreecommitdiff
path: root/editors/tea/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2016-10-19 02:28:05 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2016-10-19 02:28:05 +0000
commit21cc7d30b21fd00374078a8c46086702e44bdd78 (patch)
tree3e7ad65d0d207d46cb3235bbc6ccd3cab4c35315 /editors/tea/Makefile
parent23565463ac7b5063ba3a3ea0673443e33bcaaf69 (diff)
- Update to 43.1.0
- Fix hunspell/aspell enable/disable - Using LANG variable to handle paths with non ASCII bytes during build process
Notes
Notes: svn path=/head/; revision=424224
Diffstat (limited to 'editors/tea/Makefile')
-rw-r--r--editors/tea/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index f72d20c4ae5e..f96a35ff44dc 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tea
-PORTVERSION= 42.0.0
+PORTVERSION= 43.1.0
CATEGORIES= editors
MASTER_SITES= http://semiletov.org/tea/dloads/
@@ -17,8 +17,12 @@ OPTIONS_RADIO_SPELL= ASPELL HUNSPELL
OPTIONS_DEFAULT= ASPELL
USES= pkgconfig:build qmake tar:bzip2
+USE_GL= gl
USE_QT4= corelib gui moc_build network rcc_build
+LDFLAGS+= -lz
+MAKE_ENV+= LANG=en_US.UTF-8
+CONFIGURE_ENV+= LANG=en_US.UTF-8
PLIST_FILES= bin/tea share/pixmaps/tea_icon_v2.png
PORTDOCS= *
@@ -26,10 +30,10 @@ DESKTOP_ENTRIES="TEA" "" "${PREFIX}/share/pixmaps/tea_icon_v2.png" \
"${PORTNAME}" "" ""
ASPELL_LIB_DEPENDS= libaspell.so:textproc/aspell
-ASPELL_QMAKE_ON= CONFIG=nohunspell
+ASPELL_QMAKE_ON= CONFIG+=nohunspell
HUNSPELL_LIB_DEPENDS= libhunspell-1.3.so:textproc/hunspell
-HUNSPELL_QMAKE_ON= CONFIG=noaspell
+HUNSPELL_QMAKE_ON= CONFIG+=noaspell
post-patch:
@${REINPLACE_CMD} -e \