aboutsummaryrefslogtreecommitdiff
path: root/editors/ted
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-03 16:25:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-03 16:25:46 +0000
commitb796cb947d03ea6b7c930ea28770795f83be65f6 (patch)
treeb13218e37326dc7684c44eecaf4570921d9d3f25 /editors/ted
parentb9006ba275b3eab813649be0f16229c195bb3438 (diff)
downloadports-b796cb947d03ea6b7c930ea28770795f83be65f6.tar.gz
ports-b796cb947d03ea6b7c930ea28770795f83be65f6.zip
Notes
Diffstat (limited to 'editors/ted')
-rw-r--r--editors/ted/Makefile27
-rw-r--r--editors/ted/distinfo4
-rw-r--r--editors/ted/files/patch-Ted__makefile.in12
-rw-r--r--editors/ted/files/patch-bitmap-bmpng.c10
-rw-r--r--editors/ted/pkg-plist2
5 files changed, 30 insertions, 25 deletions
diff --git a/editors/ted/Makefile b/editors/ted/Makefile
index f12438f94170..bdef16142df0 100644
--- a/editors/ted/Makefile
+++ b/editors/ted/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ted
-PORTVERSION= 2.21
-PORTREVISION= 4
+PORTVERSION= 2.22
CATEGORIES= editors
MASTER_SITES= ftp://ftp.nluug.nl/pub/editors/ted/
EXTRACT_SUFX= .src.tar.gz
@@ -15,24 +14,28 @@ EXTRACT_SUFX= .src.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= X11 based RTF editor
+LICENSE= GPLv2
+
LIB_DEPENDS= pcre.1:${PORTSDIR}/devel/pcre \
png.6:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ paper.2:${PORTSDIR}/print/libpaper
RUN_DEPENDS= ${LOCALBASE}/share/ghostscript/fonts/a010013l.pfb:${PORTSDIR}/print/gsfonts
+OPTIONS= GTK "Use Gtk+ user intarface" off
+
WRKSRC= ${WRKDIR}/Ted-${PORTVERSION}
-USE_MOTIF= yes
USE_XORG= xext xft
USE_ICONV= yes
USE_GHOSTSCRIPT_RUN= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-MOTIF
MAKE_ENV= DEF_AFMDIR="-DAFMDIR=\"\\\"${AFMDIR}/\\\"\"" \
DEF_INDDIR="-DINDDIR=\"\\\"${INDDIR}/\\\"\"" \
DEF_DOCUMENT_DIR="-DDOCUMENT_DIR=\"\\\"${DOCSDIR}/\\\"\"" \
DEF_PSSCRIPT_DIR="-DPSSCRIPT_DIR=\"\\\"${DATADIR}/\\\"\""
ALL_TARGET= compile.shared
+MAKE_JOBS_SAFE= yes
MAN1= Ted.1 rtf2pdf.1 rtf2ps.1
@@ -42,6 +45,16 @@ DOCSDIR= ${PREFIX}/share/doc/Ted
AFMDIR= ${DATADIR}/afm
INDDIR= ${DATADIR}/dfa
+.include <bsd.port.options.mk>
+
+.if defined(WITH_GTK)
+USE_GNOME= gtk20
+CONFIGURE_ARGS+=--with-GTK
+.else
+USE_MOTIF= yes
+CONFIGURE_ARGS+=--with-MOTIF
+.endif
+
post-extract:
@cd ${WRKSRC}/tedPackage && ${TAR} xf TedBindist.tar
@${INSTALL_SCRIPT} ${FILESDIR}/configure ${WRKSRC}
@@ -51,9 +64,9 @@ post-patch:
${REINPLACE_CMD} -e \
's|/usr/X11R6|${LOCALBASE}|g ; \
s|/usr/local|${LOCALBASE}|g ; \
+ /paper.h/s|/usr/include|${LOCALBASE}/include|g ; \
+ /paper.h/s|/usr/lib|${LOCALBASE}/lib|g ; \
s|/iconv.so|/libiconv.so|g'
- @${REINPLACE_CMD} -e \
- 's|<malloc\.h>|<stdlib.h>|g' ${WRKSRC}/appUtil/csvsheet.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/Ted/Ted ${PREFIX}/bin
diff --git a/editors/ted/distinfo b/editors/ted/distinfo
index 9eb6c32bd347..48a8a470ad7e 100644
--- a/editors/ted/distinfo
+++ b/editors/ted/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ted-2.21.src.tar.gz) = 6c4bdebb8980fac00cf71ebc6c5f9bddee8ae13ab2327125dda95aa6948b363a
-SIZE (ted-2.21.src.tar.gz) = 3956815
+SHA256 (ted-2.22.src.tar.gz) = 93040d5ff259dbf7707a97f8c1ab4a7c1ec8adae63d35760e20dd6f60520fa4a
+SIZE (ted-2.22.src.tar.gz) = 4267772
diff --git a/editors/ted/files/patch-Ted__makefile.in b/editors/ted/files/patch-Ted__makefile.in
index 543fb0716c7a..b141ff6cdf29 100644
--- a/editors/ted/files/patch-Ted__makefile.in
+++ b/editors/ted/files/patch-Ted__makefile.in
@@ -1,9 +1,9 @@
---- Ted/makefile.in.orig 2009-06-10 14:41:19.000000000 +0900
-+++ Ted/makefile.in 2009-06-26 01:00:56.000000000 +0900
-@@ -42,7 +42,8 @@
- -I../bitmap \
- -I../ind \
- -I../include \
+--- Ted/makefile.in.orig 2012-04-01 18:57:26.000000000 +0900
++++ Ted/makefile.in 2012-04-09 20:45:17.000000000 +0900
+@@ -56,7 +56,8 @@
+ -I../bitmap \
+ -I../ind \
+ -I../include \
- $(DEF_PKGDIR)
+ $(DEF_DOCUMENT_DIR) \
+ $(DEF_PSSCRIPT_DIR)
diff --git a/editors/ted/files/patch-bitmap-bmpng.c b/editors/ted/files/patch-bitmap-bmpng.c
deleted file mode 100644
index 5e00c3adbad6..000000000000
--- a/editors/ted/files/patch-bitmap-bmpng.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- bitmap/bmpng.c.orig 2009-10-16 17:20:57.000000000 +0200
-+++ bitmap/bmpng.c 2010-03-29 21:20:37.000000000 +0200
-@@ -284,7 +284,6 @@
- png_info * pngi,
- const BitmapDescription * bd )
- {
-- png_info_init( pngi );
- pngi->width= bd->bdPixelsWide;
- pngi->height= bd->bdPixelsHigh;
-
diff --git a/editors/ted/pkg-plist b/editors/ted/pkg-plist
index 23db473d0ead..7ff4f5a7cc73 100644
--- a/editors/ted/pkg-plist
+++ b/editors/ted/pkg-plist
@@ -2,6 +2,8 @@ bin/Ted
bin/rtf2pdf.sh
bin/rtf2ps.sh
bin/rtf2txt.sh
+bin/rtf2epub.sh
+bin/rtf2html.sh
%%DATADIR%%/afm/AvantGarde-Book.afm
%%DATADIR%%/afm/AvantGarde-BookOblique.afm
%%DATADIR%%/afm/AvantGarde-Demi.afm