aboutsummaryrefslogtreecommitdiff
path: root/editors/texmaker/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-29 08:04:10 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-29 08:04:10 +0000
commit4fc9e4735675055e7060d512797f5da5ad687a94 (patch)
treeaad3ccb025a1df107510256c698525a93766bb76 /editors/texmaker/Makefile
parent6202905164973076ca9470dfb7d17b96e93b4bf5 (diff)
downloadports-4fc9e4735675055e7060d512797f5da5ad687a94.tar.gz
ports-4fc9e4735675055e7060d512797f5da5ad687a94.zip
Notes
Diffstat (limited to 'editors/texmaker/Makefile')
-rw-r--r--editors/texmaker/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
new file mode 100644
index 000000000000..34e13c024406
--- /dev/null
+++ b/editors/texmaker/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: texmaker
+# Date created: Dec 29, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= texmaker
+PORTVERSION= 1.0
+CATEGORIES= editors
+MASTER_SITES= http://perso.club-internet.fr/pascal.brachet/texmaker/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= LaTeX Development Environment
+
+USE_BZIP2= yes
+USE_QT_VER= 3
+
+do-build:
+ @cd ${WRKSRC} && \
+ qmake -makefile -unix "LIBS+=-lm -lqt-mt" texmaker.pro && \
+ ${SETENV} QTDIR=${X11BASE} make
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/texmaker ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>