aboutsummaryrefslogtreecommitdiff
path: root/editors/texstudio
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /editors/texstudio
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'editors/texstudio')
-rw-r--r--editors/texstudio/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index cd064ec3fa28..dca46126907f 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -20,20 +20,22 @@ FLAVORS= qt5 qt4
FLAVOR?= ${FLAVORS:[1]}
qt4_LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4 \
- libquazip.so:archivers/quazip@qt4
+ libquazip.so:archivers/quazip@qt4
qt5_LIB_DEPENDS= libpoppler-qt5.so:graphics/poppler-qt5 \
- libquazip5.so:archivers/quazip@qt5
+ libquazip5.so:archivers/quazip@qt5
USES= desktop-file-utils dos2unix ghostscript:run \
pkgconfig qmake
.if ${FLAVOR} == qt4
-USE_QT4= corelib gui network script svg xml \
+USES+= qt:4
+USE_QT= corelib gui network script svg xml \
iconengines_run designer_build moc_build rcc_build uic_build
QMAKE_ARGS= QUAZIP_INCLUDE="${LOCALBASE}/include/quazip" \
QUAZIP_LIB="-lquazip"
.else
-USE_QT5= core gui network script svg widgets xml \
+USES+= qt:5
+USE_QT = core gui network script svg widgets xml \
printsupport concurrent uitools buildtools_build
QMAKE_ARGS= QUAZIP_INCLUDE="${LOCALBASE}/include/quazip5" \
QUAZIP_LIB="-lquazip5"