aboutsummaryrefslogtreecommitdiff
path: root/editors/texworks
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2009-10-14 18:23:18 +0000
committerDavid Thiel <lx@FreeBSD.org>2009-10-14 18:23:18 +0000
commitca96306573c9d8df763a7a3fdf90e951a2d84246 (patch)
tree6ffc2a015a543294d86040fb9021bd3a4bb215a8 /editors/texworks
parent68f701b3a1463c0cc430b742742f88fa393d8cef (diff)
downloadports-ca96306573c9d8df763a7a3fdf90e951a2d84246.tar.gz
ports-ca96306573c9d8df763a7a3fdf90e951a2d84246.zip
Notes
Diffstat (limited to 'editors/texworks')
-rw-r--r--editors/texworks/Makefile47
-rw-r--r--editors/texworks/distinfo3
-rw-r--r--editors/texworks/pkg-descr4
3 files changed, 54 insertions, 0 deletions
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
new file mode 100644
index 000000000000..76c437f5d335
--- /dev/null
+++ b/editors/texworks/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: texworks
+# Date created: 2009-09-30
+# Whom: Diego DepaolI <trebestie@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= texworks
+PORTVERSION= 0.2
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= trebestie@gmail.com
+COMMENT= A simple TeX front-end program
+
+BUILD_DEPENDS= hunspell:${PORTSDIR}/hungarian/hunspell
+LIB_DEPENDS= poppler-qt4:${PORTSDIR}/graphics/poppler-qt4 \
+ dbus:${PORTSDIR}/devel/dbus
+
+USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build gui corelib rcc_build moc_build uic_build \
+ dbus xml
+
+MAKE_ENV+= QTDIR=${QT_PREFIX}
+
+DESKTOP_ENTRIES="TexWorks" \
+ "Lowering the entry barrier to the TeX world" \
+ "TeXworks.png" \
+ "texworks" \
+ "Application;Utility;" \
+ false
+PLIST_FILES= bin/texworks \
+ share/pixmaps/TeXworks.png
+
+post-patch:
+ @${RM} -f ${WRKSRC}/ui_*.h ${WRKSRC}/moc_*.cpp ${WRKSRC}/qrc_*.cpp
+ @${REINPLACE_CMD} -e 's|\/usr\/share|\${LOCALBASE}\/share|g' ${WRKSRC}/src/TWUtils.cpp
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${QMAKESPEC} TeXworks.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/texworks ${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/res/images/TeXworks.png ${PREFIX}/share/pixmaps/TeXworks.png
+.include <bsd.port.mk>
diff --git a/editors/texworks/distinfo b/editors/texworks/distinfo
new file mode 100644
index 000000000000..6fc6b5506460
--- /dev/null
+++ b/editors/texworks/distinfo
@@ -0,0 +1,3 @@
+MD5 (texworks-0.2.tar.gz) = 8d21dc7ee85e8c77a97bf39212510fed
+SHA256 (texworks-0.2.tar.gz) = eb3ebdb2d671459a5df59e42f4243a64e9cbf6194ab63172737dafaca4e8b37e
+SIZE (texworks-0.2.tar.gz) = 1899406
diff --git a/editors/texworks/pkg-descr b/editors/texworks/pkg-descr
new file mode 100644
index 000000000000..3a4d49bf5c3c
--- /dev/null
+++ b/editors/texworks/pkg-descr
@@ -0,0 +1,4 @@
+The TeXworkS project is an effort to build a simple
+TeX like TeXShop for Mac OS X.
+
+WWW: http://www.tug.org/texworks/