aboutsummaryrefslogtreecommitdiff
path: root/editors/the
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 10:34:46 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 10:34:46 +0000
commitf3381fa548d3edd4687bf4cf975577eeb10d68b7 (patch)
treea607b9b0948608d5c47edc8a47b7a82c47b30717 /editors/the
parent67375d16b1d5928bed929dcddfd6dcf003678869 (diff)
downloadports-f3381fa548d3edd4687bf4cf975577eeb10d68b7.tar.gz
ports-f3381fa548d3edd4687bf4cf975577eeb10d68b7.zip
Notes
Diffstat (limited to 'editors/the')
-rw-r--r--editors/the/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/editors/the/Makefile b/editors/the/Makefile
index 90a06be8a715..234c654a5192 100644
--- a/editors/the/Makefile
+++ b/editors/the/Makefile
@@ -27,8 +27,10 @@ ALL_TARGET= all html
MAN1= the.1
-OPTIONS= XAW3D "Enable Xaw3D" off \
- XCURSES "Build XCurses (X11) version" off
+OPTIONS_DEFINE= XAW3D XCURSES REXX_REGINA DOCS
+XAW3D_DESC= Enable Xaw3D
+XCURSES_DESC= Build XCurses (X11) version
+REXX_REGINA_DESC= Enable Rexx interpreter
.include <bsd.port.pre.mk>
@@ -36,12 +38,12 @@ OPTIONS= XAW3D "Enable Xaw3D" off \
BROKEN= Does not configure on powerpc
.endif
-.if defined(WITH_XAW3D)
+.if ${PORT_OPTIONS:MXAW3D}
CONFIGURE_ARGS+=--with-xaw3d
LIB_DEPENDS+= Xaw3d.8:${PORTSDIR}/x11-toolkits/Xaw3d
.endif
-.if defined(WITH_XCURSES)
+.if ${PORT_OPTIONS:MXCURSES}
CONFIGURE_ARGS+=--with-xcurses \
--with-cursesincdir=${LOCALBASE}/include \
--with-curseslibdir=${LOCALBASE}/lib
@@ -52,7 +54,7 @@ PLIST_SUB= XCURSES="" NCURSES="@comment "
PLIST_SUB= XCURSES="@comment " NCURSES=""
.endif
-.if defined(WITH_REXX_REGINA)
+.if ${PORT_OPTIONS:MREXX_REGINA}
BUILD_DEPENDS+= regina:${PORTSDIR}/lang/rexx-regina
RUN_DEPENDS+= regina:${PORTSDIR}/lang/rexx-regina
CONFIGURE_ARGS+= --with-rexx=regina
@@ -63,12 +65,12 @@ CONFIGURE_ARGS+= --with-rexx=rexximc
.endif
post-install:
-.if defined(WITH_XCURSES)
+.if ${PORT_OPTIONS:MXCURSES}
@${LN} -sf xthe ${PREFIX}/bin/the
.else
@${LN} -sf nthe ${PREFIX}/bin/the
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${PREFIX}/share/doc/THE
${INSTALL_DATA} ${WRKSRC}/*.html ${PREFIX}/share/doc/THE
.endif