aboutsummaryrefslogtreecommitdiff
path: root/editors/thoteditor
diff options
context:
space:
mode:
authorChuck Robey <chuckr@FreeBSD.org>1999-09-25 18:05:59 +0000
committerChuck Robey <chuckr@FreeBSD.org>1999-09-25 18:05:59 +0000
commit84ce7f54e528f4f2fe95f1b948c919792f7f36a7 (patch)
tree8b0361240d5854ee98d697723456546295c1d804 /editors/thoteditor
parentba98cb2b1f35f369db24491c65719f84bcdebfda (diff)
downloadports-84ce7f54e528f4f2fe95f1b948c919792f7f36a7.tar.gz
ports-84ce7f54e528f4f2fe95f1b948c919792f7f36a7.zip
Notes
Diffstat (limited to 'editors/thoteditor')
-rw-r--r--editors/thoteditor/Makefile20
-rw-r--r--editors/thoteditor/distinfo1
-rw-r--r--editors/thoteditor/files/patch-aa27
-rw-r--r--editors/thoteditor/files/patch-ab24
-rw-r--r--editors/thoteditor/files/patch-ac63
-rw-r--r--editors/thoteditor/files/patch-ad11
-rw-r--r--editors/thoteditor/files/patch-ae19
-rw-r--r--editors/thoteditor/pkg-plist104
8 files changed, 172 insertions, 97 deletions
diff --git a/editors/thoteditor/Makefile b/editors/thoteditor/Makefile
index 4cf4b3d834c6..617bee110237 100644
--- a/editors/thoteditor/Makefile
+++ b/editors/thoteditor/Makefile
@@ -6,8 +6,8 @@
# $FreeBSD$
#
-DISTNAME= thoteditor
-PKGNAME= thoteditor-2.1e
+DISTNAME= thoteditor-src-2.1e
+PKGNAME= thoteditor-2.1
CATEGORIES= editors www
MASTER_SITES= ftp://ftp.inrialpes.fr/pub/opera/sources/thot/ \
${MASTER_SITE_SUNSITE} \
@@ -16,30 +16,24 @@ MASTER_SITES= ftp://ftp.inrialpes.fr/pub/opera/sources/thot/ \
ftp://ftp.netlab.is.tsukuba.ac.jp/pub/editors/opera.inrialpes.fr/sources/thot/ \
ftp://ftp.agix.net/pub/infosystems/www/clients/amaya/thot/
MASTER_SITE_SUBDIR= apps/editors/X/thot
-DISTFILES= ${THOT_SRC} ${EDITOR_SRC}
MAINTAINER= chuckr@FreeBSD.org
-BROKEN= 'FUBARed'
-WRKSRC= $(WRKDIR)/Thot/objects
-
-THOT_SRC= thot-src-2.1e.tar.gz
-EDITOR_SRC= thoteditor-src-2.1e.tar.gz
+THOT_SUBDIR= Target
+REQUIRES_MOTIF= yes
+WRKSRC= $(WRKDIR)/Thot/$(THOT_SUBDIR)
-EXTRACT_ONLY= ${THOT_SRC}
REQUIRES_MOTIF= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
CONFIGURE_ARGS= --with-thot --enable-plugin --without-insure --without-amaya --disable-java --disable-intr --disable-jit --disable-math --disable-ilu
USE_GMAKE= yes
ALL_TARGET= all schemas
do-configure:
- (cd $(WRKDIR)/Thot/objects;../configure $(CONFIGURE_ARGS))
+ (cd $(WRKSRC);../configure $(CONFIGURE_ARGS))
post-extract:
- (${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${EDITOR_SRC} ${EXTRACT_AFTER_ARGS} -C ${WRKDIR}/Thot)
- (cd $(WRKDIR)/Thot;$(MKDIR) objects)
+ (cd $(WRKDIR)/Thot;$(MKDIR) $(THOT_SUBDIR))
post-install:
${MKDIR} ${PREFIX}/share/thot/doc
diff --git a/editors/thoteditor/distinfo b/editors/thoteditor/distinfo
index 6cc3baf507d5..5dff847bd995 100644
--- a/editors/thoteditor/distinfo
+++ b/editors/thoteditor/distinfo
@@ -1,2 +1 @@
-MD5 (thot-src-2.1e.tar.gz) = 846bb18d7c4163ba5427c4509640b96a
MD5 (thoteditor-src-2.1e.tar.gz) = bc2e0ceed36f7e0b85c81229554ca774
diff --git a/editors/thoteditor/files/patch-aa b/editors/thoteditor/files/patch-aa
index 314e6832a051..a79a5de4d766 100644
--- a/editors/thoteditor/files/patch-aa
+++ b/editors/thoteditor/files/patch-aa
@@ -1,24 +1,11 @@
---- ../configure.orig Wed Sep 22 00:01:33 1999
-+++ ../configure Wed Sep 22 00:04:04 1999
-@@ -5261,7 +5261,7 @@
- build_amaya="no"
+--- ../configure.orig Fri Sep 24 20:16:20 1999
++++ ../configure Fri Sep 24 20:17:39 1999
+@@ -5200,7 +5200,7 @@
+ esac
+ fi
fi
+-
++MOTIF_LIBRARIES="$(MOTIFLIB)"
--if test ! -f $srcdir/thot/Makefile.in ; then
-+if test ! -f $srcdir/Thot/Makefile.in ; then
- echo "configure: warning: Thot editor sources not found" 1>&2
- build_thot="no"
- fi
-@@ -5594,10 +5594,10 @@
-
- if test "$build_thot" = "yes" ; then
-- make_output="$make_output thot/Makefile \
-+ make_output="$make_output Thot/Makefile \
- drawlib/Makefile indexlib/Makefile"
- EXTRA_MAKEFILE_IN="$EXTRA_MAKEFILE_IN \
--$srcdir/thot/Makefile.in \
-+$srcdir/Thot/Makefile.in \
- $srcdir/drawlib/Makefile.in \
- $srcdir/indexlib/Makefile.in"
diff --git a/editors/thoteditor/files/patch-ab b/editors/thoteditor/files/patch-ab
new file mode 100644
index 000000000000..03bf5bfd09c5
--- /dev/null
+++ b/editors/thoteditor/files/patch-ab
@@ -0,0 +1,24 @@
+--- ../batch/Makefile.in.orig Sat Sep 25 11:11:53 1999
++++ ../batch/Makefile.in Sat Sep 25 11:26:34 1999
+@@ -202,14 +202,14 @@
+ $(RM) -f *.o dns_daemon
+
+ install : all
+- @(if test ! -d $(datadir) ; then $(MKDIR) $(datadir) ; fi)
+- @(if test ! -d $(datadir)/thot ; then $(MKDIR) $(datadir)/thot ; fi)
+- @(if test ! -d $(datadir)/thot/batch ; then $(MKDIR) $(datadir)/thot/batch ; fi)
+- @(if test ! -d $(datadir)/thot/applis ; then $(MKDIR) $(datadir)/thot/applis ; fi)
+- @(if test ! -d $(datadir)/thot/applis/bin ; then $(MKDIR) $(datadir)/thot/applis/bin ; fi)
+- @(for i in $(COMPILERS) ; do \
++ @(set -x;if test ! -d $(datadir) ; then $(MKDIR) $(datadir) ; fi)
++ @(set -x;if test ! -d $(datadir)/thot ; then $(MKDIR) $(datadir)/thot ; fi)
++ @(set -x;if test ! -d $(datadir)/thot/batch ; then $(MKDIR) $(datadir)/thot/batch ; fi)
++ @(set -x;if test ! -d $(datadir)/thot/applis ; then $(MKDIR) $(datadir)/thot/applis ; fi)
++ @(set -x;if test ! -d $(datadir)/thot/applis/bin ; then $(MKDIR) $(datadir)/thot/applis/bin ; fi)
++ @(set -x;for i in $(COMPILERS) ; do \
+ $(INSTALL_BIN) $$i $(datadir)/thot/applis/bin ; done)
+- (for i in $(LANGUAGES) ; do \
++ @(set -x;for i in $(LANGUAGES) ; do \
+ for file in `$(ECHO) $(THOTDIR)/batch/$$i` ; do \
+ $(INSTALL_DATA) $$file $(datadir)/thot/batch ; \
+ done ; done)
diff --git a/editors/thoteditor/files/patch-ac b/editors/thoteditor/files/patch-ac
index a174d63f9d1c..806f42c965de 100644
--- a/editors/thoteditor/files/patch-ac
+++ b/editors/thoteditor/files/patch-ac
@@ -1,11 +1,52 @@
---- ../makes/Makefile.template.orig Tue May 6 23:55:03 1997
-+++ ../makes/Makefile.template Fri Feb 12 15:06:58 1999
-@@ -56,7 +56,7 @@
- # MOTIFLIBS : how to grab Motif at link time.
- # X11R6 probably need -lSM -lICE
- #
--MOTIFLIBS = -L/usr/X11/lib -lXm -lXt # generic
-+MOTIFLIBS = ${MOTIFLIB} -L/usr/X11/lib -lXt -lXp # generic
- #MOTIFLIBS = -L/usr/X11R6/lib -lXm -lXt -lSM -lICE # Linux
- #MOTIFLIBS = -L/usr/dt/lib -L/usr/openwin/lib -lXm -lXt # Solaris
- #MOTIFLIBS = -L/usr/X11/lib -lXm -lXt # SunOs
+--- ../thot/Makefile.in.orig Wed Nov 19 05:41:49 1997
++++ ../thot/Makefile.in Sat Sep 25 11:53:28 1999
+@@ -54,30 +54,32 @@
+ $(RM) *.o EDITORAPP.c EDITOR.A
+
+ install : all
+- @(if test ! -d $(datadir) ; then $(MKDIR) $(datadir) ; fi)
+- @(if test ! -d $(datadir)/thot ; then $(MKDIR) $(datadir)/thot ; fi)
+- @(if test ! -d $(datadir)/thot/config ; then $(MKDIR) $(datadir)/thot/config ; fi)
+- @(if test ! -d $(datadir)/thot/fonts ; then $(MKDIR) $(datadir)/thot/fonts ; fi)
+- @(if test ! -d $(datadir)/thot/dicopar ; then $(MKDIR) $(datadir)/thot/dicopar ; fi)
+- @(if test ! -d $(datadir)/thot/applis ; then $(MKDIR) $(datadir)/thot/applis ; fi)
+- @(if test ! -d $(datadir)/thot/applis/bin ; then $(MKDIR) $(datadir)/thot/applis/bin ; fi)
+- @(if test ! -d $(datadir)/schemas ; then $(MKDIR) $(datadir)/schemas ; fi)
+- $(INSTALL_BIN) ../bin/thot $(datadir)/thot/applis/bin
+- $(INSTALL_BIN) ../bin/print $(datadir)/thot/applis/bin
+- (for i in $(SCHEMAS) ; do \
++ @(set -x;if test ! -d $(datadir) ; then $(MKDIR) $(datadir) ; fi)
++ @(set -x;if test ! -d $(datadir)/thot ; then $(MKDIR) $(datadir)/thot ; fi)
++ @(set -x;if test ! -d $(datadir)/thot/config ; then $(MKDIR) $(datadir)/thot/config ; fi)
++ @(set -x;if test ! -d $(datadir)/thot/fonts ; then $(MKDIR) $(datadir)/thot/fonts ; fi)
++ @(set -x;if test ! -d $(datadir)/thot/dicopar ; then $(MKDIR) $(datadir)/thot/dicopar ; fi)
++ @(set -x;if test ! -d $(datadir)/thot/applis ; then $(MKDIR) $(datadir)/thot/applis ; fi)
++ @(set -x;if test ! -d $(datadir)/thot/applis/bin ; then $(MKDIR) $(datadir)/thot/applis/bin ; fi)
++ @(set -x;if test ! -d $(datadir)/thot/schemas ; then $(MKDIR) $(datadir)/thot/schemas ; fi)
++ @$(INSTALL_BIN) ../bin/thot $(datadir)/thot/applis/bin
++ @$(INSTALL_BIN) ../bin/print $(datadir)/thot/applis/bin
++ @$(INSTALL_DATA) EDITOR.h $(THOTDIR)/schemas
++ @$(INSTALL_DATA) ExtCss.h $(THOTDIR)/schemas
++ @(set -x;for i in $(SCHEMAS) ; do \
+ for file in `$(ECHO) $(THOTDIR)/schemas/$$i` ; do \
+ $(INSTALL_DATA) $$file $(datadir)/thot/schemas ; \
+ done ; done)
+- (for i in $(CONFIGFILES) ; do \
+- for file in `$(ECHO) $(THOTDIR)/thot/config/$$i` ; do \
++ @(set -x;for i in $(CONFIGFILES) ; do \
++ for file in `$(ECHO) $(THOTDIR)/config/$$i` ; do \
+ $(INSTALL_DATA) $$file $(datadir)/thot/config ; \
+ done ; done)
+- (for i in $(DICOFILES) ; do \
+- for file in `$(ECHO) $(THOTDIR)/thot/dicopar/$$i` ; do \
++ @(set -x;for i in $(DICOFILES) ; do \
++ for file in `$(ECHO) $(THOTDIR)/dicopar/$$i` ; do \
+ $(INSTALL_DATA) $$file $(datadir)/thot/dicopar ; \
+ done ; done)
+- (for i in $(FONTSFILES) ; do \
+- for file in `$(ECHO) $(THOTDIR)/thot/fonts/$$i` ; do \
++ @(set -x;for i in $(FONTSFILES) ; do \
++ for file in `$(ECHO) $(THOTDIR)/fonts/$$i` ; do \
+ $(INSTALL_DATA) $$file $(datadir)/thot/fonts ; \
+ done ; done)
+
diff --git a/editors/thoteditor/files/patch-ad b/editors/thoteditor/files/patch-ad
new file mode 100644
index 000000000000..c0cd3600e5a1
--- /dev/null
+++ b/editors/thoteditor/files/patch-ad
@@ -0,0 +1,11 @@
+--- ../tools/Makefile.in.orig Fri May 16 10:00:20 1997
++++ ../tools/Makefile.in Sat Sep 25 12:16:00 1999
+@@ -24,7 +24,7 @@
+ cd .. ; fi ;done )
+
+ install :
+- @(for dir in $(SUBDIRS) ;\
++ @(set -x;for dir in $(SUBDIRS) ;\
+ do if test -d $$dir ; then cd $$dir ; \
+ $(MAKE) CC="$(CC)" CFLAGS="$(CFLAGS)" install ; \
+ cd .. ; fi ;done )
diff --git a/editors/thoteditor/files/patch-ae b/editors/thoteditor/files/patch-ae
new file mode 100644
index 000000000000..09b274aa84f5
--- /dev/null
+++ b/editors/thoteditor/files/patch-ae
@@ -0,0 +1,19 @@
+--- ../Makefile.in.orig Wed Oct 8 04:13:58 1997
++++ ../Makefile.in Sat Sep 25 13:24:41 1999
+@@ -17,6 +17,7 @@
+
+ SUBDIRS = tools tablelib thotlib batch drawlib indexlib thot amaya
+ EXTRA_SUBDIRS= misc classes javalib
++BINS = bin/app bin/grm bin/printstr bin/str bin/tra bin/cextract bin/print bin/prs bin/thot
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+@@ -76,6 +77,8 @@
+ do if test -d $$dir ; then cd $$dir ; \
+ $(MAKE) CC="$(CC)" CFLAGS="$(CFLAGS)" install ; \
+ cd .. ; fi ;done )
++ @(set -x;for file in $(BINS);\
++ do $(INSTALL_BIN) $$file ${bindir}; done )
+
+ uninstall :
+ @(for dir in $(SUBDIRS) ;\
diff --git a/editors/thoteditor/pkg-plist b/editors/thoteditor/pkg-plist
index 15d31230c0d9..24dfaa3d8cb5 100644
--- a/editors/thoteditor/pkg-plist
+++ b/editors/thoteditor/pkg-plist
@@ -1,43 +1,38 @@
+bin/app
+bin/grm
+bin/str
+bin/printstr
+bin/tra
+bin/cextract
bin/print
+bin/prs
bin/thot
-include/thot/app.h
-include/thot/appaction.h
-include/thot/application.h
-include/thot/attribute.h
-include/thot/browser.h
-include/thot/content.h
-include/thot/dialog.h
-include/thot/document.h
-include/thot/fileaccess.h
-include/thot/genericdriver.h
-include/thot/interface.h
-include/thot/labelAllocator.h
-include/thot/language.h
-include/thot/libmsg.h
-include/thot/message.h
-include/thot/pivot.h
-include/thot/plugin.h
-include/thot/presentation.h
-include/thot/presentdriver.h
-include/thot/print.h
-include/thot/pschema.h
-include/thot/reference.h
-include/thot/registry.h
-include/thot/selection.h
-include/thot/simx.h
-include/thot/specificdriver.h
-include/thot/sysdep.h
-include/thot/thot_gui.h
-include/thot/thot_sys.h
-include/thot/tree.h
-include/thot/typebase.h
-include/thot/view.h
-lib/libThotDraw.a
-lib/libThotEditor.a
-lib/libThotIndex.a
-lib/libThotKernel.a
-lib/libThotTable.a
+share/thot/batch/APP.GRM
+share/thot/batch/PRESEN.GRM
+share/thot/batch/STRUCT.GRM
+share/thot/batch/TRANS.GRM
+share/thot/batch/APP.LAN
+share/thot/batch/PRESEN.LAN
+share/thot/batch/STRUCT.LAN
+share/thot/batch/TRANS.LAN
+share/thot/batch/APP.LST
+share/thot/batch/PRESEN.LST
+share/thot/batch/STRUCT.LST
+share/thot/batch/TRANS.LST
+share/thot/applis/bin/grm
+share/thot/applis/bin/str
+share/thot/applis/bin/prs
+share/thot/applis/bin/tra
+share/thot/applis/bin/app
+share/thot/applis/bin/printstr
+share/thot/applis/bin/thot
+share/thot/applis/bin/print
share/thot/config/XKeysymDB
+share/thot/config/thot.ini
+share/thot/config/thot.color
+share/thot/config/thot.pattern
+share/thot/config/thot.keyboard
+share/thot/config/fr-thotdialogue
share/thot/config/en-appdialogue
share/thot/config/en-compildialogue
share/thot/config/en-corrdialogue
@@ -65,18 +60,17 @@ share/thot/config/fr-libdialogue
share/thot/config/fr-printdialogue
share/thot/config/fr-prsdialogue
share/thot/config/fr-strdialogue
-share/thot/config/fr-thotdialogue
share/thot/config/fr-thotmessage
share/thot/config/fr-thotversion
share/thot/config/fr-transdialogue
share/thot/config/fr-typdialogue
-share/thot/config/thot.color
-share/thot/config/thot.ini
-share/thot/config/thot.keyboard
-share/thot/config/thot.pattern
-share/thot/dicopar/alphabet
+share/thot/fonts/Families.list
+share/thot/fonts/fonts.dir
+share/thot/fonts/icones.ff
+share/thot/fonts/icones.pcf
+share/thot/fonts/icones1.fb
+share/thot/fonts/icones11.fb
share/thot/dicopar/american.ptn
-share/thot/dicopar/clavier
share/thot/dicopar/deutsch.ptn
share/thot/dicopar/english.ptn
share/thot/dicopar/espanol.ptn
@@ -86,19 +80,18 @@ share/thot/dicopar/italiano.ptn
share/thot/dicopar/nederl.ptn
share/thot/dicopar/portug.ptn
share/thot/dicopar/swedish.ptn
-share/thot/fonts/Families.list
-share/thot/fonts/fonts.dir
-share/thot/fonts/icones.ff
-share/thot/fonts/icones.pcf
-share/thot/fonts/icones1.fb
-share/thot/fonts/icones11.fb
+share/thot/dicopar/alphabet
+share/thot/dicopar/clavier
share/thot/schemas/Makefile
share/thot/schemas/Text_ASCII.inc
share/thot/schemas/Text_SGML.inc
+share/thot/schemas/EDITOR.h
+share/thot/schemas/ExtCss.h
share/thot/schemas/Arbre2.S
share/thot/schemas/Draw2.S
share/thot/schemas/Draw3.S
share/thot/schemas/Expose.S
+share/thot/schemas/ExtCss.S
share/thot/schemas/ExtIndex.S
share/thot/schemas/Feuille.S
share/thot/schemas/Fichier.S
@@ -113,6 +106,7 @@ share/thot/schemas/Arbre2.STR
share/thot/schemas/Draw2.STR
share/thot/schemas/Draw3.STR
share/thot/schemas/Expose.STR
+share/thot/schemas/ExtCss.STR
share/thot/schemas/ExtIndex.STR
share/thot/schemas/Feuille.STR
share/thot/schemas/Fichier.STR
@@ -127,6 +121,7 @@ share/thot/schemas/Arbre2P.P
share/thot/schemas/Draw2P.P
share/thot/schemas/Draw3P.P
share/thot/schemas/ExposeP.P
+share/thot/schemas/ExtCssP.P
share/thot/schemas/ExtIndexP.P
share/thot/schemas/FeuilleP.P
share/thot/schemas/FichierP.P
@@ -148,6 +143,7 @@ share/thot/schemas/ExposePINUS.PRS
share/thot/schemas/ExposePIUS.PRS
share/thot/schemas/ExposePP.PRS
share/thot/schemas/ExposePPUS.PRS
+share/thot/schemas/ExtCssP.PRS
share/thot/schemas/ExtIndexPP.PRS
share/thot/schemas/ExtIndexPPE.PRS
share/thot/schemas/ExtIndexPPEUS.PRS
@@ -204,7 +200,6 @@ share/thot/schemas/Draw2H.T
share/thot/schemas/Draw2T.T
share/thot/schemas/Draw2T1.T
share/thot/schemas/Draw3A.T
-share/thot/schemas/MathH.T
share/thot/schemas/Draw3H.T
share/thot/schemas/Draw3T.T
share/thot/schemas/Draw3T1.T
@@ -218,6 +213,7 @@ share/thot/schemas/FichierA.T
share/thot/schemas/FichierH.T
share/thot/schemas/FichierT.T
share/thot/schemas/LettreA.T
+share/thot/schemas/MathH.T
share/thot/schemas/MathT.T
share/thot/schemas/ParagraphA.T
share/thot/schemas/ParagraphH.T
@@ -280,6 +276,7 @@ share/thot/schemas/Arbre2.conf
share/thot/schemas/Draw2.conf
share/thot/schemas/Draw3.conf
share/thot/schemas/Expose.conf
+share/thot/schemas/ExtCss.conf
share/thot/schemas/ExtIndex.conf
share/thot/schemas/Feuille.conf
share/thot/schemas/Fichier.conf
@@ -292,12 +289,12 @@ share/thot/schemas/Table.conf
share/thot/schemas/Arbre2.fr
share/thot/schemas/Draw2.fr
share/thot/schemas/Draw3.fr
+share/thot/schemas/Math.fr
share/thot/schemas/Expose.fr
share/thot/schemas/ExtIndex.fr
share/thot/schemas/Feuille.fr
share/thot/schemas/Fichier.fr
share/thot/schemas/Lettre.fr
-share/thot/schemas/Math.fr
share/thot/schemas/Paragraphe.fr
share/thot/schemas/Rapport.fr
share/thot/schemas/RefBib.fr
@@ -320,5 +317,8 @@ share/thot/schemas/Table.en
@dirrm share/thot/doc
@exec mkdir -p %D/share/thot/doc
@dirrm share/thot/dicopar
+@dirrm share/thot/batch
+@dirrm share/thot/applis/bin
+@dirrm share/thot/applis
@dirrm share/thot/config
@dirrm share/thot