aboutsummaryrefslogtreecommitdiff
path: root/editors/vigor
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-04-08 06:53:38 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-04-08 06:53:38 +0000
commitc5f3ebf9723df953ea49bbea679ce2a2cd022282 (patch)
treeceb54b11ce1304543fdcdc5d4cb93829fc73662c /editors/vigor
parent5b219e6c8a77b3b495f3d793eab30fba614d1ffc (diff)
downloadports-c5f3ebf9723df953ea49bbea679ce2a2cd022282.tar.gz
ports-c5f3ebf9723df953ea49bbea679ce2a2cd022282.zip
Notes
Diffstat (limited to 'editors/vigor')
-rw-r--r--editors/vigor/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/editors/vigor/Makefile b/editors/vigor/Makefile
index dbd3e48649e2..adaf764d68ed 100644
--- a/editors/vigor/Makefile
+++ b/editors/vigor/Makefile
@@ -17,6 +17,7 @@ COMMENT= A vi clone inspired by the userfriendly comic strip
LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82 \
tcl82.1:${PORTSDIR}/lang/tcl82
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--program-transform-name="s,0,1,"
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
@@ -24,17 +25,12 @@ CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
WRKSRC= ${WRKDIR}/${DISTNAME}/build
CFLAGS+= -I${LOCALBASE}/include/tcl8.2 -I${LOCALBASE}/include/tk8.2
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
# Uglyness. So is "-ltcl -ltk -ltcl", so I don't feel bad.
post-patch:
- @${CP} ${WRKSRC}/configure ${WRKSRC}/configure.orig
- @${SED} -e 's#-ltcl#-ltcl82 -L${LOCALBASE}/lib#g' \
- -e 's#-ltk#-ltk82#g' \
- < ${WRKSRC}/configure.orig > ${WRKSRC}/configure
+ ${REINPLACE_CMD} \
+ -e 's,-ltcl,-ltcl82 -L${LOCALBASE}/lib,g' \
+ -e 's,-ltk,-ltk82,g' \
+ -e 's,^grantpt,XXXgrantpt,g' \
+ ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>