aboutsummaryrefslogtreecommitdiff
path: root/editors/vile
diff options
context:
space:
mode:
authorGary Jennejohn <gj@FreeBSD.org>2008-02-17 11:49:05 +0000
committerGary Jennejohn <gj@FreeBSD.org>2008-02-17 11:49:05 +0000
commitd68951ddadce043caf2d17e6de759fc98cc0b46c (patch)
tree4b770564a4121e4601d4b3a25cd18d5500e7b14e /editors/vile
parent139e1397b9215453694a35bbff42d6016c8d98c1 (diff)
downloadports-d68951ddadce043caf2d17e6de759fc98cc0b46c.tar.gz
ports-d68951ddadce043caf2d17e6de759fc98cc0b46c.zip
Notes
Diffstat (limited to 'editors/vile')
-rw-r--r--editors/vile/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/editors/vile/Makefile b/editors/vile/Makefile
index 13bd2d0c4557..18371e2994bd 100644
--- a/editors/vile/Makefile
+++ b/editors/vile/Makefile
@@ -29,10 +29,18 @@ GNU_CONFIGURE= yes
MAN1= vile.1
OPTIONS= FILTERS "Add support for loadable filters" OFF
+OPTIONS+= ICONV "Add support for ICONV" OFF
OPTIONS+= PERL "Add support for perl functions" OFF
.include <bsd.port.pre.mk>
+.if defined(WITH_ICONV)
+CONFIGURE_ARGS+= --with-iconv
+USE_ICONV= yes
+.else
+CONFIGURE_ARGS+= --without-iconv
+.endif
+
.if defined(WITH_PERL)
CONFIGURE_ARGS+= --with-perl
PLIST= ${PKGDIR}/pkg-plist.perl
@@ -49,6 +57,10 @@ PLIST= ${PKGDIR}/pkg-plist.perl+filt
.endif
pre-configure:
+.if ! defined(WITH_ICONV)
+ @${ECHO_MSG} "Choose the option ICONV if you want to make a vile which includes"
+ @${ECHO_MSG} "ICONV functionality"
+.endif
.if ! defined(WITH_PERL)
@${ECHO_MSG} "Choose the option PERL if you want to make a vile which includes"
@${ECHO_MSG} "PERL functionality"