aboutsummaryrefslogtreecommitdiff
path: root/editors/vim/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2001-05-24 01:19:05 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2001-05-24 01:19:05 +0000
commit13c44e816bd37b117bc4ff218281eaad9e5ce451 (patch)
treea42c1b4152e101d3f532087824bbf5b17f92dd3b /editors/vim/Makefile
parent527f36a623dda5f1ca32a5fddd9a9aa55897a1ca (diff)
downloadports-13c44e816bd37b117bc4ff218281eaad9e5ce451.tar.gz
ports-13c44e816bd37b117bc4ff218281eaad9e5ce451.zip
Notes
Diffstat (limited to 'editors/vim/Makefile')
-rw-r--r--editors/vim/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 634590ae09ac..c6c013cf45b6 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -91,5 +91,20 @@ pre-build:
post-install:
[ -e ${PREFIX}/bin/gvim ] || (cd ${PREFIX}/bin ; ${LN} -sf vim gvim)
+ cd ${PREFIX} ;\
+ find share/vim/${DISTNAME:S/-//:S/.//}/ -type f -o -type l \
+ | sort \
+ >${WRKDIR}/PLIST.share-vim
+ cd ${PREFIX} ;\
+ find share/vim/${DISTNAME:S/-//:S/.//}/ -type d \
+ | sort -r | ${SED} -e 's/^/@dirrm /g' \
+ >>${WRKDIR}/PLIST.share-vim
+ ${ECHO} "r ${TMPPLIST}" > ${WRKDIR}/ex.script
+ ${ECHO} "/Insert PLIST.share-vim" >> ${WRKDIR}/ex.script
+ ${ECHO} "d" >> ${WRKDIR}/ex.script
+ ${ECHO} "r ${WRKDIR}/PLIST.share-vim" >> ${WRKDIR}/ex.script
+ ${ECHO} "x!" >> ${WRKDIR}/ex.script
+ ${CP} -p ${TMPPLIST} ${TMPPLIST}.pre-share-vim
+ cd ${WRKDIR} ; ex < ex.script
.include <bsd.port.post.mk>