aboutsummaryrefslogtreecommitdiff
path: root/editors/vim/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1997-05-25 02:59:06 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1997-05-25 02:59:06 +0000
commit87322138a9e724f485f0e6c7287eae5ecd7a1751 (patch)
tree4b2d6065e8190b0c1723596459640d5e4ae68472 /editors/vim/Makefile
parent6fceba7f126061dc0c5097f238fb1479c0a89ae0 (diff)
downloadports-87322138a9e724f485f0e6c7287eae5ecd7a1751.tar.gz
ports-87322138a9e724f485f0e6c7287eae5ecd7a1751.zip
Notes
Diffstat (limited to 'editors/vim/Makefile')
-rw-r--r--editors/vim/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
new file mode 100644
index 000000000000..5169d230467b
--- /dev/null
+++ b/editors/vim/Makefile
@@ -0,0 +1,40 @@
+# ex:ts=8
+# New ports collection makefile for: vim
+# Version required: 5.x
+# Date created: Sat June 29, 1996
+# Whom: David O'Brien (obrien@cs.ucdavis.edu)
+#
+# $Id: Makefile,v 1.7 1997/03/27 05:42:13 obrien Exp $
+#
+
+DISTNAME= vim-5.0h
+CATEGORIES= editors
+MASTER_SITES= ftp://nuxi.ucdavis.edu/pub/vim/beta-test/unix/ \
+ ftp://ftp.nuxi.com/pub/vim/beta-test/unix/ \
+ ftp://ftp.oce.nl/pub/misc/vim/beta-test/unix/ \
+ ftp://ftp.prz.tu-berlin.de/pub/unix/editors/vim/beta-test/unix/ \
+ ftp://ftp.is.co.za/applications/editors/beta-test/vim/ \
+ ftp://ftp.progsoc.uts.edu.au/pub/beta-test/vim/
+
+MAINTAINER= obrien@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+USE_GMAKE= yes
+ALL_TARGET=
+MAN1= vim.1 xxd.1 ctags.1 etags.1
+
+.if defined(HAVE_MOTIF)
+REQUIRES_MOTIF= yes
+MAKE_FLAGS+= CONF_OPT_GUI="--enable-gui=motif" MOTIFHOME=${X11BASE} -f
+.else
+MAKE_FLAGS+= CONF_OPT_GUI="--enable-gui=yes" -f
+.endif
+
+pre-build:
+ @(cd ${WRKSRC}; ${GMAKE} distclean)
+
+post-install:
+ [ -e ${PREFIX}/bin/gvim ] || /bin/ln -s ${PREFIX}/bin/vim ${PREFIX}/bin/gvim
+
+
+.include <bsd.port.mk>