aboutsummaryrefslogtreecommitdiff
path: root/editors/vim/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2003-08-10 00:42:47 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2003-08-10 00:42:47 +0000
commit8e93e45e3ec0fbbcdcfa5391101c3cdbd1c889a4 (patch)
treea071e300e635a88dc06ac8395dea255c3f9eab76 /editors/vim/Makefile
parent2571be8d33396a89392af08a41e6ede0a0fa29ac (diff)
Notes
Diffstat (limited to 'editors/vim/Makefile')
-rw-r--r--editors/vim/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 6722552d8037..331e3304ca83 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -7,9 +7,9 @@
#
PORTNAME?= vim
-PATCHLEVEL= 21
+PATCHLEVEL= 61
PORTVERSION= 6.2.${PATCHLEVEL}
-PORTREVISION?= 1
+PORTREVISION?= 0
CATEGORIES?= editors
MASTER_SITES= ${MASTER_SITE_VIM}
DISTNAME= vim-${PORTVERSION:C/\.[0-9]*$//}
@@ -18,7 +18,7 @@ PATCH_SITES= ${MASTER_SITES:S/unix/patches/}
PATCHFILES!= /usr/bin/jot -s " " -w ${PORTVERSION:C/\.[0-9]*$//}.%03d \
${PATCHLEVEL} 1 ${PATCHLEVEL}
# bits to remove
-BADPATCHES= 009 013 015 019
+BADPATCHES= 009 013 019 022 023 024 033 036 038 039 041 042 047 056 057 060
.for p in ${BADPATCHES}
PATCHFILES:= ${PATCHFILES:N6.2.${p}}
.endfor
@@ -173,4 +173,8 @@ post-install:
${CP} -p ${TMPPLIST} ${TMPPLIST}.pre-share-vim
cd ${WRKDIR} ; ex < ex.script
+cklatest:
+ @-ncftpls ftp://ftp.vim.org/pub/vim/patches/ \
+ | fgrep ${PORTVERSION:C/[0-9]*$//} | ${TAIL}
+
.include <bsd.port.post.mk>