aboutsummaryrefslogtreecommitdiff
path: root/editors/vim/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2012-04-24 17:44:43 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2012-04-24 17:44:43 +0000
commitda3cd20bff4dcd72bb2c056b7b917d351a7a20ce (patch)
tree5190224ead6fc2984efb54b28d67426cb962ada8 /editors/vim/Makefile
parentca030a712ffdd1da3887959c0a290214002e2392 (diff)
downloadports-da3cd20bff4dcd72bb2c056b7b917d351a7a20ce.tar.gz
ports-da3cd20bff4dcd72bb2c056b7b917d351a7a20ce.zip
Notes
Diffstat (limited to 'editors/vim/Makefile')
-rw-r--r--editors/vim/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index b05f27796988..384ec908f23a 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -10,7 +10,7 @@ PORTNAME?= vim
# ! _NEVER_ reduce or lower PATCHLEVEL, even if the PATCHLEVEL
# ! value # is added to BADPATCHES. Doing otherwise will cause
# ! PORTEPOCH to be needed, which we do NOT want.
-PATCHLEVEL= 480
+PATCHLEVEL= 502
PORTVERSION= 7.3.${PATCHLEVEL}
RELEASE= vim-${PORTVERSION:C/\.[0-9a-z]*$//}
PORTREVISION?= 0
@@ -23,7 +23,7 @@ PATCH_SITES= ${MASTER_SITES:S|unix|patches/${PORTVERSION:C/\.[0-9a-z]*$//}|}\
PATCHFILES!= /usr/bin/jot -s " " -w ${PORTVERSION:C/\.[0-9]*$//}.%03d \
${PATCHLEVEL} 1 ${PATCHLEVEL}
# bits to remove
-BADPATCHES= 122 225 235 246 247 252 253 336 386 387 400 434
+BADPATCHES= 122 225 235 246 247 252 253 336 386 387 400 434 487 491
.for p in ${BADPATCHES}
PATCHFILES:= ${PATCHFILES:N7.3.${p}}
.endfor
@@ -246,6 +246,7 @@ cklatest: .PHONY
@${MAKE} -V PATCHLEVEL
-(ncftpls \
ftp://ftp.vim.org/pub/vim/patches/${PORTVERSION:C/\.[0-9a-z]*$//}/ \
+ | grep "^${PORTVERSION:C/\.[0-9a-z]*$//}" \
| ${SED} -n -e 's/${PORTVERSION:C/[0-9]*$//}\([0-9][0-9][0-9]\)$$/\1/p' \
| ${TAIL} -1)