aboutsummaryrefslogtreecommitdiff
path: root/editors/vim/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2002-04-09 02:23:01 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2002-04-09 02:23:01 +0000
commita1ba576fdf134e4473164dbe02e776d259ea24ed (patch)
treeb545c4f36addca76fcf15e0d6686ffffd1cc5600 /editors/vim/Makefile
parentd7acd0ef07fef7316619974cf1c2ecae2e58f979 (diff)
Notes
Diffstat (limited to 'editors/vim/Makefile')
-rw-r--r--editors/vim/Makefile35
1 files changed, 15 insertions, 20 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 731956bb0ea1..e68c1746840b 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -7,27 +7,26 @@
#
PORTNAME?= vim
-PATCHLEVEL= 0
-PORTVERSION= 6.0.271.${PATCHLEVEL}
+PATCHLEVEL= 9
+PORTVERSION= 6.1.${PATCHLEVEL}
PORTREVISION?= 0
CATEGORIES?= editors
-MASTER_SITES= ftp://nuxi.ucdavis.edu/pub/vim/unstable/unix/ \
- ftp://relay.nuxi.com/pub/vim/unstable/unix/ \
- ftp://ftp.vim.org/pub/vim/unstable/unix/ \
- ftp://ftp.is.co.za/applications/editors/vim/unstable/unix/ \
- ftp://ftp.prz.tu-berlin.de/pub/unix/editors/vim/unstable/unix/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.vim.org/pub/vim/unstable/unix/ \
- ftp://ftp.progsoc.uts.edu.au/pub/vim/unstable/unix/
-#DISTNAME= vim-${PORTVERSION:C/\.[0-9]*$//}
-DISTNAME= vim-6.1b
+MASTER_SITES= ftp://nuxi.ucdavis.edu/pub/vim/unix/ \
+ ftp://relay.nuxi.com/pub/vim/unix/ \
+ ftp://ftp.vim.org/pub/vim/unix/ \
+ ftp://ftp.is.co.za/applications/editors/vim/unix/ \
+ ftp://ftp.prz.tu-berlin.de/pub/unix/editors/vim/unix/ \
+ ftp://ftp.mirror.ac.uk/sites/ftp.vim.org/pub/vim/unix/ \
+ ftp://ftp.progsoc.uts.edu.au/pub/vim/unix/
+DISTNAME= vim-${PORTVERSION:C/\.[0-9]*$//}
PATCH_SITES= ${MASTER_SITES:S/unix/patches/}
-#PATCHFILES!= jot -s " " -w ${PORTVERSION:C/0\.271\.[0-9]*$//}1a.%03d \
-# ${PATCHLEVEL} 1 ${PATCHLEVEL}
+PATCHFILES!= jot -s " " -w ${PORTVERSION:C/\.[0-9]*$//}.%03d \
+ ${PATCHLEVEL} 1 ${PATCHLEVEL}
# bits to remove
-BADPATCHES=
+BADPATCHES= 002
.for p in ${BADPATCHES}
-PATCHFILES:= ${PATCHFILES:N6.1b.${p}}
+PATCHFILES:= ${PATCHFILES:N6.1.${p}}
.endfor
MAINTAINER?= obrien@FreeBSD.org
@@ -43,7 +42,7 @@ WITH_CSCOPE= yes
USE_BZIP2= yes
DIST_SUBDIR= vim
-WRKSRC= ${WRKDIR}/vim${PORTVERSION:C/0\.271\.[0-9]*$//:S/.//g}1b/src
+WRKSRC= ${WRKDIR}/vim${PORTVERSION:C/\.[0-9]*$//:S/.//g}/src
PATCH_DIST_ARGS= -d ${WRKSRC:S/src$//} --forward --quiet -E ${PATCH_DIST_STRIP}
# consider
#PATCH_DIST_ARGS= -t
@@ -129,10 +128,6 @@ MAKE_ARGS+= CONF_OPT_PERL="--disable-perlinterp --disable-pythoninterp --disable
.if defined(WITH_GTK)
USE_XLIB= yes
.endif
-.if defined(USE_XLIB)
-post-patch:
- ${PERL} -pi.orig -e 's/ X11 //g' ${WRKSRC}/link.sh
-.endif
pre-build:
@(cd ${WRKSRC}; ${MAKE} distclean)