aboutsummaryrefslogtreecommitdiff
path: root/editors/vim5
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-02-15 22:03:07 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-02-15 22:03:07 +0000
commit3d6b8a5b94ac30253107cda0fb4d26d6d183468b (patch)
tree3371f600d6f0b75cc3ba899da6d28bd5702a8d1e /editors/vim5
parent837e83529ade4f8960554b9fb5d55fe8bef64a32 (diff)
downloadports-3d6b8a5b94ac30253107cda0fb4d26d6d183468b.tar.gz
ports-3d6b8a5b94ac30253107cda0fb4d26d6d183468b.zip
Notes
Diffstat (limited to 'editors/vim5')
-rw-r--r--editors/vim5/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/editors/vim5/Makefile b/editors/vim5/Makefile
index f2a51c4a7010..feb369b43cd5 100644
--- a/editors/vim5/Makefile
+++ b/editors/vim5/Makefile
@@ -38,18 +38,6 @@ MAN1= vim.1 vimtutor.1 xxd.1
MLINKS= vim.1 rvim.1 vim.1 rview.1 ectags.1 etags.1
MLINKS+= vim.1 gvim.1 vim.1 gview.1 vim.1 rgvim.1 vim.1 rgview.1
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 500800
-BROKEN= "Does not compile with perl 5.8"
-.endif
-
-# Determine if we need xpg4.
-# No xpg4 in libc below 400020 and 500005
-.if ${OSVERSION} < 400020 && ${OSVERSION} < 500005
-MAKE_ARGS+= LIBS=-lxpg4
-.endif
-
.if !defined(LITE)
MAKE_ARGS+= CONF_OPT_MAX="--enable-max-features"
I18N= CONF_OPT_MULTIBYTE="--enable-multibyte --enable-fontset --enable-xim"
@@ -83,6 +71,18 @@ MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=no --without-x --enable-multibyte"
MAKE_ARGS+= CONF_OPT_PERL="--disable-perlinterp --disable-pythoninterp --disable-tclinterp"
.endif # LITE
+.include <bsd.port.pre.mk>
+
+# Determine if we need xpg4.
+# No xpg4 in libc below 400020 and 500005
+.if ${OSVERSION} < 400020 && ${OSVERSION} < 500005
+MAKE_ARGS+= LIBS=-lxpg4
+.endif
+
+.if ${PERL_LEVEL} >= 500800
+BROKEN= "Does not compile with perl 5.8"
+.endif
+
pre-build:
@(cd ${WRKSRC}; ${MAKE} distclean)