aboutsummaryrefslogtreecommitdiff
path: root/editors/vim
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2018-08-16 21:04:01 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2018-08-16 21:04:01 +0000
commit9bf68f57dd58eb7e88504edb20d559c0de820d13 (patch)
tree1517479ef0c96ab94dc6366984e71778c67e7a6b /editors/vim
parent1b1dae1753951c2ebf1543ad73678c69d6ff2e60 (diff)
Notes
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile2
-rw-r--r--editors/vim/files/patch-src-auto-configure18
2 files changed, 2 insertions, 18 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 0f9fa22338c2..28a5222460a4 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -129,10 +129,12 @@ PERL_CONFIGURE_ENABLE= perlinterp
PERL_USES= perl5
PYTHON2_CONFIGURE_ENABLE= pythoninterp
+PYTHON2_CONFIGURE_WITH= python-command=${LOCALBASE}/bin/python${PYTHON2_DEFAULT}
PYTHON2_BUILD_DEPENDS= python${PYTHON2_DEFAULT}:lang/python${PYTHON2_DEFAULT:S/.//}
PYTHON2_RUN_DEPENDS= ${PYTHON2_BUILD_DEPENDS}
PYTHON3_CONFIGURE_ENABLE= python3interp
+PYTHON3_CONFIGURE_WITH= python3-command=${PYTHON_CMD}
PYTHON3_USES= python:3.4+
RUBY_CONFIGURE_ENABLE= rubyinterp
diff --git a/editors/vim/files/patch-src-auto-configure b/editors/vim/files/patch-src-auto-configure
index 15882f62b7cd..39bc29256854 100644
--- a/editors/vim/files/patch-src-auto-configure
+++ b/editors/vim/files/patch-src-auto-configure
@@ -46,21 +46,3 @@
fi
if test "X$LUA_CFLAGS$LUA_LIBS" != "X" && \
test "x$MACOS_X" = "xyes" && test "x$vi_cv_with_luajit" != "xno" && \
-@@ -6230,7 +6231,7 @@ fi
-
-
- if test "X$vi_cv_path_python" = "X"; then
-- for ac_prog in python2 python
-+ for ac_prog in python2.7
- do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
- set dummy $ac_prog; ac_word=$2
-@@ -6580,7 +6581,7 @@ fi
-
-
- if test "X$vi_cv_path_python3" = "X"; then
-- for ac_prog in python3 python
-+ for ac_prog in python3.6 python3.5 python3.4
- do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
- set dummy $ac_prog; ac_word=$2