aboutsummaryrefslogtreecommitdiff
path: root/editors/vim
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2003-04-06 16:11:48 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2003-04-06 16:11:48 +0000
commit6fb546432abd4d83520c2f72c077886b0ed7b3eb (patch)
treedb51f972bce3a31f0c2c74120cc36977586810da /editors/vim
parentbf01a788233eaec10ad5fb0c056fec1264611eb7 (diff)
downloadports-6fb546432abd4d83520c2f72c077886b0ed7b3eb.tar.gz
ports-6fb546432abd4d83520c2f72c077886b0ed7b3eb.zip
Notes
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 71ba3e75aa31..df322e7500ba 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -47,7 +47,7 @@ PATCH_DIST_ARGS= -d ${WRKSRC:S/src$//} --forward --quiet -E ${PATCH_DIST_STRIP}
MAKE_ARGS+= CONF_ARGS="--prefix=${PREFIX} --with-tlib=termlib ${CSCOPE_ARG}"
ALL_TARGET= #
PLIST_SUB= VIM_VER=${DISTNAME:S/-//:S/.//}
-DATADIR= ${PREFIX}/share/vim/${DISTNAME:S/-//:S/.//}
+DATADIR= ${PREFIX}/share/vim/vim${PORTVERSION:C/\.[0-9]*$//:S/.//g}
MAN1= evim.1 vim.1 vimdiff.1 vimtutor.1 xxd.1
MLINKS= vim.1 rvim.1 vim.1 rview.1
.if !defined(LITE)
@@ -154,11 +154,11 @@ post-install:
|| (cd ${PREFIX}/bin ; ${LN} -sf vim gvimdiff)
${INSTALL_DATA} ${FILESDIR}/vietnamese_viscii.vim ${DATADIR}/keymap
cd ${PREFIX} ;\
- ${FIND} share/vim/${DISTNAME:S/-//:S/.//}/ -type f -o -type l \
+ ${FIND} ${DATADIR:S/^${PREFIX}\///} -type f -o -type l \
| sort \
>${WRKDIR}/PLIST.share-vim
cd ${PREFIX} ;\
- ${FIND} share/vim/${DISTNAME:S/-//:S/.//}/ -type d \
+ ${FIND} ${DATADIR:S/^${PREFIX}\///} -type d \
| sort -r | ${SED} -e 's/^/@dirrm /g' \
>>${WRKDIR}/PLIST.share-vim
${ECHO_CMD} "r ${TMPPLIST}" > ${WRKDIR}/ex.script