aboutsummaryrefslogtreecommitdiff
path: root/editors/vim
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-05-28 18:57:07 +0000
committerChris Rees <crees@FreeBSD.org>2012-05-28 18:57:07 +0000
commitc67a2a2dc16255a0508c2ffd646219d2a490f780 (patch)
tree725fbfccbdf6e1a9a8273116046adcc7655a1824 /editors/vim
parent263142fd23a462d96cf10a8ba7c3e460b728665a (diff)
downloadports-c67a2a2dc16255a0508c2ffd646219d2a490f780.tar.gz
ports-c67a2a2dc16255a0508c2ffd646219d2a490f780.zip
Notes
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index f9f0d7089063..32538a2e3c59 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -58,8 +58,10 @@ MLINKS= vim.1 rvim.1 vim.1 rview.1
MLINKS+= vim.1 gvim.1 vim.1 gview.1 vimdiff.1 gvimdiff.1 \
vim.1 rgvim.1 vim.1 rgview.1 evim.1 eview.1
.endif
+.if !defined(WITHOUT_NLS)
MANLANG= "" ru.KOI8-R ru.UTF-8 pl.ISO8859-2 pl.UTF-8 pl fr.ISO8859-1 \
fr.UTF-8 fr it.ISO8859-1 it.UTF-8 it
+.endif
.if defined(PACKAGE_BUILDING) && !defined(LITE)
WITH_CSCOPE= yes
@@ -109,7 +111,6 @@ MAKE_ARGS+= CONF_OPT_PERL="--disable-perlinterp --disable-pythoninterp --disable
.else # !LITE
MAKE_ARGS+= CONF_OPT_FEAT="--with-features=big"
I18N= CONF_OPT_MULTIBYTE="--enable-multibyte --enable-fontset --enable-xim"
-USE_GETTEXT= yes
. if defined(NO_GUI) || defined(WITHOUT_GUI)
WITHOUT_X11= yes
@@ -169,8 +170,10 @@ MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=no --without-x" ${I18N}
.if exists(${LOCALBASE}/lib/libiconv.so)
USE_ICONV= yes
.endif
-.if exists(${LOCALBASE}/lib/libintl.so)
+.if exists(${LOCALBASE}/lib/libintl.so) && !defined(WITHOUT_NLS)
USE_GETTEXT= yes
+.else
+MAKE_ARGS+= CONF_OPT_NLS="--disable-nls"
.endif
.if defined(WITH_EXUBERANT_CTAGS)