aboutsummaryrefslogtreecommitdiff
path: root/editors/wily/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-11-17 11:53:06 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-11-17 11:53:06 +0000
commitdc47bfa69716ae525d70a0fc897fe438871f94ce (patch)
tree0f1506deec64e70e50a1a5afbab91a7a77456a45 /editors/wily/Makefile
parent7ff48bbb2e006b8f14543911b454d0672e6ad990 (diff)
downloadports-dc47bfa69716ae525d70a0fc897fe438871f94ce.tar.gz
ports-dc47bfa69716ae525d70a0fc897fe438871f94ce.zip
Notes
Diffstat (limited to 'editors/wily/Makefile')
-rw-r--r--editors/wily/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/editors/wily/Makefile b/editors/wily/Makefile
new file mode 100644
index 000000000000..87e2a3a69430
--- /dev/null
+++ b/editors/wily/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: wily
+# Version required: 0.13.36
+# Date created: 23 September 1997
+# Whom: koshy
+#
+# $Id$
+#
+
+DISTNAME= wily-0.13.36
+CATEGORIES= plan9 editors
+MASTER_SITES= ftp://ftp.northsea.com/pub/plan9_unix/wily/wily/src/ \
+ ftp://ftp.cs.york.ac.uk/pub/mhw/wily/src/ \
+ ftp://ftp.cs.su.oz.au/gary/wily/src/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= koshy@india.hp.com
+
+USE_X11= YES
+GNU_CONFIGURE= YES
+
+WILYDOCDIR= ${PREFIX}/share/doc/wily
+WILYDOCFILES= index.html intro.html download.html credits.html FAQ.txt \
+ onepage.html user.html idioms.html C.html python.html \
+ perl.txt hack.html changes.txt AcmeVsWily.html Tcl.html \
+ pythonpaper.html winmanager.html
+
+# The default Wily makefile does not install any documentation. Rectify.
+post-install:
+ strip ${PREFIX}/bin/wily
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${WILYDOCDIR}
+ set -e; for f in ${WILYDOCFILES}; do \
+ ${INSTALL_DATA} ${WRKSRC}/Doc/$${f} ${WILYDOCDIR}/$${f}; \
+ done
+.endif
+
+.include <bsd.port.mk>