aboutsummaryrefslogtreecommitdiff
path: root/editors/wordgrinder
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2010-08-20 12:06:27 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2010-08-20 12:06:27 +0000
commite742d91d59ac6181de7f92618c154944d5c3a53f (patch)
tree91c4c51dfc1a4a64f34ee331c42087742c424e9e /editors/wordgrinder
parent5f1e0922728afacfde1b52fb6d9896755d56933a (diff)
Notes
Diffstat (limited to 'editors/wordgrinder')
-rw-r--r--editors/wordgrinder/Makefile50
-rw-r--r--editors/wordgrinder/distinfo3
-rw-r--r--editors/wordgrinder/pkg-descr11
3 files changed, 64 insertions, 0 deletions
diff --git a/editors/wordgrinder/Makefile b/editors/wordgrinder/Makefile
new file mode 100644
index 000000000000..c5cab17aa2dd
--- /dev/null
+++ b/editors/wordgrinder/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: wordgrinder
+# Date created: 15 August 2010
+# Whom: Vitaly Magerya <vmagerya@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wordgrinder
+PORTVERSION= 0.3.3
+CATEGORIES= editors
+MASTER_SITES= SF
+
+MAINTAINER= vmagerya@gmail.com
+COMMENT= A simple Unicode-aware console-based word processor
+
+RUN_DEPENDS= ${LUA_MODLIBDIR}/lfs.so:${PORTSDIR}/devel/luafilesystem
+
+USE_LUA= 5.1+
+
+USE_BZIP2= yes
+
+LICENSE= MIT
+
+MAN1= wordgrinder.1
+
+PLIST_DIRS= share/doc/wordgrinder
+PLIST_FILES= bin/wordgrinder share/doc/wordgrinder/README.wg
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,^PREFIX =.*$$,PREFIX = "${PREFIX}",' \
+ -e 's,/usr/include/lua5.1,${LUA_INCDIR},' \
+ -e 's,command = "lua ,command = "${LUA_CMD} ,' \
+ -e '/curses_exe =/s,$$,\
+ CLINKFLAGS = {PARENT\, "-L${LUA_LIBDIR}"}\,,' \
+ -e 's,lua5.1,lua,' \
+ -e 's,install -D,install,' \
+ ${WRKSRC}/pmfile
+ ${REINPLACE_CMD} 's,^LUACOMPILER =.*$$,LUACOMPILER = "${LUAC_CMD}",' \
+ ${WRKSRC}/tools/lua.pm
+
+do-build:
+ (cd ${WRKSRC}; ./pm)
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/share/doc/wordgrinder
+ (cd ${WRKSRC}; ./pm install)
+ ${STRIP_CMD} ${PREFIX}/bin/wordgrinder
+
+.include <bsd.port.mk>
diff --git a/editors/wordgrinder/distinfo b/editors/wordgrinder/distinfo
new file mode 100644
index 000000000000..a30e145c3969
--- /dev/null
+++ b/editors/wordgrinder/distinfo
@@ -0,0 +1,3 @@
+MD5 (wordgrinder-0.3.3.tar.bz2) = 1ae3bcf2fc4ee027bdd9518a73733505
+SHA256 (wordgrinder-0.3.3.tar.bz2) = 999781e169eda05d64b5df6034e0ab1d98f768a936218979754f754ca6eeb339
+SIZE (wordgrinder-0.3.3.tar.bz2) = 680918
diff --git a/editors/wordgrinder/pkg-descr b/editors/wordgrinder/pkg-descr
new file mode 100644
index 000000000000..e24e58417a6a
--- /dev/null
+++ b/editors/wordgrinder/pkg-descr
@@ -0,0 +1,11 @@
+WordGrinder is a simple, Unicode-aware word processor that runs on the
+console. It's designed to get the hell out of your way and let you write;
+it does very little, but what it does it does well.
+
+It supports basic paragraph styles, basic character styles, basic screen
+markup, a menu interface that means you don't have to remember complex
+key sequences, HTML import and export, and some other useful features.
+
+WordGrinder does not require X. It runs in a terminal.
+
+WWW: http://wordgrinder.sf.net