aboutsummaryrefslogtreecommitdiff
path: root/editors/xemacs-devel-mule/files
diff options
context:
space:
mode:
authorKiriyama Kazuhiko <kiri@FreeBSD.org>2002-01-05 11:11:07 +0000
committerKiriyama Kazuhiko <kiri@FreeBSD.org>2002-01-05 11:11:07 +0000
commit940c18381d5f26b379b3ac3d94ff1befe16a8cda (patch)
tree4ade6317a422cefdf8b465e9adece002df8097e6 /editors/xemacs-devel-mule/files
parent675c8f1816e6ca41cc19d912699e5a5375d2214e (diff)
Notes
Diffstat (limited to 'editors/xemacs-devel-mule/files')
-rw-r--r--editors/xemacs-devel-mule/files/patch-aa11
-rw-r--r--editors/xemacs-devel-mule/files/patch-af53
-rw-r--r--editors/xemacs-devel-mule/files/patch-ai20
-rw-r--r--editors/xemacs-devel-mule/files/patch-ak17
4 files changed, 101 insertions, 0 deletions
diff --git a/editors/xemacs-devel-mule/files/patch-aa b/editors/xemacs-devel-mule/files/patch-aa
new file mode 100644
index 000000000000..45fbafd60623
--- /dev/null
+++ b/editors/xemacs-devel-mule/files/patch-aa
@@ -0,0 +1,11 @@
+--- lib-src/Makefile.in.in~ Tue Feb 8 11:54:39 2000
++++ lib-src/Makefile.in.in Thu Sep 21 22:26:13 2000
+@@ -224,7 +224,7 @@
+ (cd ${archlibdir} && \
+ $(RM) ${UTILITIES} ${INSTALLABLES} ${SCRIPTS} ${INSTALLABLE_SCRIPTS})
+
+-.PHONY: mostlyclean clean distclean realclean extraclean
++.PHONY: mostlyclean clean distclean realclean extraclean ${archlibdir}
+ mostlyclean:
+ $(RM) *.o *.i core
+ clean: mostlyclean
diff --git a/editors/xemacs-devel-mule/files/patch-af b/editors/xemacs-devel-mule/files/patch-af
new file mode 100644
index 000000000000..c0c55cbf0aef
--- /dev/null
+++ b/editors/xemacs-devel-mule/files/patch-af
@@ -0,0 +1,53 @@
+--- configure.in.orig Wed Jul 25 09:39:21 2001
++++ configure.in Sun Oct 7 23:20:24 2001
+@@ -1098,6 +1098,7 @@
+ dnl Straightforward OS determination
+ case "$canonical" in
+ *-*-linux* ) opsys=linux ;;
++ *-*-freebsd* ) opsys=freebsd ;;
+ *-*-netbsd* ) opsys=netbsd ;;
+ *-*-openbsd* ) opsys=openbsd ;;
+ *-*-nextstep* ) opsys=nextstep ;;
+@@ -3661,21 +3662,24 @@
+ test "$ac_cv_func_crypt" != "yes" && { AC_CHECK_LIB(crypt, crypt) }
+ fi
+ dnl Back to our regularly scheduled wnn hunting
+- if test -z "$with_wnn" -o "$with_wnn" = "yes"; then
+- AC_CHECK_LIB(wnn,jl_dic_list_e,libwnn=wnn,
+- AC_CHECK_LIB(wnn4,jl_dic_list_e,libwnn=wnn4,
+- AC_CHECK_LIB(wnn6,jl_dic_list_e,libwnn=wnn6,
+- AC_CHECK_LIB(wnn6_fromsrc,dic_list_e,libwnn=wnn6_fromsrc,with_wnn=no))))
++ if test "$with_wnn6" = "yes"; then
++ AC_CHECK_LIB(wnn6,jl_fi_dic_list_e,libwnn=wnn6,
++ AC_CHECK_LIB(wnn6_fromsrc,jl_fi_dic_list_e,libwnn=wnn6_fromsrc,
++ AC_CHECK_LIB(wnn,jl_fi_dic_list_e,libwnn=wnn, [with_wnn6=no; with_wnn=no])))
++ else
++ if test -z "$with_wnn" -o "$with_wnn" = "yes"; then
++ AC_CHECK_LIB(wnn,jl_dic_list_e,libwnn=wnn,
++ AC_CHECK_LIB(wnn4,jl_dic_list_e,libwnn=wnn4,
++ AC_CHECK_LIB(wnn6,jl_fi_dic_list_e,[libwnn=wnn6; with_wnn6=yes],
++ AC_CHECK_LIB(wnn6_fromsrc,jl_fi_dic_list_e, [libwnn=wnn6_fromsrc; with_wnn6=yes],with_wnn=no))))
++ fi
+ fi
+ test -z "$with_wnn" && with_wnn=yes
+ if test "$with_wnn" = "yes"; then
+ AC_DEFINE(HAVE_WNN)
+ XE_PREPEND(-l$libwnn, libs_x)
+ XE_ADD_OBJS(mule-wnnfns.o)
+- if test "$with_wnn6" != "no"; then
+- AC_CHECK_LIB($libwnn, jl_fi_dic_list, with_wnn6=yes)
+- test "$with_wnn6" = "yes" && AC_DEFINE(WNN6)
+- fi
++ test "$with_wnn6" = "yes" && AC_DEFINE(WNN6)
+ fi
+
+ dnl Autodetect canna
+@@ -4257,7 +4261,7 @@
+ dnl Check for Berkeley DB.
+ if test "$with_database_berkdb" != "no"; then
+ AC_MSG_CHECKING(for Berkeley db.h)
+- for header in "db/db.h" "db.h"; do
++ for header in "/usr/include/db.h" "db/db.h" "db.h"; do
+ AC_TRY_COMPILE([
+ #include <stdlib.h>
+ #if !(defined __GLIBC__ && __GLIBC_MINOR__ >= 1)
diff --git a/editors/xemacs-devel-mule/files/patch-ai b/editors/xemacs-devel-mule/files/patch-ai
new file mode 100644
index 000000000000..c91881639c5e
--- /dev/null
+++ b/editors/xemacs-devel-mule/files/patch-ai
@@ -0,0 +1,20 @@
+--- lib-src/fakemail.c.orig Tue Mar 23 22:09:58 1999
++++ lib-src/fakemail.c Tue Mar 23 22:12:20 1999
+@@ -157,9 +157,17 @@
+ extern char *malloc (), *realloc ();
+ #endif
+
++#if defined(__FreeBSD_version) && __FreeBSD_version >= 400000
++#define CURRENT_USER
++#endif
++
+ #ifdef CURRENT_USER
+ extern struct passwd *getpwuid ();
++#if defined(__FreeBSD_version) && __FreeBSD_version >= 400000
++extern uid_t geteuid ();
++#else
+ extern unsigned short geteuid ();
++#endif
+ static struct passwd *my_entry;
+ #define cuserid(s) \
+ (my_entry = getpwuid (((int) geteuid ())), \
diff --git a/editors/xemacs-devel-mule/files/patch-ak b/editors/xemacs-devel-mule/files/patch-ak
new file mode 100644
index 000000000000..a45db5e1084d
--- /dev/null
+++ b/editors/xemacs-devel-mule/files/patch-ak
@@ -0,0 +1,17 @@
+--- ./src/unexelf.c~ Sun Aug 15 03:29:56 1999
++++ ./src/unexelf.c Tue Nov 2 10:24:55 1999
+@@ -515,6 +515,14 @@
+ # include <sys/exec_elf.h>
+ #endif
+
++#if defined(__FreeBSD__) && defined(__alpha__)
++# ifdef __STDC__
++# define ElfW(type) Elf64_##type
++# else
++# define ElfW(type) Elf64_/**/type
++# endif
++#endif
++
+ #if __GNU_LIBRARY__ - 0 >= 6
+ # include <link.h> /* get ElfW etc */
+ #endif