aboutsummaryrefslogtreecommitdiff
path: root/editors/xemacs-devel-mule
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2006-02-17 21:12:07 +0000
committerAndrey Slusar <anray@FreeBSD.org>2006-02-17 21:12:07 +0000
commit050ebfa26f8e413430f0fc07beea9c368de911b0 (patch)
treead6ccf2060d15d7f09bbd5fcb333d087c33cfdaa /editors/xemacs-devel-mule
parent2e142b64d01cb542d74d1010403e57a1858a9e9f (diff)
downloadports-050ebfa26f8e413430f0fc07beea9c368de911b0.tar.gz
ports-050ebfa26f8e413430f0fc07beea9c368de911b0.zip
Notes
Diffstat (limited to 'editors/xemacs-devel-mule')
-rw-r--r--editors/xemacs-devel-mule/Makefile2
-rw-r--r--editors/xemacs-devel-mule/files/patch-xgccache.c17
2 files changed, 18 insertions, 1 deletions
diff --git a/editors/xemacs-devel-mule/Makefile b/editors/xemacs-devel-mule/Makefile
index c6217f79e1ee..19af0785522e 100644
--- a/editors/xemacs-devel-mule/Makefile
+++ b/editors/xemacs-devel-mule/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xemacs-devel-mule
PORTVERSION= ${XEMACS_VER:S/-/./}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= editors
MASTER_SITES= ${MASTER_SITE_XEMACS}
MASTER_SITE_SUBDIR= xemacs-${XEMACS_REL}
diff --git a/editors/xemacs-devel-mule/files/patch-xgccache.c b/editors/xemacs-devel-mule/files/patch-xgccache.c
new file mode 100644
index 000000000000..bc0d7dbef59e
--- /dev/null
+++ b/editors/xemacs-devel-mule/files/patch-xgccache.c
@@ -0,0 +1,17 @@
+Index: src/xgccache.c
+===================================================================
+RCS file: /pack/xemacscvs/XEmacs/xemacs/src/xgccache.c,v
+retrieving revision 1.13
+diff -u -r1.13 xgccache.c
+--- src/xgccache.c 2005/11/26 11:46:11 1.13
++++ src/xgccache.c 2006/02/16 20:18:18
+@@ -233,7 +233,9 @@
+ cache->head = cell->next;
+ cache->head->prev = 0;
+ if (cache->tail == cell) cache->tail = 0; /* only one */
++#if 0
+ debug_out ("Cache full, freeing GC: %08lx\n ", XE_GCONTEXT(cell));
++#endif
+ XFreeGC (cache->dpy, cell->gc);
+ cache->delete_count++;
+ #ifdef GCCACHE_HASH