aboutsummaryrefslogtreecommitdiff
path: root/editors/xemacs-packages
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2004-01-22 11:06:02 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2004-01-22 11:06:02 +0000
commitfbd1108f49e97dfa6bd38fe69dc8f6b8ab89bb26 (patch)
tree9b742ae12218d8cfd77191127558a0c126be4516 /editors/xemacs-packages
parent4bf1b98ed95c044ceb91201095348dd7ef4787f9 (diff)
downloadports-fbd1108f49e97dfa6bd38fe69dc8f6b8ab89bb26.tar.gz
ports-fbd1108f49e97dfa6bd38fe69dc8f6b8ab89bb26.zip
Notes
Diffstat (limited to 'editors/xemacs-packages')
-rw-r--r--editors/xemacs-packages/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/editors/xemacs-packages/Makefile b/editors/xemacs-packages/Makefile
index 1a66faf4212d..663aa9338c85 100644
--- a/editors/xemacs-packages/Makefile
+++ b/editors/xemacs-packages/Makefile
@@ -144,8 +144,10 @@ do-install:
post-install:
@cd ${WRKDIR} && \
- ${FIND} ${PACKAGES_SUBDIR} -type f|sort|${SED} 's:^:lib/xemacs/:' >> ${TMPPLIST}; \
- ${FIND} ${PACKAGES_SUBDIR}/*/* -type d|sort -r|${SED} 's:^:@dirrm lib/xemacs/:'>> ${TMPPLIST}
+ ${FIND} ${PACKAGES_SUBDIR} -type f|${SORT}| \
+ ${SED} 's:^:lib/xemacs/:' >> ${TMPPLIST}; \
+ ${FIND} ${PACKAGES_SUBDIR}/*/* -type d|${SORT} -r| \
+ ${SED} 's:^:@dirrm lib/xemacs/:'>> ${TMPPLIST}
@${ECHO_CMD} '@unexec rmdir %D/lib/xemacs/${PACKAGES_SUBDIR}/* 2>/dev/null || true' >> ${TMPPLIST}
@${ECHO_CMD} '@unexec rmdir %D/lib/xemacs/${PACKAGES_SUBDIR} 2>/dev/null || true' >> ${TMPPLIST}
@${ECHO_CMD} '@unexec rmdir %D/lib/xemacs 2>/dev/null || true' >> ${TMPPLIST}