aboutsummaryrefslogtreecommitdiff
path: root/editors/xemacs21/Makefile
diff options
context:
space:
mode:
authorGary Jennejohn <gj@FreeBSD.org>1999-10-14 21:47:04 +0000
committerGary Jennejohn <gj@FreeBSD.org>1999-10-14 21:47:04 +0000
commit89980f4fd705a99bf230bebc3d19e3b299f992f2 (patch)
tree0380f8710e97db234e6453f8074ebdc50d298ff8 /editors/xemacs21/Makefile
parent26cdb8cc432a854302a1eb4ba95eef1f29c2ac77 (diff)
downloadports-89980f4fd705a99bf230bebc3d19e3b299f992f2.tar.gz
ports-89980f4fd705a99bf230bebc3d19e3b299f992f2.zip
Notes
Diffstat (limited to 'editors/xemacs21/Makefile')
-rw-r--r--editors/xemacs21/Makefile19
1 files changed, 5 insertions, 14 deletions
diff --git a/editors/xemacs21/Makefile b/editors/xemacs21/Makefile
index 807a751a3fea..d8dc67377baa 100644
--- a/editors/xemacs21/Makefile
+++ b/editors/xemacs21/Makefile
@@ -6,7 +6,7 @@
# $FreeBSD$
#
-DISTNAME= xemacs-21.1.2
+DISTNAME= xemacs-21.1.6
PKGNAME= xemacs-21.1
CATEGORIES= editors
MASTER_SITES= \
@@ -24,7 +24,7 @@ LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.3:${PORTSDIR}/graphics/png
-XEMACS_VER= 21.1-p2
+XEMACS_VER= 21.1.6
DIST_SUBDIR= xemacs
USE_GMAKE= yes
@@ -38,18 +38,16 @@ CONFIGURE_ARGS= ${XEMACS_ARCH} --prefix=${PREFIX} \
--site-includes=${PREFIX}/include \
--site-libraries=${PREFIX}/lib \
--with-session=yes \
- ${WITH_XFACE} ${WITH_MULE} ${WITH_DIALOGS} ${WITH_OFFIX}
+ --with-png=yes \
+ ${WITH_XFACE} ${WITH_DIALOGS} ${WITH_OFFIX}
MAN1= ctags.1 etags.1 gnuattach.1 gnuclient.1 gnudoit.1 \
gnuserv.1 xemacs.1
ALL_TARGET= all dist
PLIST_SUB= XEMACS_VER=${XEMACS_VER} XEMACS_ARCH=${XEMACS_ARCH}
-# Have
pre-fetch:
-.if !defined(USE_MULE)
- @${ECHO_MSG} "To compile in the MULE features, set the environment variable USE_MULE"
-.endif
+ @${ECHO_MSG} "If you want the MULE features, please use the xemacs-mule port"
.if defined(HAVE_MOTIF)
.if !defined(MOTIF_STATIC)
@${ECHO_MSG} ""
@@ -60,12 +58,6 @@ pre-fetch:
.endif
.endif
-.if defined(USE_MULE)
-WITH_MULE= --with-mule
-# MULEDISTFILE= ${DISTNAME}-mule.tar.gz
-# PLIST= ${PKGDIR}/PLIST.mule
-.endif
-
# hack to avoid shipping binaries linked with Motif
.if defined(MOTIF_STATIC)
WITH_DIALOGS= --with-dialogs=athena
@@ -85,7 +77,6 @@ post-install:
.endfor
# ``make install'' does not set the permissions like pkg_add does.
${CHMOD} 1777 /var/run/emacs/lock
-# ${MKDIR} ${PREFIX}/lib/xemacs
${RM} -f ${PREFIX}/bin/send-pr
# install xemacs21.sh into ${PREFIX}/etc/rc.d
@if [ ! -d ${PREFIX}/etc/rc.d ]; then ${MKDIR} ${PREFIX}/etc/rc.d; fi