aboutsummaryrefslogtreecommitdiff
path: root/editors/xemacs
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /editors/xemacs
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'editors/xemacs')
-rw-r--r--editors/xemacs/Makefile7
-rw-r--r--editors/xemacs/files/patch-src__glyphs-eimage.c10
2 files changed, 14 insertions, 3 deletions
diff --git a/editors/xemacs/Makefile b/editors/xemacs/Makefile
index b4eff16e82da..ad1350cbe8a2 100644
--- a/editors/xemacs/Makefile
+++ b/editors/xemacs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xemacs
PORTVERSION= ${XEMACS_VER}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_XEMACS}
MASTER_SITE_SUBDIR= xemacs-${XEMACS_REL}
@@ -91,11 +91,12 @@ CONFIGURE_ARGS+= --without-postgresql
RUN_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/etc/enriched.doc:${PORTSDIR}/editors/xemacs-packages
.endif
.if !defined(WITHOUT_X11)
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png \
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
CONFIGURE_ARGS+= --with-png --with-jpeg --with-tiff
-USE_XORG= xpm x11
+USE_XORG= xpm x11 xbitmaps xaw
+CFLAGS+= -I${LOCALBASE}/include/libpng15
.if !defined(WITHOUT_MOTIF) && !defined(MOTIF_STATIC)
USE_MOTIF= yes
WITH_SCROLLBARS= --with-scrollbars=motif
diff --git a/editors/xemacs/files/patch-src__glyphs-eimage.c b/editors/xemacs/files/patch-src__glyphs-eimage.c
new file mode 100644
index 000000000000..fc854bd37715
--- /dev/null
+++ b/editors/xemacs/files/patch-src__glyphs-eimage.c
@@ -0,0 +1,10 @@
+--- src/glyphs-eimage.c.orig 2007-08-20 21:52:28.000000000 +0200
++++ src/glyphs-eimage.c 2012-05-02 20:05:31.000000000 +0200
+@@ -65,6 +65,7 @@
+ extern "C" {
+ #endif
+ #include <png.h>
++#include <pngpriv.h>
+ #ifdef __cplusplus
+ }
+ #endif