aboutsummaryrefslogtreecommitdiff
path: root/editors/xvile/Makefile
diff options
context:
space:
mode:
authorGary Jennejohn <gj@FreeBSD.org>1997-09-06 19:58:13 +0000
committerGary Jennejohn <gj@FreeBSD.org>1997-09-06 19:58:13 +0000
commit69dc23787512ef1116d262eab895ccf3164a9626 (patch)
treed3075de077b058a0cf11918569b2b7a35215d121 /editors/xvile/Makefile
parent2b5260cd929730a14f8f7ce2d5a2b3fc9d89677d (diff)
downloadports-69dc23787512ef1116d262eab895ccf3164a9626.tar.gz
ports-69dc23787512ef1116d262eab895ccf3164a9626.zip
Notes
Diffstat (limited to 'editors/xvile/Makefile')
-rw-r--r--editors/xvile/Makefile29
1 files changed, 23 insertions, 6 deletions
diff --git a/editors/xvile/Makefile b/editors/xvile/Makefile
index 67fce9a43dc5..6c8796e5ca55 100644
--- a/editors/xvile/Makefile
+++ b/editors/xvile/Makefile
@@ -1,22 +1,39 @@
# New ports collection makefile for: xvile
-# Version required: 7.1
+# Version required: 7.2
# Date created: Wed Nov 26, 1996
# Whom: pgf
#
-# $Id: Makefile,v 1.11 1996/12/03 12:53:38 obrien Exp $
+# $Id: Makefile,v 1.12 1997/06/17 20:11:58 gj Exp $
#
-DISTNAME= vile-7.1
-PKGNAME= xvile-7.1
+DISTNAME= vile-7.2
+PKGNAME= xvile-7.2
CATEGORIES= editors
-MASTER_SITES= ftp://ftp.clark.net/pub/dickey/vile/
+MASTER_SITES= ftp://ftp.clark.net/pub/dickey/vile/ \
+ ftp://id.wing.net/pub/pgf/vile/
EXTRACT_SUFX= .tgz
MAINTAINER= gj@freebsd.org
MAKEFILE= makefile
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-screen=x11
+CONFIGURE_ARGS= --with-screen=${SCREEN_TYPE}
MAN1= xvile.1
+pre-configure:
+ @echo "To use xvile with menus, set the environment variable USE_MENUS"
+
+.if defined(USE_MENUS)
+SCREEN_TYPE= Xaw
+.else
+SCREEN_TYPE= x11
+.endif
+
+post-install:
+ @echo "You might want to copy the *.rc files from the source tree before"
+ @echo "doing \`make clean'."
+.if defined(USE_MENUS)
+ @echo "And also take a look at README.MENU !"
+.endif
+
.include <bsd.port.mk>