aboutsummaryrefslogtreecommitdiff
path: root/editors/yui
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-05-27 15:13:08 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-05-27 15:13:08 +0000
commitbb93d89713042af656ca44fb2168f4dbf9a0bef1 (patch)
tree5ee87d5c839524fbbdb2a2423812f43ab7713b26 /editors/yui
parentdb8bdbb2e128459793e920e5cbe5fcf645c69945 (diff)
downloadports-bb93d89713042af656ca44fb2168f4dbf9a0bef1.tar.gz
ports-bb93d89713042af656ca44fb2168f4dbf9a0bef1.zip
Notes
Diffstat (limited to 'editors/yui')
-rw-r--r--editors/yui/Makefile24
-rw-r--r--editors/yui/files/patch-Makefile.in22
-rw-r--r--editors/yui/pkg-plist1
3 files changed, 30 insertions, 17 deletions
diff --git a/editors/yui/Makefile b/editors/yui/Makefile
index 84dd2d0abdb8..f011400d3cd9 100644
--- a/editors/yui/Makefile
+++ b/editors/yui/Makefile
@@ -10,33 +10,23 @@ MASTER_SITES= http://www.sheltonsoft.ru/fileZ/software/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Rich-featured multi-windows console text editor
-USE_BZIP2= yes
+USES= tar:bzip2
USE_AUTOTOOLS= autoconf aclocal
ACLOCAL_ARGS+= -I m4
-
MAKE_ENV+= LIBPATH=${PREFIX}/lib
-MAN1= y.1
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+BROKEN_sparc64= Does not compile on sparc64
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
+.include <bsd.port.options.mk>
post-install:
- ${LN} -sf ${PREFIX}/lib/yui/help_eng.html ${PREFIX}/lib/yui/yhelp.html
-
+ ${LN} -sf ${STAGEDIR}${PREFIX}/lib/yui/help_eng.html ${PREFIX}/lib/yui/yhelp.html
.if $(PORT_OPTIONS:MDOCS)
-
- @${MKDIR} ${DOCSDIR}
-
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in BUGS CHANGES COPYRIGHT TODO COPYRIGHT.ITK THANKS
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/yui/files/patch-Makefile.in b/editors/yui/files/patch-Makefile.in
new file mode 100644
index 000000000000..e4a63d644296
--- /dev/null
+++ b/editors/yui/files/patch-Makefile.in
@@ -0,0 +1,22 @@
+--- Makefile.in.orig 2014-05-27 23:10:08.284230405 +0800
++++ Makefile.in 2014-05-27 23:10:49.067246053 +0800
+@@ -77,12 +77,12 @@ dist: realclean
+ && $(MV) $(DSTNAME).tar.bz2 $(HOMEDIR)/backup/current)
+
+ install: all
+- $(INSTALL) -d -m 755 $(INSTDIR)
+- $(INSTALL) -d -m 755 $(MANDIR)/man1
+- $(INSTALL) -d -m 755 $(LIBDIR)/yui
++ $(INSTALL) -d -m 755 $(DESTDIR)$(INSTDIR)
++ $(INSTALL) -d -m 755 $(DESTDIR)$(MANDIR)/man1
++ $(INSTALL) -d -m 755 $(DESTDIR)$(LIBDIR)/yui
+ $(STRIP) tyui/y
+- $(INSTALL) -m 755 tyui/y $(INSTDIR)/y
+- $(INSTALL) -m 644 y.1 $(MANDIR)/man1/y.1
++ $(INSTALL) -m 755 tyui/y $(DESTDIR)$(INSTDIR)/y
++ $(INSTALL) -m 644 y.1 $(DESTDIR)$(MANDIR)/man1/y.1
+ for _doc in $(FILES) ; do cd doc && $(SED) -e s!@LIBPATH@!$(LIBPATH)!g \
+- < $$_doc.in > $(LIBDIR)/yui/$$_doc && cd ..; done
+- -cd $(LIBDIR)/yui && $(LN) -s help_eng.html yhelp.html
++ < $$_doc.in > $(DESTDIR)$(LIBDIR)/yui/$$_doc && cd ..; done
++ -cd $(DESTDIR)$(LIBDIR)/yui && $(LN) -s help_eng.html yhelp.html
diff --git a/editors/yui/pkg-plist b/editors/yui/pkg-plist
index 2c71cf9838e6..49a5fa45a4ce 100644
--- a/editors/yui/pkg-plist
+++ b/editors/yui/pkg-plist
@@ -10,6 +10,7 @@ lib/yui/highlight_html
lib/yui/keymap
lib/yui/options
lib/yui/yhelp.html
+man/man1/y.1.gz
%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT