aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-22 08:31:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-22 08:31:01 +0000
commit0616a86b3cd8577c89c3478bebbdb448bc41d1e4 (patch)
treefc11dd0ebbc5f20405a6b8c35d43f1dd3e4a357e /editors
parent000cebd64d68a4e2f7e7e45639e3e3d05e0d1da9 (diff)
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/qemacs/Makefile62
-rw-r--r--editors/qemacs/distinfo6
-rw-r--r--editors/qemacs/files/patch-Makefile35
-rw-r--r--editors/qemacs/files/patch-charset.c11
-rw-r--r--editors/qemacs/files/patch-configure11
-rw-r--r--editors/qemacs/files/patch-tty.c11
-rw-r--r--editors/qemacs/files/patch-x11.c11
-rw-r--r--editors/qemacs/pkg-descr45
-rw-r--r--editors/qemacs/pkg-plist5
9 files changed, 118 insertions, 79 deletions
diff --git a/editors/qemacs/Makefile b/editors/qemacs/Makefile
index 2e18aa75652c..6b892275acec 100644
--- a/editors/qemacs/Makefile
+++ b/editors/qemacs/Makefile
@@ -6,22 +6,26 @@
#
PORTNAME= qemacs
-PORTVERSION= 0.3.p.12
-PORTREVISION= 1
+PORTVERSION= 0.3.1
CATEGORIES= editors
MASTER_SITES= http://fabrice.bellard.free.fr/qemacs/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p./pre/}
MAINTAINER= ports@FreeBSD.org
-COMMENT= QEmacs (for Quick Emacs) is a very small but powerful UNIX editor
-
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+COMMENT= Quick Emacs - a very small but powerful UNIX editor
USE_GMAKE= yes
-USE_XLIB= yes
-MAKE_ARGS+= CFLAGS="${CFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix="${PREFIX}" --make="${GMAKE}" --cc="${CC}" \
+ --extra-cflags="${CFLAGS}" --extra-ldflags="${LDFLAGS}"
+
+DATADIR= ${PREFIX}/share/qe
+
MAN1= qe.1
+MLINKS= qe.1 qemacs.1
+PORTDOCS= qe-doc.html
+PLIST_FILES= bin/html2png bin/qe bin/qemacs \
+ %%DATADIR%%/kmaps %%DATADIR%%/ligatures
+PLIST_DIRS= %%DATADIR%%
.include <bsd.port.pre.mk>
@@ -29,13 +33,45 @@ MAN1= qe.1
IGNORE= crashes on startup
.endif
+.if defined(WITHOUT_PNG)
+CONFIGURE_ARGS+= --disable-png
+.else
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+CFLAGS+= `libpng-config --I_opts`
+LDFLAGS= `libpng-config --L_opts`
+.endif
+
+.if defined(WITHOUT_X11)
+PKGNAMESUFFIX= -nox11
+CONFIGURE_ARGS+= --disable-x11
+.else
+USE_XLIB= yes
+CFLAGS+= -I${X11BASE}/include
+LDFLAGS+= -L${X11BASE}/lib
+.endif
+
post-patch:
- ${REINPLACE_CMD} -e 's,HOST_CC,CC,g' ${WRKSRC}/Makefile
+ @${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-Wall -g|-Wall|g ; \
+ s|-m.*386||g ; \
+ s|-ldl||g ; \
+ s|-L/usr/X11R6/lib||g ; \
+ s|make -C|$$(MAKE) -C|g ; \
+ s|HOST_CC|CC|g'
+ @${REINPLACE_CMD} -e 's|/usr/share/doc/qemacs/|${DOCSDIR}/|g ; \
+ s|README.gz|qe-doc.html|g' ${WRKSRC}/qe.1
do-install:
- cd ${WRKSRC}; ${INSTALL_PROGRAM} qe html2png ${PREFIX}/bin
- ${MKDIR} ${DATADIR:S/qemacs/qe/}
- cd ${WRKSRC}; ${INSTALL_DATA} kmaps ligatures ${DATADIR:S/qemacs/qe/}
+ ${INSTALL_PROGRAM} ${WRKSRC}/html2png ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/qe ${PREFIX}/bin
+ ${LN} -sf qe ${PREFIX}/bin/qemacs
${INSTALL_MAN} ${WRKSRC}/qe.1 ${MANPREFIX}/man/man1
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/kmaps ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/ligatures ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/qe-doc.html ${DOCSDIR}
+.endif
.include <bsd.port.post.mk>
diff --git a/editors/qemacs/distinfo b/editors/qemacs/distinfo
index 891c73a1e245..9ec3b68298cc 100644
--- a/editors/qemacs/distinfo
+++ b/editors/qemacs/distinfo
@@ -1,3 +1,3 @@
-MD5 (qemacs-0.3pre12.tar.gz) = 9768b5439ab73d185e18503b0dbf337f
-SHA256 (qemacs-0.3pre12.tar.gz) = b9b00421bc463247cd77d17fc425f065069e9aaeb29894daf0cb08b31594a15f
-SIZE (qemacs-0.3pre12.tar.gz) = 775218
+MD5 (qemacs-0.3.1.tar.gz) = 74d85dee9861d494bf1f9c53bbc85298
+SHA256 (qemacs-0.3.1.tar.gz) = a3db57e09729d8c83be5ff9ab028ece173d8f5f10aaf61ca41f88aecb64996c7
+SIZE (qemacs-0.3.1.tar.gz) = 809124
diff --git a/editors/qemacs/files/patch-Makefile b/editors/qemacs/files/patch-Makefile
deleted file mode 100644
index dc8d946d5a28..000000000000
--- a/editors/qemacs/files/patch-Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
---- Makefile.orig Thu May 2 02:27:40 2002
-+++ Makefile Fri Nov 24 15:53:28 2006
-@@ -42,17 +42,17 @@
- #
- CONFIG_PNG_OUTPUT=y
-
--HOST_CC=gcc
--CC=$(HOST_CC)
-+HOST_CC?=gcc
-+CC?=$(HOST_CC)
- PROFILE=
--CFLAGS=-Wall -O2 -g $(PROFILE)
-+CFLAGS?=-Wall -O2 -g $(PROFILE)
- #CFLAGS+=-fomit-frame-pointer
- #CPU dependent flags
--CFLAGS+=-m386 -malign-functions=0
--LDFLAGS= $(PROFILE)
-+#CFLAGS+=-m386 -malign-functions=0
-+LDFLAGS?= $(PROFILE)
- STRIP=strip -s -R .comment -R .note
- DEFINES=
--prefix=/usr/local
-+prefix?=/usr/local
-
- ########################################################
- # do not modify after this
-@@ -136,7 +136,7 @@
- DEFINES+= -DCONFIG_XFT
- LIBS+=-lXft
- endif
--LIBS+= -L/usr/X11R6/lib -lXext -lX11
-+LIBS+= -L$(X11BASE)/lib -lXext -lX11
- endif
-
- ifdef CONFIG_HTML
diff --git a/editors/qemacs/files/patch-charset.c b/editors/qemacs/files/patch-charset.c
new file mode 100644
index 000000000000..d8796d70e349
--- /dev/null
+++ b/editors/qemacs/files/patch-charset.c
@@ -0,0 +1,11 @@
+--- charset.c.orig Tue Apr 22 07:01:42 2003
++++ charset.c Thu Jan 18 13:56:10 2007
+@@ -20,7 +20,7 @@
+
+ QECharset *first_charset = NULL;
+
+-extern QECharset charset_7bit;
++static QECharset charset_7bit;
+
+ /* specific tables */
+ static unsigned short table_idem[256];
diff --git a/editors/qemacs/files/patch-configure b/editors/qemacs/files/patch-configure
new file mode 100644
index 000000000000..6a141f1d05d9
--- /dev/null
+++ b/editors/qemacs/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Apr 22 07:01:43 2003
++++ configure Thu Jan 18 12:39:56 2007
+@@ -311,7 +311,7 @@
+ head $source_path/VERSION >>config.mak
+ echo "" >>config.mak
+ echo -n "#define QE_VERSION \"" >> $TMPH
+-head $source_path/VERSION >> $TMPH
++echo -n `head $source_path/VERSION` >> $TMPH
+ echo "\"" >> $TMPH
+ if test "$network" = "yes" ; then
+ echo "#define CONFIG_NETWORK 1" >> $TMPH
diff --git a/editors/qemacs/files/patch-tty.c b/editors/qemacs/files/patch-tty.c
new file mode 100644
index 000000000000..36726f020dd5
--- /dev/null
+++ b/editors/qemacs/files/patch-tty.c
@@ -0,0 +1,11 @@
+--- tty.c.orig Tue Apr 22 07:01:42 2003
++++ tty.c Thu Jan 18 13:56:41 2007
+@@ -70,7 +70,7 @@
+ return 1;
+ }
+
+-extern QEDisplay tty_dpy;
++static QEDisplay tty_dpy;
+
+ static int term_init(QEditScreen *s, int w, int h)
+ {
diff --git a/editors/qemacs/files/patch-x11.c b/editors/qemacs/files/patch-x11.c
new file mode 100644
index 000000000000..2e0654fbf9be
--- /dev/null
+++ b/editors/qemacs/files/patch-x11.c
@@ -0,0 +1,11 @@
+--- x11.c.orig Tue Apr 22 07:01:42 2003
++++ x11.c Thu Jan 18 13:57:10 2007
+@@ -76,7 +76,7 @@
+ static CSSRect update_rects[UPDATE_MAX_REGIONS];
+ #endif
+
+-extern QEDisplay x11_dpy;
++static QEDisplay x11_dpy;
+ static int visual_depth;
+
+ static int force_tty = 0;
diff --git a/editors/qemacs/pkg-descr b/editors/qemacs/pkg-descr
index 509d6ce7c20e..15b12eebf878 100644
--- a/editors/qemacs/pkg-descr
+++ b/editors/qemacs/pkg-descr
@@ -1,24 +1,23 @@
QEmacs has features other big editors lack:
-* Full screen editor with an Emacs look and feel with all Emacs common features:
-multi-buffer, multi-window, command mode, universal argument, keyboard macros,
-config file with C like syntax, minibuffer with completion and history.
-* Can edit files of hundreds of Megabytes without being slow by using a highly
-optimized internal representation and by mmaping the file.
-* Full Unicode support, including multi charset handling (8859-x, UTF8, SJIS,
-EUC-JP, ...) and bidirectional editing respecting the Unicode bidi algorithm.
-Arabic and Indic scripts handling (in progress).
-* WYSIWYG HTML/XML/CSS2 mode graphical editing. Also supports lynx like
-rendering on VT100 terminals.
-* WYSIWYG DocBook mode based on XML/CSS2 renderer.
-* C mode: coloring with immediate update. Emacs like auto-indent.
-* Shell mode: colorized VT100 emulation so that your shell work exactly as you
-expect. Compile mode with next/prev error.
-* Input methods for most languages, including Chinese (input methods come from
-the Yudit editor).
-* Hexadecimal editing mode with insertion and block commands. Unicode hexa
-editing is also supported.
-* Works on any VT100 terminals without termcap. UTF8 VT100 support included
-with double width glyphs.
-* Small! Full version (including HTML/XML/CSS2/DocBook rendering and all
-charsets): 200KB big. Basic version (without bidir/unicode
-scripts/input/X11/C/Shell/HTML/dired): 49KB.
+* Full screen editor with an Emacs look and feel with all Emacs common
+ features: multi-buffer, multi-window, command mode, universal argument,
+ keyboard macros, config file with C like syntax, minibuffer with
+ completion and history.
+* Can edit files of hundreds of Megabytes without being slow by using a
+ highly optimized internal representation and by mmaping the file.
+* Full UTF8 support, including bidirectional editing respecting the Unicode
+ bidi algorithm. Arabic and Indic scripts handling (in progress).
+* C mode: coloring with immediate update. Emacs like auto-indent.
+* Shell mode: colorized VT100 emulation so that your shell work exactly as
+ you expect. Compile mode with next/prev error.
+* Input methods for most languages, including Chinese (input methods come
+ from the Yudit editor).
+* Hexadecimal editing mode with insertion and block commands. Unicode hexa
+ editing of UTF8 files also supported.
+* Works on any VT100 terminals without termcap. UTF8 VT100 support included
+ with double width glyphs.
+* X11 support. Support multiple proportionnal fonts at the same time (as
+ XEmacs). X Input methods supported. Xft extension supported for anti
+ aliased font display.
+
+WWW: http://fabrice.bellard.free.fr/qemacs/
diff --git a/editors/qemacs/pkg-plist b/editors/qemacs/pkg-plist
deleted file mode 100644
index e9089bd3f388..000000000000
--- a/editors/qemacs/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/html2png
-bin/qe
-share/qe/kmaps
-share/qe/ligatures
-@dirrm share/qe