aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 13:06:42 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 13:06:42 +0000
commit9dff3523203bdda7ae358dcff3eb5a5ef3e54d33 (patch)
tree0721b637b4bcfc0a8ff2a945bdcb7e68f8993680 /editors
parent2e4b740f2cc9a250b2c6056d8706e15d3bfa9763 (diff)
downloadports-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.tar.gz
ports-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.zip
Fix every instance of RUN_DEPENDS:=${BUILD_DEPENDS} in p5 ports, except
for where it resulted in a change in output from build-depends-list or run-depends-list. Approved by: portmgr (adamw)
Notes
Notes: svn path=/head/; revision=481365
Diffstat (limited to 'editors')
-rw-r--r--editors/p5-Padre/Makefile6
-rw-r--r--editors/p5-Proc-InvokeEditor/Makefile4
2 files changed, 5 insertions, 5 deletions
diff --git a/editors/p5-Padre/Makefile b/editors/p5-Padre/Makefile
index 7d847df9781a..689c0d284898 100644
--- a/editors/p5-Padre/Makefile
+++ b/editors/p5-Padre/Makefile
@@ -17,7 +17,9 @@ LICENSE_COMB= dual
LICENSE_FILE_ART10= ${WRKSRC}/Artistic
LICENSE_FILE_GPLv1+ = ${WRKSRC}/COPYING
-BUILD_DEPENDS= p5-Algorithm-Diff>=1.19:devel/p5-Algorithm-Diff \
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ p5-Module-Build>=0.36:devel/p5-Module-Build
+RUN_DEPENDS= p5-Algorithm-Diff>=1.19:devel/p5-Algorithm-Diff \
p5-App-cpanminus>=0.9923:devel/p5-App-cpanminus \
p5-CGI>=3.47:www/p5-CGI \
p5-Capture-Tiny>0:devel/p5-Capture-Tiny \
@@ -64,8 +66,6 @@ BUILD_DEPENDS= p5-Algorithm-Diff>=1.19:devel/p5-Algorithm-Diff \
p5-Wx>=0.9700:x11-toolkits/p5-Wx \
p5-YAML-Tiny>=1.32:textproc/p5-YAML-Tiny \
p5-libwww>=5.815:www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-BUILD_DEPENDS+= p5-Module-Build>=0.36:devel/p5-Module-Build
USES= compiler:c++11-lib dos2unix gettext perl5
USE_PERL5= configure
diff --git a/editors/p5-Proc-InvokeEditor/Makefile b/editors/p5-Proc-InvokeEditor/Makefile
index 78c6d39c665c..581f73a77e5e 100644
--- a/editors/p5-Proc-InvokeEditor/Makefile
+++ b/editors/p5-Proc-InvokeEditor/Makefile
@@ -14,8 +14,8 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-Carp-Assert>=0:devel/p5-Carp-Assert
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Carp-Assert>=0:devel/p5-Carp-Assert
NO_ARCH= yes
USES= perl5