aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorAlexandre C. GuimarĂ£es <rigoletto@FreeBSD.org>2018-10-14 18:28:00 +0000
committerAlexandre C. GuimarĂ£es <rigoletto@FreeBSD.org>2018-10-14 18:28:00 +0000
commita4b80a6ec880475e8d43515f92c69bcffec35e36 (patch)
tree43bed100280e2e362c16d92291eea21c1e26298b /editors
parentd17eb8ba62d9dde94d9529ec2a2246cc3aa2314b (diff)
downloadports-a4b80a6ec880475e8d43515f92c69bcffec35e36.tar.gz
ports-a4b80a6ec880475e8d43515f92c69bcffec35e36.zip
editors/texworks: Update to version 0.6.2.
Texworks is available now as Qt5 only because the upcoming poppler update will not include a Qt4 version. PR: 200302 Submitted by: tkato432@yahoo.com (original version) Reviewed by: mat (mentor) Approved by: tcberner (mentor), hrs (maintainer, timeout) Differential Revision: https://reviews.freebsd.org/D17177
Notes
Notes: svn path=/head/; revision=482104
Diffstat (limited to 'editors')
-rw-r--r--editors/texworks/Makefile105
-rw-r--r--editors/texworks/distinfo5
-rw-r--r--editors/texworks/files/patch-TeXworks.pro44
3 files changed, 31 insertions, 123 deletions
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index eec1eaa0a2a9..3b483912a315 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -2,101 +2,52 @@
# $FreeBSD$
PORTNAME= texworks
-PORTVERSION= 0.4.6
DISTVERSIONPREFIX= release-
-PORTREVISION= 7
+DISTVERSION= 0.6.2
CATEGORIES= editors
MAINTAINER= hrs@FreeBSD.org
COMMENT= Simple TeX front-end program
-LICENSE= GPLv2
-
-BROKEN_armv6= fails to install: PDFDocument.cpp:1836:39: cannot initialize a parameter of type 'qreal *' with an rvalue of type 'double *'
-BROKEN_armv7= fails to install: PDFDocument.cpp:1836:39: cannot initialize a parameter of type 'qreal *' with an rvalue of type 'double *'
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= hunspell:textproc/hunspell
-LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4
+LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell \
+ libpoppler.so:graphics/poppler \
+ libpoppler-qt5.so:graphics/poppler-qt5
-USES= compiler:c++11-lang pkgconfig qmake qt:4
+USES= cmake:outsource desktop-file-utils pkgconfig qt:5
USE_GITHUB= yes
GH_ACCOUNT= TeXworks
-USE_QT= gui corelib rcc_build moc_build uic_build \
- dbus xml scripttools designer_build
-QMAKE_ARGS= INSTALL_PREFIX=${PREFIX} \
- DATA_DIR=${DATADIR} \
- DOCS_DIR=${DOCSDIR} \
- ICON_DIR=${PREFIX}/share/pixmaps \
- DESKTOP_DIR=${PREFIX}/share/applications \
- MAN_DIR=${PREFIX}/man/man1 \
- TW_DICPATH=${LOCALBASE}/share/hunspell \
- TW_HELPPATH=${DOCSDIR} \
- TW_PLUGINPATH=${PREFIX}/lib/texworks
+USE_QT= buildtools_build designer_build qmake_build \
+ core concurrent dbus gui linguisttools script \
+ scripttools uitools widgets xml
+
USE_TEX= synctex
+USE_LDCONFIG= yes
-DESKTOP_ENTRIES="TexWorks" \
- "Lowering the entry barrier to the TeX world" \
- "TeXworks" \
- "${PORTNAME}" \
- "Utility;Qt;" \
- true
-
-PLIST_FILES= bin/texworks \
- man/man1/texworks.1.gz \
- share/pixmaps/TeXworks.png
-PLIST_DIRS= lib/texworks
-PORTDOCS= *
+CMAKE_ARGS= -DTeXworks_DIC_DIR:PATH=${LOCALBASE}/share/hunspell \
+ -DTeXworks_DOCS_DIR:PATH=${DOCSDIR_REL} \
+ -DTeXworks_HELP_DIR:PATH=${DOCSDIR_REL} \
+ -DTeXworks_MAN_DIR:PATH=man/man1
OPTIONS_DEFINE= DOCS LUA PYTHON
-LUA_USES= lua:51
-LUA_PLIST_FILES=lib/texworks/libTWLuaPlugin.so
-PYTHON_USES= python:3.4+
-PYTHON_PLIST_FILES=lib/texworks/libTWPythonPlugin.so
-
-post-extract:
- cd ${WRKSRC} && ${INSTALL_DATA} GitArchiveInfo.txt src/GitRev.h
-
-post-patch:
- @${REINPLACE_CMD} -e 's,/usr/share,${LOCALBASE}/share,' \
- ${WRKSRC}/src/TWUtils.cpp
- @${REINPLACE_CMD} -e 's,lua5.1,lua-5.1,' \
- ${WRKSRC}/plugins-src/TWLuaPlugin/TWLuaPlugin.pro
- @${REINPLACE_CMD} -e '53,54s,^,#,' \
- -e '57,59s,#,,' \
- -e 's,python3,python-${PYTHON_VER},' \
- ${WRKSRC}/plugins-src/TWPythonPlugin/TWPythonPlugin.pro
-post-patch-DOCS-off:
- @${REINPLACE_CMD} -e '/INSTALLS/s,documentation manual ,,' \
- ${WRKSRC}/TeXworks.pro
+LUA_USES= lua
+LUA_CMAKE_BOOL= WITH_LUA
+LUA_PLIST_FILES= lib/texworks/libTWLuaPlugin.so
-post-configure-LUA-on:
- cd ${WRKSRC}/plugins-src/TWLuaPlugin && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKE_ARGS}
+PYTHON_USES= python:3.4+
+PYTHON_CMAKE_BOOL= WITH_PYTHON
+PYTHON_PLIST_FILES= lib/texworks/libTWPythonPlugin.so
-post-configure-PYTHON-on:
- cd ${WRKSRC}/plugins-src/TWPythonPlugin && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKE_ARGS}
-
-post-build-LUA-on:
- cd ${WRKSRC}/plugins-src/TWLuaPlugin && ${MAKE}
-
-post-build-PYTHON-on:
- cd ${WRKSRC}/plugins-src/TWPythonPlugin && ${MAKE}
-
-post-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/texworks
-
-post-install-LUA-on:
- ${MKDIR} ${STAGEDIR}${PREFIX}/lib/texworks
- cd ${WRKSRC}/plugins-src/TWLuaPlugin && \
- ${INSTALL_DATA} libTWLuaPlugin.so \
- ${STAGEDIR}${PREFIX}/lib/texworks
+PORTDOCS= *
-post-install-PYTHON-on:
- ${MKDIR} ${STAGEDIR}${PREFIX}/lib/texworks
- cd ${WRKSRC}/plugins-src/TWPythonPlugin && \
- ${INSTALL_DATA} libTWPythonPlugin.so \
- ${STAGEDIR}${PREFIX}/lib/texworks
+PLIST_FILES= bin/texworks \
+ man/man1/texworks.1.gz \
+ share/appdata/texworks.appdata.xml \
+ share/applications/texworks.desktop \
+ share/pixmaps/TeXworks.png
.include <bsd.port.mk>
diff --git a/editors/texworks/distinfo b/editors/texworks/distinfo
index 6782f45c399f..61bf36964673 100644
--- a/editors/texworks/distinfo
+++ b/editors/texworks/distinfo
@@ -1,2 +1,3 @@
-SHA256 (TeXworks-texworks-release-0.4.6_GH0.tar.gz) = 58650574c1e3234c38cddc3375f8043a83cc65075839030fc7089471af6a3bde
-SIZE (TeXworks-texworks-release-0.4.6_GH0.tar.gz) = 11271881
+TIMESTAMP = 1536894823
+SHA256 (TeXworks-texworks-release-0.6.2_GH0.tar.gz) = 22885c11d92654b0cba1f4808fc9aa3c2fdd3e5435fd89dff9aa1e67658a6339
+SIZE (TeXworks-texworks-release-0.6.2_GH0.tar.gz) = 11508277
diff --git a/editors/texworks/files/patch-TeXworks.pro b/editors/texworks/files/patch-TeXworks.pro
deleted file mode 100644
index b1adfbbfae7a..000000000000
--- a/editors/texworks/files/patch-TeXworks.pro
+++ /dev/null
@@ -1,44 +0,0 @@
---- TeXworks.pro.orig 2015-04-03 18:05:39 UTC
-+++ TeXworks.pro
-@@ -108,7 +108,7 @@ unix:!macx { # on Unix-ish platforms we
- CONFIG += link_pkgconfig
- PKGCONFIG += hunspell
- PKGCONFIG += poppler-qt4
-- PKGCONFIG += zlib
-+ PKGCONFIG += synctex zlib
-
- # Enclose the path in \\\" (which later gets expanded to \", which in turn
- # gets expanded to " in the c++ code)
-@@ -180,8 +181,7 @@ HEADERS += src/TWApp.h \
- src/TWVersion.h \
- src/TWTextCodecs.h \
- src/SvnRev.h \
-- src/synctex_parser.h \
-- src/synctex_parser_utils.h \
-+ src/TWSynchronizer.h \
- src/ClickableLabel.h \
- src/ConfigurableApp.h \
- src/TWSystemCmd.h
-@@ -225,8 +225,7 @@ SOURCES += src/main.cpp \
- src/ResourcesDialog.cpp \
- src/ScriptManager.cpp \
- src/ConfirmDelete.cpp \
-- src/synctex_parser.c \
-- src/synctex_parser_utils.c
-+ src/TWSynchronizer.cpp
-
- RESOURCES += res/resources.qrc \
- res/resfiles.qrc
-@@ -259,10 +258,10 @@ unix:!macx { # installation on Unix-ish
- isEmpty(DESKTOP_DIR):DESKTOP_DIR = $$DATA_DIR/applications
-
- target.path = $$BIN_DIR
-- documentation.files = COPYING README NEWS
-+ documentation.files = README NEWS
- documentation.path = $$DOCS_DIR
- manual.files = manual/*
-- manual.path = $$TW_HELPPATH
-+ manual.path = DOCS_DIR
- icon.files = res/images/TeXworks.png
- icon.path = $$ICON_DIR
- man.files = man/texworks.1