aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-07-09 00:07:41 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-07-09 00:07:41 +0000
commitb092ac8f7f86aad629065211a1fa4b62a32f63ed (patch)
treeae194784fa20c5b66ef55e27c106be5991e916c3 /editors
parent7fea3f99822ffc6cde371474f73e11ef022a4e1c (diff)
downloadports-b092ac8f7f86aad629065211a1fa4b62a32f63ed.tar.gz
ports-b092ac8f7f86aad629065211a1fa4b62a32f63ed.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/qemacs/Makefile3
-rw-r--r--editors/qemacs/files/patch-qe.h22
2 files changed, 24 insertions, 1 deletions
diff --git a/editors/qemacs/Makefile b/editors/qemacs/Makefile
index c635b2d9ba01..bc8ea8fbc667 100644
--- a/editors/qemacs/Makefile
+++ b/editors/qemacs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qemacs
PORTVERSION= 0.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors
MASTER_SITES= http://fabrice.bellard.free.fr/qemacs/
@@ -18,6 +18,7 @@ USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" --make="${GMAKE}" --cc="${CC}" \
--extra-cflags="${CFLAGS}" --extra-ldflags="${LDFLAGS}"
+USE_GCC= 3.4
DATADIR= ${PREFIX}/share/qe
diff --git a/editors/qemacs/files/patch-qe.h b/editors/qemacs/files/patch-qe.h
new file mode 100644
index 000000000000..3756ddf0de61
--- /dev/null
+++ b/editors/qemacs/files/patch-qe.h
@@ -0,0 +1,22 @@
+--- qe.h.orig 2003-04-22 00:01:42.000000000 +0200
++++ qe.h 2005-06-07 16:02:27.000000000 +0200
+@@ -576,10 +576,18 @@
+
+ /* make sure that the keyword is not disabled by glibc (TINYC case) */
+ #undef __attribute__
+-
++#if __GNUC__ < 3 || (__GNUC__ == 3 && __GNUC_MINOR__ < 3)
+ /* same method as the linux kernel... */
+ #define __init_call __attribute__ ((unused,__section__ (".initcall.init")))
+ #define __exit_call __attribute__ ((unused,__section__ (".exitcall.exit")))
++#else
++#undef __attribute_used__
++#define __attribute_used__ __attribute__((__used__))
++#define __init_call __attribute_used__ __attribute__((__section__ (".initcall.init")))
++#define __exit_call __attribute_used__ __attribute__((__section__ (".exitcall.exit")))
++
++#endif
++
+
+ #define qe_module_init(fn) \
+ static int (*__initcall_##fn)(void) __init_call = fn