aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-09-27 20:42:29 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-09-27 20:42:29 +0000
commitd5ff68dac61647d9476340b0b51facb17c76b194 (patch)
treeb921af4b2b3575b0470d7ff76241dc4771510a2f /editors
parent0056a48f71cd9b258ffee402497fa0e3cdf79ace (diff)
downloadports-d5ff68dac61647d9476340b0b51facb17c76b194.tar.gz
ports-d5ff68dac61647d9476340b0b51facb17c76b194.zip
- Update to 3.1
Notes
Notes: svn path=/head/; revision=480818
Diffstat (limited to 'editors')
-rw-r--r--editors/nano/Makefile6
-rw-r--r--editors/nano/distinfo6
-rw-r--r--editors/nano/files/patch-src_nano.c11
-rw-r--r--editors/nano/files/patch-src_nano.h10
4 files changed, 6 insertions, 27 deletions
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index edd56f751613..16b2a6163371 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nano
-PORTVERSION= 3.0
-PORTREVISION= 1
+PORTVERSION= 3.1
CATEGORIES= editors
MASTER_SITES= http://www.nano-editor.org/dist/v${PORTVERSION:R}/ GNU
@@ -12,9 +11,10 @@ COMMENT= Nano's ANOther editor, an enhanced free Pico clone
LICENSE= GPLv3
+USES= charsetfix ncurses
+
CONFLICTS= nano-devel-2*
-USES= charsetfix ncurses
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --docdir=${DOCSDIR} --enable-utf8
diff --git a/editors/nano/distinfo b/editors/nano/distinfo
index 29992037322b..8897f877286d 100644
--- a/editors/nano/distinfo
+++ b/editors/nano/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1536705832
-SHA256 (nano-3.0.tar.gz) = 3f5f7713665155d9089ffde814ca89b3795104892af2ce8db2c1a70b82fa84a3
-SIZE (nano-3.0.tar.gz) = 2921245
+TIMESTAMP = 1538080224
+SHA256 (nano-3.1.tar.gz) = cc99372b6e3f38a86617143cbf5987f33641f541334070146dc2648aba1fa42f
+SIZE (nano-3.1.tar.gz) = 2923258
diff --git a/editors/nano/files/patch-src_nano.c b/editors/nano/files/patch-src_nano.c
deleted file mode 100644
index 83331be9119c..000000000000
--- a/editors/nano/files/patch-src_nano.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/nano.c.orig 2018-09-14 11:02:24 UTC
-+++ src/nano.c
-@@ -2580,7 +2580,7 @@ int main(int argc, char **argv)
- controlhome = get_keycode("kHOM5", CONTROL_HOME);
- controlend = get_keycode("kEND5", CONTROL_END);
- controldelete = get_keycode("kDC5", CONTROL_DELETE);
-- controlshiftdelete = get_keycode("kDC6", KEY_BACKSPACE);
-+ controlshiftdelete = get_keycode("kDC6", CONTROL_SHIFT_DELETE);
- #ifndef NANO_TINY
- /* Ask for the codes for Shift+Control+Left/Right/Up/Down. */
- shiftcontrolleft = get_keycode("kLFT6", SHIFT_CONTROL_LEFT);
diff --git a/editors/nano/files/patch-src_nano.h b/editors/nano/files/patch-src_nano.h
deleted file mode 100644
index fc24ecf0bfe9..000000000000
--- a/editors/nano/files/patch-src_nano.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/nano.h.orig 2018-09-14 11:02:29 UTC
-+++ src/nano.h
-@@ -588,6 +588,7 @@ enum
- #define SHIFT_CONTROL_DOWN 0x414
- #define SHIFT_CONTROL_HOME 0x415
- #define SHIFT_CONTROL_END 0x416
-+#define CONTROL_SHIFT_DELETE 0x417
- #define ALT_LEFT 0x421
- #define ALT_RIGHT 0x422
- #define ALT_UP 0x423