aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorYoichi NAKAYAMA <yoichi@FreeBSD.org>2001-12-29 12:31:30 +0000
committerYoichi NAKAYAMA <yoichi@FreeBSD.org>2001-12-29 12:31:30 +0000
commitd9bc13c68ae0bd04201f8e86e35897df38557fb2 (patch)
tree710664fa4416f244a5a90b76eb818fcd230ed94f /editors
parent66a133ef4ee06697ae89795ad1f4ff393763d8f3 (diff)
downloadports-d9bc13c68ae0bd04201f8e86e35897df38557fb2.tar.gz
ports-d9bc13c68ae0bd04201f8e86e35897df38557fb2.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/speedbar/Makefile49
-rw-r--r--editors/speedbar/distinfo1
-rw-r--r--editors/speedbar/files/patch-aa15
-rw-r--r--editors/speedbar/files/patch-ab11
-rw-r--r--editors/speedbar/pkg-comment1
-rw-r--r--editors/speedbar/pkg-descr11
-rw-r--r--editors/speedbar/pkg-plist37
8 files changed, 126 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index aae7b416c203..1e9698f055af 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -106,6 +106,7 @@
SUBDIR += semi113-emacs20
SUBDIR += semi113-mule
SUBDIR += semi113-xemacs21-mule
+ SUBDIR += speedbar
SUBDIR += staroffice5
SUBDIR += staroffice52
SUBDIR += staroffice60
diff --git a/editors/speedbar/Makefile b/editors/speedbar/Makefile
new file mode 100644
index 000000000000..b1e8f3240ae0
--- /dev/null
+++ b/editors/speedbar/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: speedbar
+# Date created: 29 December 2001
+# Whom: Kimura Fuyuki <fuyuki@mj.0038.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= speedbar
+PORTVERSION= 0.13a
+CATEGORIES= editors elisp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cedet
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+
+MAINTAINER= fuyuki@mj.0038.net
+
+EMACS_PORT_NAME?= emacs21
+
+USE_GMAKE= yes
+MAKE_ARGS= LOADPATH=.
+
+LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/speedbar
+
+# We need to recompile these el's because of some incompatible changes
+# in speedbar.
+MUST_BE_RECOMPILED= gud.el info.el rmail.el vhdl-mode.el
+
+EMACS_ARGS= -batch -l speedbar-compile-script -f batch-byte-compile
+
+pre-build:
+.for i in ${MUST_BE_RECOMPILED}
+ ${CP} `${FIND} ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/lisp -name ${i}` \
+ ${WRKSRC}
+ ${PERL} -pi -e 's/speedbar-attached-frame/dframe-attached-frame/' \
+ ${WRKSRC}/${i}
+.endfor
+
+post-build:
+ cd ${WRKSRC}; ${EMACS_CMD} ${EMACS_ARGS} ${MUST_BE_RECOMPILED}
+
+do-install:
+ ${MKDIR} ${LISPDIR}
+.for i in *.el *.elc *.xpm
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${LISPDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/speedbar.info ${PREFIX}/info
+ install-info ${PREFIX}/info/speedbar.info ${PREFIX}/info/dir
+
+.include <bsd.port.mk>
diff --git a/editors/speedbar/distinfo b/editors/speedbar/distinfo
new file mode 100644
index 000000000000..1f2b6cd09efe
--- /dev/null
+++ b/editors/speedbar/distinfo
@@ -0,0 +1 @@
+MD5 (speedbar-0.13a.tar.gz) = 5f405fba3618be0c60125982e30c2b82
diff --git a/editors/speedbar/files/patch-aa b/editors/speedbar/files/patch-aa
new file mode 100644
index 000000000000..ab28e44bbce9
--- /dev/null
+++ b/editors/speedbar/files/patch-aa
@@ -0,0 +1,15 @@
+--- speedbar.texi.orig Mon Dec 10 11:33:16 2001
++++ speedbar.texi Mon Dec 10 11:53:31 2001
+@@ -26,9 +26,10 @@
+
+ @ifinfo
+ @format
+-START-INFO-DIR-ENTRY
++@dircategory The Emacs editor and associated tools
++@direntry
+ * Speedbar: (speedbar). File/Tag summarizing utility.
+-END-INFO-DIR-ENTRY
++@end direntry
+ @end format
+ @end ifinfo
+
diff --git a/editors/speedbar/files/patch-ab b/editors/speedbar/files/patch-ab
new file mode 100644
index 000000000000..338971410f11
--- /dev/null
+++ b/editors/speedbar/files/patch-ab
@@ -0,0 +1,11 @@
+--- speedbar.el.orig Sat Dec 29 19:10:04 2001
++++ speedbar.el Sat Dec 29 19:12:09 2001
+@@ -948,6 +948,8 @@
+ (speedbar-reconfigure-keymaps)
+ (speedbar-update-contents)
+ (speedbar-set-timer dframe-update-speed)
++ (if (not window-system)
++ (select-frame speedbar-frame))
+ )
+ (set (make-local-variable 'automatic-hscrolling) nil) ; Emacs 21
+ ;; reset the selection variable
diff --git a/editors/speedbar/pkg-comment b/editors/speedbar/pkg-comment
new file mode 100644
index 000000000000..cdfdf1ea15ef
--- /dev/null
+++ b/editors/speedbar/pkg-comment
@@ -0,0 +1 @@
+Quick access to files and tags in an Emacs frame
diff --git a/editors/speedbar/pkg-descr b/editors/speedbar/pkg-descr
new file mode 100644
index 000000000000..86bd040f8b7f
--- /dev/null
+++ b/editors/speedbar/pkg-descr
@@ -0,0 +1,11 @@
+Speedbar is an Emacs Lisp program which allows you to create a special
+skinny frame with a specialized directory listing in it. This listing
+will have both directories and filtered files in it. You can then load
+files into your emacs frame, or expand the files to display all the
+tags that are in them and jump to those tags. You can also expand
+multiple directories into your speedbar frame.
+
+WWW: http://cedet.sourceforge.net/speedbar.shtml
+
+- Kimura Fuyuki
+fuyuki@mj.0038.net
diff --git a/editors/speedbar/pkg-plist b/editors/speedbar/pkg-plist
new file mode 100644
index 000000000000..d05dbee6a410
--- /dev/null
+++ b/editors/speedbar/pkg-plist
@@ -0,0 +1,37 @@
+@unexec install-info --delete %D/info/speedbar.info %D/info/dir
+info/speedbar.info
+@exec install-info %D/info/speedbar.info %D/info/dir
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/bigclock.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/dframe.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/dframe.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/gud.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/gud.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/info.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/info.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/rmail.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/rmail.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/rpm.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-dir-minus.xpm
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-dir-plus.xpm
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-dir.xpm
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-gud.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-image.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-info.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-mail.xpm
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-pg-minus.xpm
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-pg-plus.xpm
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-pg.xpm
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-rmail.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-tag-gt.xpm
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-tag-minus.xpm
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-tag-plus.xpm
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-tag-type.xpm
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-tag-v.xpm
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-tag.xpm
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-texinfo.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/sb-w3.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/speedbar.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/speedbar.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/vhdl-mode.el
+%%EMACS_VERSION_SITE_LISPDIR%%/speedbar/vhdl-mode.elc
+@dirrm %%EMACS_VERSION_SITE_LISPDIR%%/speedbar