aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-10-01 14:23:56 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-10-01 14:23:56 +0000
commitfc965e2fda9b94b5348981b1ff222867778b2537 (patch)
treedc4e92eda990fc975dd821ee57b301940c365d82 /editors
parent864866c05d22507c2e7b200c81a8f6fbe6406cff (diff)
downloadports-fc965e2fda9b94b5348981b1ff222867778b2537.tar.gz
ports-fc965e2fda9b94b5348981b1ff222867778b2537.zip
editors/mg: Update to 20180927
This brings mg up to what will be in OpenBSD 6.4. Simplify port by moving to Brian Callahan's portable mg release. It has a configure script to detect OS features and it hopefully won't break building mg on FreeBSD for no reason. MFH: 2018Q4
Notes
Notes: svn path=/head/; revision=481035
Diffstat (limited to 'editors')
-rw-r--r--editors/mg/Makefile27
-rw-r--r--editors/mg/distinfo6
-rw-r--r--editors/mg/files/extra-patch-def.h11
-rw-r--r--editors/mg/files/reallocarray.c39
-rw-r--r--editors/mg/pkg-descr2
5 files changed, 9 insertions, 76 deletions
diff --git a/editors/mg/Makefile b/editors/mg/Makefile
index 54a889a79b3e..dc89bb834154 100644
--- a/editors/mg/Makefile
+++ b/editors/mg/Makefile
@@ -2,8 +2,9 @@
# $FreeBSD$
PORTNAME= mg
-PORTVERSION= 20180408
+PORTVERSION= 20180927
CATEGORIES= editors
+MASTER_SITES= https://github.com/ibara/mg/releases/download/mg-${PORTVERSION}/
MAINTAINER= tobik@FreeBSD.org
COMMENT= Small, fast Emacs-like editor
@@ -11,31 +12,13 @@ COMMENT= Small, fast Emacs-like editor
LICENSE= PD
USES= ncurses
-USE_GITHUB= yes
-GH_ACCOUNT= hboetes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
PLIST_FILES= bin/mg man/man1/mg.1.gz
-PORTDOCS= README tutorial
+PORTDOCS= README-Mg README.md tutorial
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} != FreeBSD || ${OSVERSION} < 1100072
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-def.h
-
-post-patch:
- ${CP} ${FILESDIR}/reallocarray.c ${WRKSRC}
- @${REINPLACE_CMD} 's| tags.c| tags.c reallocarray.c|' ${WRKSRC}/Makefile
-.endif
-
-pre-configure:
- @${REINPLACE_CMD} 's|-lcurses|-lncurses|' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} 's|__dead|__dead2|' ${WRKSRC}/main.c
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
-
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/editors/mg/distinfo b/editors/mg/distinfo
index e984251daba6..7bff02b969e6 100644
--- a/editors/mg/distinfo
+++ b/editors/mg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1526285944
-SHA256 (hboetes-mg-20180408_GH0.tar.gz) = 85c1d47500fd042e427b670c630c228668bcc4f532a280f9ecce3d302229bbe4
-SIZE (hboetes-mg-20180408_GH0.tar.gz) = 141988
+TIMESTAMP = 1538400869
+SHA256 (mg-20180927.tar.gz) = 99b2fd2cf9d6474153d6c5769c818dd5514c147b8a8ad660a5e114bc1ebd504d
+SIZE (mg-20180927.tar.gz) = 156632
diff --git a/editors/mg/files/extra-patch-def.h b/editors/mg/files/extra-patch-def.h
deleted file mode 100644
index d22292c786f1..000000000000
--- a/editors/mg/files/extra-patch-def.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- def.h.orig 2016-09-01 15:30:59 UTC
-+++ def.h
-@@ -328,6 +328,8 @@ struct undo_rec {
- * Prototypes.
- */
-
-+void *reallocarray(void*, size_t, size_t);
-+
- /* tty.c X */
- void ttinit(void);
- void ttreinit(void);
diff --git a/editors/mg/files/reallocarray.c b/editors/mg/files/reallocarray.c
deleted file mode 100644
index 21b0914fe484..000000000000
--- a/editors/mg/files/reallocarray.c
+++ /dev/null
@@ -1,39 +0,0 @@
-/* $OpenBSD: reallocarray.c,v 1.3 2015/09/13 08:31:47 guenther Exp $ */
-/*
- * Copyright (c) 2008 Otto Moerbeek <otto@drijf.net>
- *
- * Permission to use, copy, modify, and distribute this software for any
- * purpose with or without fee is hereby granted, provided that the above
- * copyright notice and this permission notice appear in all copies.
- *
- * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
- * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
- * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
- * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
- * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
- * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
- * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
- */
-
-#include <sys/types.h>
-#include <errno.h>
-#include <stdint.h>
-#include <stdlib.h>
-
-/*
- * This is sqrt(SIZE_MAX+1), as s1*s2 <= SIZE_MAX
- * if both s1 < MUL_NO_OVERFLOW and s2 < MUL_NO_OVERFLOW
- */
-#define MUL_NO_OVERFLOW ((size_t)1 << (sizeof(size_t) * 4))
-
-void *
-reallocarray(void *optr, size_t nmemb, size_t size)
-{
- if ((nmemb >= MUL_NO_OVERFLOW || size >= MUL_NO_OVERFLOW) &&
- nmemb > 0 && SIZE_MAX / nmemb < size) {
- errno = ENOMEM;
- return NULL;
- }
- return realloc(optr, size * nmemb);
-}
-
diff --git a/editors/mg/pkg-descr b/editors/mg/pkg-descr
index f8afd19d4ebe..29a5833a4b13 100644
--- a/editors/mg/pkg-descr
+++ b/editors/mg/pkg-descr
@@ -3,4 +3,4 @@ editor maintained by the OpenBSD Project. It is intended for people
who can't, or don't want to, run the real GNU Emacs, or are not
familiar with the vi(1) editor.
-WWW: https://github.com/hboetes/mg
+WWW: https://github.com/ibara/mg