aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorGary Jennejohn <gj@FreeBSD.org>2001-03-23 21:02:17 +0000
committerGary Jennejohn <gj@FreeBSD.org>2001-03-23 21:02:17 +0000
commit00835307315a546cf842b84a4605c6eef77d35e5 (patch)
treecee1c4b04d2f29175f687db0cb49e430b34c7dcc /editors
parent85441a23ad2e47eaeeda9ee4448da3a80036d71f (diff)
downloadports-00835307315a546cf842b84a4605c6eef77d35e5.tar.gz
ports-00835307315a546cf842b84a4605c6eef77d35e5.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/vile/Makefile30
-rw-r--r--editors/vile/distinfo10
-rw-r--r--editors/vile/pkg-plist11
-rw-r--r--editors/vile/pkg-plist.filt88
-rw-r--r--editors/vile/pkg-plist.perl11
-rw-r--r--editors/vile/pkg-plist.perl+filt110
-rw-r--r--editors/xvile/Makefile42
-rw-r--r--editors/xvile/distinfo10
-rw-r--r--editors/xvile/pkg-plist11
-rw-r--r--editors/xvile/pkg-plist.filt91
-rw-r--r--editors/xvile/pkg-plist.perl11
-rw-r--r--editors/xvile/pkg-plist.perl+filt112
12 files changed, 530 insertions, 7 deletions
diff --git a/editors/vile/Makefile b/editors/vile/Makefile
index f729ab719eed..249f885a2776 100644
--- a/editors/vile/Makefile
+++ b/editors/vile/Makefile
@@ -6,10 +6,23 @@
#
PORTNAME= vile
-PORTVERSION= 9.2
+PORTVERSION= 9.2_pj
+DISTNAME= vile-9.2
CATEGORIES= editors
MASTER_SITES= ftp://ftp.phred.org/pub/vile/ \
- ftp://id.wing.net/pub/pgf/vile/
+ ftp://dickey.his.com/vile/
+PATCH_SITES= ${MASTER_SITES:S,vile/,vile/patches,g}
+PATCHFILES= vile-9.2a.patch.gz \
+ vile-9.2b.patch.gz \
+ vile-9.2c.patch.gz \
+ vile-9.2d.patch.gz \
+ vile-9.2e.patch.gz \
+ vile-9.2f.patch.gz \
+ vile-9.2g.patch.gz \
+ vile-9.2h.patch.gz \
+ vile-9.2i.patch.gz \
+ vile-9.2j.patch.gz
+
EXTRACT_SUFX= .tgz
MAINTAINER= gj@freebsd.org
@@ -24,11 +37,24 @@ PLIST= ${PKGDIR}/pkg-plist.perl
USE_PERL5= yes
.endif
+.if defined(WITH_FILTERS)
+CONFIGURE_ARGS+= --with-builtin-filters=all
+PLIST= ${PKGDIR}/pkg-plist.filt
+.endif
+
+.if defined(WITH_PERL) && defined(WITH_FILTERS)
+PLIST= ${PKGDIR}/pkg-plist.perl+filt
+.endif
+
pre-configure:
.if ! defined(WITH_PERL)
@${ECHO_MSG} "Define WITH_PERL if you want to make a vile which includes"
@${ECHO_MSG} "PERL functionality"
.endif
+.if ! defined(WITH_FILTERS)
+ @${ECHO_MSG} "Define WITH_FILTERS if you want to make a vile which includes"
+ @${ECHO_MSG} "all filters in the binary"
+.endif
post-install:
.if !defined(NOPORTDOCS)
diff --git a/editors/vile/distinfo b/editors/vile/distinfo
index da2707c87551..4bac72473577 100644
--- a/editors/vile/distinfo
+++ b/editors/vile/distinfo
@@ -1 +1,11 @@
MD5 (vile-9.2.tgz) = 92b9c329db3f6a528b3b82296714bf4c
+MD5 (vile-9.2a.patch.gz) = a2c5d562302202fe2632746fed0bfbd4
+MD5 (vile-9.2b.patch.gz) = 110dc49ca162ff551c478edb9fd49635
+MD5 (vile-9.2c.patch.gz) = a48389242027723dbdd41dc1fc605026
+MD5 (vile-9.2d.patch.gz) = 513fda8ab5fa3156481966a4451cc36b
+MD5 (vile-9.2e.patch.gz) = 1f3eccdb4527e7fb4649ac8a343e9100
+MD5 (vile-9.2f.patch.gz) = 924a1e612631f8dc0c280096ca68ccad
+MD5 (vile-9.2g.patch.gz) = 535e3eb334fa7da30bd61cc3a37e9001
+MD5 (vile-9.2h.patch.gz) = 02db5c9325dd07eec5824f5756f306ad
+MD5 (vile-9.2i.patch.gz) = 8a7eac1ffe4693bfeb2fcd07e3593d4c
+MD5 (vile-9.2j.patch.gz) = 6acba886d739f7d5cf3d6dadec2bcaa8
diff --git a/editors/vile/pkg-plist b/editors/vile/pkg-plist
index a64c6d81ef9c..92a3be5b4714 100644
--- a/editors/vile/pkg-plist
+++ b/editors/vile/pkg-plist
@@ -1,5 +1,6 @@
bin/vile
bin/vile-pager
+lib/vile/vile-basic-filt
lib/vile/vile-c-filt
lib/vile/vile-crypt
lib/vile/vile-key-filt
@@ -12,7 +13,9 @@ lib/vile/vile-cfg-filt
lib/vile/vile-cweb-filt
lib/vile/vile-dcl-filt
lib/vile/vile-fdl-filt
+lib/vile/vile-def-filt
lib/vile/vile-diff-filt
+lib/vile/vile-ecl-filt
lib/vile/vile-esql-filt
lib/vile/vile-html-filt
lib/vile/vile-imake-filt
@@ -26,6 +29,7 @@ lib/vile/vile-nr-filt
lib/vile/vile-perl-filt
lib/vile/vile-pl-filt
lib/vile/vile-py-filt
+lib/vile/vile-rc-filt
lib/vile/vile-rcs-filt
lib/vile/vile-rexx-filt
lib/vile/vile-sccs-filt
@@ -41,6 +45,7 @@ lib/vile/vile-tcl-filt
lib/vile/vile-ti-filt
lib/vile/vile-txt-filt
lib/vile/vile-vile-filt
+lib/vile/vile-vlog-filt
lib/vile/vile-xres-filt
lib/vile/vile-xs-filt
lib/vile/vile-yacc-filt
@@ -70,13 +75,16 @@ share/vile/vileperl.rc
share/vile/vile.hlp
share/vile/ada.keywords
share/vile/awk.keywords
+share/vile/basic.keywords
share/vile/bat.keywords
share/vile/c.keywords
share/vile/cpp.keywords
share/vile/csh.keywords
share/vile/cweb.keywords
share/vile/dcl.keywords
+share/vile/def.keywords
share/vile/diff.keywords
+share/vile/ecl.keywords
share/vile/esql.keywords
share/vile/fdl.keywords
share/vile/js.keywords
@@ -94,6 +102,7 @@ share/vile/pc.keywords
share/vile/perl.keywords
share/vile/py.keywords
share/vile/pot.keywords
+share/vile/rc.keywords
share/vile/rcs.keywords
share/vile/rexx.keywords
share/vile/sccs.keywords
@@ -105,8 +114,10 @@ share/vile/tbl.keywords
share/vile/tc.keywords
share/vile/tcl.keywords
share/vile/ti.keywords
+share/vile/vb.keywords
share/vile/vile.keywords
share/vile/vim.keywords
+share/vile/vlog.keywords
share/vile/xres.keywords
share/vile/xs.keywords
share/vile/yacc.keywords
diff --git a/editors/vile/pkg-plist.filt b/editors/vile/pkg-plist.filt
new file mode 100644
index 000000000000..6250701fcf6a
--- /dev/null
+++ b/editors/vile/pkg-plist.filt
@@ -0,0 +1,88 @@
+bin/vile
+bin/vile-pager
+lib/vile/vile-crypt
+lib/vile/vile-manfilt
+@dirrm lib/vile
+share/doc/vile/Vileserv.doc
+share/doc/vile/config.doc
+share/doc/vile/dir.doc
+share/doc/vile/filters.doc
+share/doc/vile/macros.doc
+share/doc/vile/menus.doc
+share/doc/vile/modes.doc
+share/doc/vile/oleauto.doc
+share/doc/vile/perl.doc
+share/doc/vile/visvile.doc
+share/doc/vile/w32modes.doc
+@dirrm share/doc/vile
+share/vile/color-ls.rc
+share/vile/digraphs.rc
+share/vile/filters.rc
+share/vile/manpage.rc
+share/vile/palettes.rc
+share/vile/pictmode.rc
+share/vile/shifts.rc
+share/vile/spell.rc
+share/vile/vileinit.rc
+share/vile/vileperl.rc
+share/vile/vile.hlp
+share/vile/ada.keywords
+share/vile/awk.keywords
+share/vile/basic.keywords
+share/vile/bat.keywords
+share/vile/c.keywords
+share/vile/cpp.keywords
+share/vile/csh.keywords
+share/vile/cweb.keywords
+share/vile/dcl.keywords
+share/vile/def.keywords
+share/vile/diff.keywords
+share/vile/ecl.keywords
+share/vile/esql.keywords
+share/vile/fdl.keywords
+share/vile/js.keywords
+share/vile/html.keywords
+share/vile/imake.keywords
+share/vile/java.keywords
+share/vile/latex.keywords
+share/vile/lex.keywords
+share/vile/m4.keywords
+share/vile/mail.keywords
+share/vile/make.keywords
+share/vile/nr.keywords
+share/vile/pas.keywords
+share/vile/pc.keywords
+share/vile/perl.keywords
+share/vile/py.keywords
+share/vile/pot.keywords
+share/vile/rc.keywords
+share/vile/rcs.keywords
+share/vile/rexx.keywords
+share/vile/sccs.keywords
+share/vile/sh.keywords
+share/vile/sql.keywords
+share/vile/sml.keywords
+share/vile/tags.keywords
+share/vile/tbl.keywords
+share/vile/tc.keywords
+share/vile/tcl.keywords
+share/vile/ti.keywords
+share/vile/vb.keywords
+share/vile/vile.keywords
+share/vile/vim.keywords
+share/vile/vlog.keywords
+share/vile/xres.keywords
+share/vile/xs.keywords
+share/vile/yacc.keywords
+share/vile/macros/color-ls.rc
+share/vile/macros/digraphs.rc
+share/vile/macros/manpage.rc
+share/vile/macros/palettes.rc
+share/vile/macros/pictmode.rc
+share/vile/macros/shifts.rc
+share/vile/macros/vileinit.rc
+share/vile/macros/vilemenu.rc
+share/vile/macros/vileperl.rc
+share/vile/macros/vile-pager
+@dirrm share/vile/macros
+@dirrm share/vile
diff --git a/editors/vile/pkg-plist.perl b/editors/vile/pkg-plist.perl
index 9749607a4d79..5cfa3c55bd0e 100644
--- a/editors/vile/pkg-plist.perl
+++ b/editors/vile/pkg-plist.perl
@@ -1,6 +1,7 @@
bin/vile
bin/vile-pager
bin/vileget
+lib/vile/vile-basic-filt
lib/vile/vile-c-filt
lib/vile/vile-crypt
lib/vile/vile-key-filt
@@ -12,8 +13,10 @@ lib/vile/vile-bat-filt
lib/vile/vile-cfg-filt
lib/vile/vile-cweb-filt
lib/vile/vile-dcl-filt
+lib/vile/vile-def-filt
lib/vile/vile-fdl-filt
lib/vile/vile-diff-filt
+lib/vile/vile-ecl-filt
lib/vile/vile-esql-filt
lib/vile/vile-html-filt
lib/vile/vile-imake-filt
@@ -27,6 +30,7 @@ lib/vile/vile-nr-filt
lib/vile/vile-perl-filt
lib/vile/vile-pl-filt
lib/vile/vile-py-filt
+lib/vile/vile-rc-filt
lib/vile/vile-rcs-filt
lib/vile/vile-rexx-filt
lib/vile/vile-sccs-filt
@@ -42,6 +46,7 @@ lib/vile/vile-tcl-filt
lib/vile/vile-ti-filt
lib/vile/vile-txt-filt
lib/vile/vile-vile-filt
+lib/vile/vile-vlog-filt
lib/vile/vile-xres-filt
lib/vile/vile-xs-filt
lib/vile/vile-yacc-filt
@@ -86,20 +91,25 @@ share/vile/shifts.rc
share/vile/vileinit.rc
share/vile/vileperl.rc
share/vile/vile.hlp
+share/vile/basic.keywords
share/vile/c.keywords
share/vile/cpp.keywords
share/vile/filters.rc
share/vile/pas.keywords
share/vile/pc.keywords
+share/vile/vb.keywords
share/vile/vile.keywords
share/vile/vim.keywords
+share/vile/vlog.keywords
share/vile/ada.keywords
share/vile/awk.keywords
share/vile/bat.keywords
share/vile/csh.keywords
share/vile/cweb.keywords
share/vile/dcl.keywords
+share/vile/def.keywords
share/vile/diff.keywords
+share/vile/ecl.keywords
share/vile/esql.keywords
share/vile/fdl.keywords
share/vile/html.keywords
@@ -115,6 +125,7 @@ share/vile/nr.keywords
share/vile/perl.keywords
share/vile/py.keywords
share/vile/pot.keywords
+share/vile/rc.keywords
share/vile/rcs.keywords
share/vile/rexx.keywords
share/vile/sccs.keywords
diff --git a/editors/vile/pkg-plist.perl+filt b/editors/vile/pkg-plist.perl+filt
new file mode 100644
index 000000000000..5f991889b29e
--- /dev/null
+++ b/editors/vile/pkg-plist.perl+filt
@@ -0,0 +1,110 @@
+bin/vile
+bin/vile-pager
+bin/vileget
+lib/vile/vile-crypt
+lib/vile/vile-manfilt
+@dirrm lib/vile
+share/doc/vile/Vileserv.doc
+share/doc/vile/config.doc
+share/doc/vile/dir.doc
+share/doc/vile/filters.doc
+share/doc/vile/macros.doc
+share/doc/vile/menus.doc
+share/doc/vile/modes.doc
+share/doc/vile/oleauto.doc
+share/doc/vile/perl.doc
+share/doc/vile/visvile.doc
+share/doc/vile/w32modes.doc
+share/doc/vile/vile-perl-api.doc
+@dirrm share/doc/vile
+share/vile/perl/Vile/Exporter.pm
+share/vile/perl/Vile/Manual.pm
+share/vile/perl/Glob2re.pm
+share/vile/perl/Vile.pm
+share/vile/perl/Vileserv.pm
+share/vile/perl/Visit.pm
+share/vile/perl/capture.pm
+share/vile/perl/directory.pm
+share/vile/perl/dirlist.pm
+share/vile/perl/gdb.pm
+share/vile/perl/hgrep.pm
+share/vile/perl/lock.pm
+share/vile/perl/mime.pl
+share/vile/perl/plugins.pl
+share/vile/perl/search.pm
+share/vile/perl/shell.pm
+share/vile/perl/spell.pm
+share/vile/perl/winops.pm
+share/vile/color-ls.rc
+share/vile/digraphs.rc
+share/vile/manpage.rc
+share/vile/palettes.rc
+share/vile/pictmode.rc
+share/vile/shifts.rc
+share/vile/vileinit.rc
+share/vile/vileperl.rc
+share/vile/vile.hlp
+share/vile/c.keywords
+share/vile/cpp.keywords
+share/vile/filters.rc
+share/vile/pas.keywords
+share/vile/pc.keywords
+share/vile/vb.keywords
+share/vile/vile.keywords
+share/vile/vim.keywords
+share/vile/vlog.keywords
+share/vile/ada.keywords
+share/vile/awk.keywords
+share/vile/basic.keywords
+share/vile/bat.keywords
+share/vile/csh.keywords
+share/vile/cweb.keywords
+share/vile/dcl.keywords
+share/vile/def.keywords
+share/vile/diff.keywords
+share/vile/ecl.keywords
+share/vile/esql.keywords
+share/vile/fdl.keywords
+share/vile/html.keywords
+share/vile/imake.keywords
+share/vile/java.keywords
+share/vile/js.keywords
+share/vile/latex.keywords
+share/vile/lex.keywords
+share/vile/m4.keywords
+share/vile/mail.keywords
+share/vile/make.keywords
+share/vile/nr.keywords
+share/vile/perl.keywords
+share/vile/py.keywords
+share/vile/pot.keywords
+share/vile/rc.keywords
+share/vile/rcs.keywords
+share/vile/rexx.keywords
+share/vile/sccs.keywords
+share/vile/sh.keywords
+share/vile/sml.keywords
+share/vile/spell.rc
+share/vile/sql.keywords
+share/vile/tags.keywords
+share/vile/tbl.keywords
+share/vile/tc.keywords
+share/vile/tcl.keywords
+share/vile/ti.keywords
+share/vile/xres.keywords
+share/vile/xs.keywords
+share/vile/macros/color-ls.rc
+share/vile/macros/digraphs.rc
+share/vile/macros/manpage.rc
+share/vile/macros/palettes.rc
+share/vile/macros/pictmode.rc
+share/vile/macros/shifts.rc
+share/vile/macros/vileinit.rc
+share/vile/macros/vilemenu.rc
+share/vile/macros/vileperl.rc
+share/vile/macros/vile-pager
+share/vile/yacc.keywords
+@dirrm share/vile/perl/Vile
+@dirrm share/vile/perl
+@dirrm share/vile/macros
+@dirrm share/vile
diff --git a/editors/xvile/Makefile b/editors/xvile/Makefile
index debb8bcff0b6..654707899028 100644
--- a/editors/xvile/Makefile
+++ b/editors/xvile/Makefile
@@ -6,13 +6,25 @@
#
PORTNAME= xvile
-PORTVERSION= 9.2
+PORTVERSION= 9.2j
CATEGORIES= editors
MASTER_SITES= ftp://ftp.phred.org/pub/vile/ \
- ftp://id.wing.net/pub/pgf/vile/
-DISTNAME= vile-${PORTVERSION}
+ ftp://dickey.his.com/vile/
+DISTNAME= vile-9.2
EXTRACT_SUFX= .tgz
+PATCH_SITES= ${MASTER_SITES:S,vile/,vile/patches,g}
+PATCHFILES= vile-9.2a.patch.gz \
+ vile-9.2b.patch.gz \
+ vile-9.2c.patch.gz \
+ vile-9.2d.patch.gz \
+ vile-9.2e.patch.gz \
+ vile-9.2f.patch.gz \
+ vile-9.2g.patch.gz \
+ vile-9.2h.patch.gz \
+ vile-9.2i.patch.gz \
+ vile-9.2j.patch.gz
+
MAINTAINER= gj@freebsd.org
USE_XLIB= yes
@@ -26,14 +38,25 @@ MAN1= xvile.1
pre-configure:
.if ! defined(WITH_MENUS)
- @${ECHO_MSG} "To use xvile with menus, set the environment variable WITH_MENUS"
+ @${ECHO_MSG} "To use xvile with menus, set the environment variable WITH_MENUS,"
+ @${ECHO_MSG} "which will also turn on Xaw. If you have Xaw3d, you can use it"
+ @${ECHO_MSG} "by also settting the environment variable WITH_XAW3D."
.endif
+
.if ! defined(WITH_PERL)
- @${ECHO_MSG} "To use xvile with PERL, set the environment variable WITH_PERL"
+ @${ECHO_MSG} "To use xvile with PERL, set the environment variable WITH_PERL."
+.endif
+
+.if ! defined(WITH_FILTERS)
+ @${ECHO_MSG} "Define WITH_FILTERS if you want to make an xvile which includes"
+ @${ECHO_MSG} "all filters in the binary"
.endif
.if defined(WITH_MENUS)
CONFIGURE_ARGS+= --with-screen=Xaw
+.if defined(WITH_XAW3D)
+CONFIGURE_ARGS+= --with-Xaw3d
+.endif
.else
CONFIGURE_ARGS+= --with-screen=x11
.endif
@@ -44,6 +67,15 @@ PLIST= ${PKGDIR}/pkg-plist.perl
USE_PERL5= yes
.endif
+.if defined(WITH_FILTERS)
+CONFIGURE_ARGS+= --with-builtin-filters=all
+PLIST= ${PKGDIR}/pkg-plist.filt
+.endif
+
+.if defined(WITH_PERL) && defined(WITH_FILTERS)
+PLIST= ${PKGDIR}/pkg-plist.perl+filt
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@if ! [ -d ${PREFIX}/share/doc/xvile ]; then ${MKDIR} ${PREFIX}/share/doc/xvile; fi
diff --git a/editors/xvile/distinfo b/editors/xvile/distinfo
index da2707c87551..4bac72473577 100644
--- a/editors/xvile/distinfo
+++ b/editors/xvile/distinfo
@@ -1 +1,11 @@
MD5 (vile-9.2.tgz) = 92b9c329db3f6a528b3b82296714bf4c
+MD5 (vile-9.2a.patch.gz) = a2c5d562302202fe2632746fed0bfbd4
+MD5 (vile-9.2b.patch.gz) = 110dc49ca162ff551c478edb9fd49635
+MD5 (vile-9.2c.patch.gz) = a48389242027723dbdd41dc1fc605026
+MD5 (vile-9.2d.patch.gz) = 513fda8ab5fa3156481966a4451cc36b
+MD5 (vile-9.2e.patch.gz) = 1f3eccdb4527e7fb4649ac8a343e9100
+MD5 (vile-9.2f.patch.gz) = 924a1e612631f8dc0c280096ca68ccad
+MD5 (vile-9.2g.patch.gz) = 535e3eb334fa7da30bd61cc3a37e9001
+MD5 (vile-9.2h.patch.gz) = 02db5c9325dd07eec5824f5756f306ad
+MD5 (vile-9.2i.patch.gz) = 8a7eac1ffe4693bfeb2fcd07e3593d4c
+MD5 (vile-9.2j.patch.gz) = 6acba886d739f7d5cf3d6dadec2bcaa8
diff --git a/editors/xvile/pkg-plist b/editors/xvile/pkg-plist
index 4067b40e9f0e..9defa2df0566 100644
--- a/editors/xvile/pkg-plist
+++ b/editors/xvile/pkg-plist
@@ -1,6 +1,7 @@
bin/xvile
bin/xvile-pager
bin/xshell.sh
+lib/xvile/vile-basic-filt
lib/xvile/vile-c-filt
lib/xvile/vile-crypt
lib/xvile/vile-key-filt
@@ -13,7 +14,9 @@ lib/xvile/vile-cfg-filt
lib/xvile/vile-cweb-filt
lib/xvile/vile-dcl-filt
lib/xvile/vile-fdl-filt
+lib/xvile/vile-def-filt
lib/xvile/vile-diff-filt
+lib/xvile/vile-ecl-filt
lib/xvile/vile-esql-filt
lib/xvile/vile-html-filt
lib/xvile/vile-imake-filt
@@ -27,6 +30,7 @@ lib/xvile/vile-nr-filt
lib/xvile/vile-perl-filt
lib/xvile/vile-pl-filt
lib/xvile/vile-py-filt
+lib/xvile/vile-rc-filt
lib/xvile/vile-rcs-filt
lib/xvile/vile-rexx-filt
lib/xvile/vile-sccs-filt
@@ -42,6 +46,7 @@ lib/xvile/vile-tcl-filt
lib/xvile/vile-ti-filt
lib/xvile/vile-txt-filt
lib/xvile/vile-vile-filt
+lib/xvile/vile-vlog-filt
lib/xvile/vile-xres-filt
lib/xvile/vile-xs-filt
lib/xvile/vile-yacc-filt
@@ -68,6 +73,7 @@ share/xvile/vile/shifts.rc
share/xvile/vile/vileinit.rc
share/xvile/vile/vileperl.rc
share/xvile/vile/vile.hlp
+share/xvile/vile/basic.keywords
share/xvile/vile/c.keywords
share/xvile/vile/cpp.keywords
share/xvile/vile/filters.rc
@@ -81,7 +87,9 @@ share/xvile/vile/bat.keywords
share/xvile/vile/csh.keywords
share/xvile/vile/cweb.keywords
share/xvile/vile/dcl.keywords
+share/xvile/vile/def.keywords
share/xvile/vile/diff.keywords
+share/xvile/vile/ecl.keywords
share/xvile/vile/esql.keywords
share/xvile/vile/fdl.keywords
share/xvile/vile/html.keywords
@@ -97,6 +105,7 @@ share/xvile/vile/nr.keywords
share/xvile/vile/perl.keywords
share/xvile/vile/py.keywords
share/xvile/vile/pot.keywords
+share/xvile/vile/rc.keywords
share/xvile/vile/rcs.keywords
share/xvile/vile/rexx.keywords
share/xvile/vile/sccs.keywords
@@ -109,6 +118,8 @@ share/xvile/vile/tbl.keywords
share/xvile/vile/tc.keywords
share/xvile/vile/tcl.keywords
share/xvile/vile/ti.keywords
+share/xvile/vile/vb.keywords
+share/xvile/vile/vlog.keywords
share/xvile/vile/xres.keywords
share/xvile/vile/xs.keywords
share/xvile/vile/yacc.keywords
diff --git a/editors/xvile/pkg-plist.filt b/editors/xvile/pkg-plist.filt
new file mode 100644
index 000000000000..07ef93b39178
--- /dev/null
+++ b/editors/xvile/pkg-plist.filt
@@ -0,0 +1,91 @@
+bin/xvile
+bin/xvile-pager
+bin/xshell.sh
+lib/xvile/vile-crypt
+lib/xvile/vile-manfilt
+@dirrm lib/xvile
+share/doc/xvile/Vileserv.doc
+share/doc/xvile/config.doc
+share/doc/xvile/dir.doc
+share/doc/xvile/filters.doc
+share/doc/xvile/macros.doc
+share/doc/xvile/menus.doc
+share/doc/xvile/modes.doc
+share/doc/xvile/oleauto.doc
+share/doc/xvile/perl.doc
+share/doc/xvile/visvile.doc
+share/doc/xvile/w32modes.doc
+@dirrm share/doc/xvile
+@unexec rm -f %D/share/xvile/vile/.vilemenu
+share/xvile/vile/color-ls.rc
+share/xvile/vile/digraphs.rc
+share/xvile/vile/manpage.rc
+share/xvile/vile/palettes.rc
+share/xvile/vile/pictmode.rc
+share/xvile/vile/shifts.rc
+share/xvile/vile/vileinit.rc
+share/xvile/vile/vileperl.rc
+share/xvile/vile/vile.hlp
+share/xvile/vile/basic.keywords
+share/xvile/vile/c.keywords
+share/xvile/vile/cpp.keywords
+share/xvile/vile/filters.rc
+share/xvile/vile/pas.keywords
+share/xvile/vile/pc.keywords
+share/xvile/vile/vb.keywords
+share/xvile/vile/vile.keywords
+share/xvile/vile/vim.keywords
+share/xvile/vile/vlog.keywords
+share/xvile/vile/ada.keywords
+share/xvile/vile/awk.keywords
+share/xvile/vile/bat.keywords
+share/xvile/vile/csh.keywords
+share/xvile/vile/cweb.keywords
+share/xvile/vile/dcl.keywords
+share/xvile/vile/def.keywords
+share/xvile/vile/diff.keywords
+share/xvile/vile/ecl.keywords
+share/xvile/vile/esql.keywords
+share/xvile/vile/fdl.keywords
+share/xvile/vile/html.keywords
+share/xvile/vile/imake.keywords
+share/xvile/vile/java.keywords
+share/xvile/vile/js.keywords
+share/xvile/vile/latex.keywords
+share/xvile/vile/lex.keywords
+share/xvile/vile/m4.keywords
+share/xvile/vile/mail.keywords
+share/xvile/vile/make.keywords
+share/xvile/vile/nr.keywords
+share/xvile/vile/perl.keywords
+share/xvile/vile/py.keywords
+share/xvile/vile/pot.keywords
+share/xvile/vile/rc.keywords
+share/xvile/vile/rcs.keywords
+share/xvile/vile/rexx.keywords
+share/xvile/vile/sccs.keywords
+share/xvile/vile/sh.keywords
+share/xvile/vile/sml.keywords
+share/xvile/vile/spell.rc
+share/xvile/vile/sql.keywords
+share/xvile/vile/tags.keywords
+share/xvile/vile/tbl.keywords
+share/xvile/vile/tc.keywords
+share/xvile/vile/tcl.keywords
+share/xvile/vile/ti.keywords
+share/xvile/vile/xres.keywords
+share/xvile/vile/xs.keywords
+share/xvile/vile/yacc.keywords
+share/xvile/macros/color-ls.rc
+share/xvile/macros/digraphs.rc
+share/xvile/macros/manpage.rc
+share/xvile/macros/palettes.rc
+share/xvile/macros/pictmode.rc
+share/xvile/macros/shifts.rc
+share/xvile/macros/vileinit.rc
+share/xvile/macros/vilemenu.rc
+share/xvile/macros/vileperl.rc
+share/xvile/macros/vile-pager
+@dirrm share/xvile/vile
+@dirrm share/xvile/macros
+@dirrm share/xvile
diff --git a/editors/xvile/pkg-plist.perl b/editors/xvile/pkg-plist.perl
index 519b9e8b3e99..c3a6370625d5 100644
--- a/editors/xvile/pkg-plist.perl
+++ b/editors/xvile/pkg-plist.perl
@@ -1,6 +1,7 @@
bin/xvile
bin/xvile-pager
bin/xshell.sh
+lib/xvile/vile-basic-filt
lib/xvile/vile-c-filt
lib/xvile/vile-crypt
lib/xvile/vile-key-filt
@@ -13,7 +14,9 @@ lib/xvile/vile-cfg-filt
lib/xvile/vile-cweb-filt
lib/xvile/vile-dcl-filt
lib/xvile/vile-fdl-filt
+lib/xvile/vile-def-filt
lib/xvile/vile-diff-filt
+lib/xvile/vile-ecl-filt
lib/xvile/vile-esql-filt
lib/xvile/vile-html-filt
lib/xvile/vile-imake-filt
@@ -27,6 +30,7 @@ lib/xvile/vile-nr-filt
lib/xvile/vile-perl-filt
lib/xvile/vile-pl-filt
lib/xvile/vile-py-filt
+lib/xvile/vile-rc-filt
lib/xvile/vile-rcs-filt
lib/xvile/vile-rexx-filt
lib/xvile/vile-sccs-filt
@@ -41,6 +45,7 @@ lib/xvile/vile-tc-filt
lib/xvile/vile-tcl-filt
lib/xvile/vile-ti-filt
lib/xvile/vile-txt-filt
+lib/xvile/vile-vlog-filt
lib/xvile/vile-vile-filt
lib/xvile/vile-xres-filt
lib/xvile/vile-xs-filt
@@ -87,20 +92,25 @@ share/xvile/vile/shifts.rc
share/xvile/vile/vileinit.rc
share/xvile/vile/vileperl.rc
share/xvile/vile/vile.hlp
+share/xvile/vile/basic.keywords
share/xvile/vile/c.keywords
share/xvile/vile/cpp.keywords
share/xvile/vile/filters.rc
share/xvile/vile/pas.keywords
share/xvile/vile/pc.keywords
+share/xvile/vile/vb.keywords
share/xvile/vile/vile.keywords
share/xvile/vile/vim.keywords
+share/xvile/vile/vlog.keywords
share/xvile/vile/ada.keywords
share/xvile/vile/awk.keywords
share/xvile/vile/bat.keywords
share/xvile/vile/csh.keywords
share/xvile/vile/cweb.keywords
share/xvile/vile/dcl.keywords
+share/xvile/vile/def.keywords
share/xvile/vile/diff.keywords
+share/xvile/vile/ecl.keywords
share/xvile/vile/esql.keywords
share/xvile/vile/fdl.keywords
share/xvile/vile/html.keywords
@@ -116,6 +126,7 @@ share/xvile/vile/nr.keywords
share/xvile/vile/perl.keywords
share/xvile/vile/py.keywords
share/xvile/vile/pot.keywords
+share/xvile/vile/rc.keywords
share/xvile/vile/rcs.keywords
share/xvile/vile/rexx.keywords
share/xvile/vile/sccs.keywords
diff --git a/editors/xvile/pkg-plist.perl+filt b/editors/xvile/pkg-plist.perl+filt
new file mode 100644
index 000000000000..a9464312e5f3
--- /dev/null
+++ b/editors/xvile/pkg-plist.perl+filt
@@ -0,0 +1,112 @@
+bin/xvile
+bin/xvile-pager
+bin/xshell.sh
+lib/xvile/vile-crypt
+lib/xvile/vile-manfilt
+@dirrm lib/xvile
+share/doc/xvile/Vileserv.doc
+share/doc/xvile/config.doc
+share/doc/xvile/dir.doc
+share/doc/xvile/filters.doc
+share/doc/xvile/macros.doc
+share/doc/xvile/menus.doc
+share/doc/xvile/modes.doc
+share/doc/xvile/oleauto.doc
+share/doc/xvile/perl.doc
+share/doc/xvile/visvile.doc
+share/doc/xvile/w32modes.doc
+share/doc/xvile/vile-perl-api.doc
+@dirrm share/doc/xvile
+share/xvile/vile/perl/Vile/Exporter.pm
+share/xvile/vile/perl/Vile/Manual.pm
+share/xvile/vile/perl/Glob2re.pm
+share/xvile/vile/perl/Vile.pm
+share/xvile/vile/perl/Vileserv.pm
+share/xvile/vile/perl/Visit.pm
+share/xvile/vile/perl/capture.pm
+share/xvile/vile/perl/directory.pm
+share/xvile/vile/perl/dirlist.pm
+share/xvile/vile/perl/gdb.pm
+share/xvile/vile/perl/hgrep.pm
+share/xvile/vile/perl/lock.pm
+share/xvile/vile/perl/mime.pl
+share/xvile/vile/perl/plugins.pl
+share/xvile/vile/perl/search.pm
+share/xvile/vile/perl/shell.pm
+share/xvile/vile/perl/spell.pm
+share/xvile/vile/perl/winops.pm
+@unexec rm -f %D/share/xvile/vile/.vilemenu
+share/xvile/vile/color-ls.rc
+share/xvile/vile/digraphs.rc
+share/xvile/vile/manpage.rc
+share/xvile/vile/palettes.rc
+share/xvile/vile/pictmode.rc
+share/xvile/vile/shifts.rc
+share/xvile/vile/vileinit.rc
+share/xvile/vile/vileperl.rc
+share/xvile/vile/vile.hlp
+share/xvile/vile/basic.keywords
+share/xvile/vile/c.keywords
+share/xvile/vile/cpp.keywords
+share/xvile/vile/filters.rc
+share/xvile/vile/pas.keywords
+share/xvile/vile/pc.keywords
+share/xvile/vile/vb.keywords
+share/xvile/vile/vile.keywords
+share/xvile/vile/vim.keywords
+share/xvile/vile/vlog.keywords
+share/xvile/vile/ada.keywords
+share/xvile/vile/awk.keywords
+share/xvile/vile/bat.keywords
+share/xvile/vile/csh.keywords
+share/xvile/vile/cweb.keywords
+share/xvile/vile/dcl.keywords
+share/xvile/vile/def.keywords
+share/xvile/vile/diff.keywords
+share/xvile/vile/ecl.keywords
+share/xvile/vile/esql.keywords
+share/xvile/vile/fdl.keywords
+share/xvile/vile/html.keywords
+share/xvile/vile/imake.keywords
+share/xvile/vile/java.keywords
+share/xvile/vile/js.keywords
+share/xvile/vile/latex.keywords
+share/xvile/vile/lex.keywords
+share/xvile/vile/m4.keywords
+share/xvile/vile/mail.keywords
+share/xvile/vile/make.keywords
+share/xvile/vile/nr.keywords
+share/xvile/vile/perl.keywords
+share/xvile/vile/py.keywords
+share/xvile/vile/pot.keywords
+share/xvile/vile/rc.keywords
+share/xvile/vile/rcs.keywords
+share/xvile/vile/rexx.keywords
+share/xvile/vile/sccs.keywords
+share/xvile/vile/sh.keywords
+share/xvile/vile/sml.keywords
+share/xvile/vile/spell.rc
+share/xvile/vile/sql.keywords
+share/xvile/vile/tags.keywords
+share/xvile/vile/tbl.keywords
+share/xvile/vile/tc.keywords
+share/xvile/vile/tcl.keywords
+share/xvile/vile/ti.keywords
+share/xvile/vile/xres.keywords
+share/xvile/vile/xs.keywords
+share/xvile/macros/color-ls.rc
+share/xvile/macros/digraphs.rc
+share/xvile/macros/manpage.rc
+share/xvile/macros/palettes.rc
+share/xvile/macros/pictmode.rc
+share/xvile/macros/shifts.rc
+share/xvile/macros/vileinit.rc
+share/xvile/macros/vilemenu.rc
+share/xvile/macros/vileperl.rc
+share/xvile/macros/vile-pager
+share/xvile/vile/yacc.keywords
+@dirrm share/xvile/vile/perl/Vile
+@dirrm share/xvile/vile/perl
+@dirrm share/xvile/macros
+@dirrm share/xvile/vile
+@dirrm share/xvile