aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-02-08 06:01:25 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-02-08 06:01:25 +0000
commit880ccf9a637f112636ff998d9b0a35ff0b0b8971 (patch)
tree210bcb0ea8e890cddcb296b8a7119f1307a3184a /editors
parent0d1a1360ef999de0174568c1093dfdd895f193c3 (diff)
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/emacs.app/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/editors/emacs.app/Makefile b/editors/emacs.app/Makefile
index 69d1e76bb008..f202237489d9 100644
--- a/editors/emacs.app/Makefile
+++ b/editors/emacs.app/Makefile
@@ -39,6 +39,14 @@ USE_MAKEFILE= yes
MAKE_ENV+= MAKE="${GMAKE}" EMACSLOADPATH="${WRKSRC}/lisp:${WRKSRC}/leim"
MAKE_ENV+= GNUSTEP_SYSTEM_HEADERS="${GNUSTEP_SYSTEM_ROOT}/Library/Headers"
+post-patch:
+ ${MV} ${WRKSRC}/lib-src/Makefile.in ${WRKSRC}/lib-src/Makefile.in.orig
+ ${AWK} '/\\$$/ { printf("%s",$$0); next}; {print}' < ${WRKSRC}/lib-src/Makefile.in.orig > ${WRKSRC}/lib-src/Makefile.in
+ ${REINPLACE_CMD} -e 's|\\ | |g' -e 's|\\ | |g' ${WRKSRC}/lib-src/Makefile.in
+ ${MV} ${WRKSRC}/src/Makefile.in ${WRKSRC}/src/Makefile.in.tmp
+ ${AWK} '/\\$$/ { printf("%s",$$0); next}; {print}' < ${WRKSRC}/src/Makefile.in.tmp > ${WRKSRC}/src/Makefile.in
+ ${REINPLACE_CMD} -e 's|\\ | |g' -e 's|\\ | |g' ${WRKSRC}/src/Makefile.in
+
post-configure:
@${REINPLACE_CMD} -e 's|#define config_machfile "m/.h"|#define config_machfile "m/sparc.h"|g' ${WRKSRC}/src/config.h