aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2002-08-17 10:48:18 +0000
committerMartin Blapp <mbr@FreeBSD.org>2002-08-17 10:48:18 +0000
commitb4269a596c304047057aecbf747eab1807919a37 (patch)
treeed13f0b3ca4982e1129100ea457f86890b120074 /editors
parent83ae4c0b01ac7a43348c9e83b5f46929c671fe34 (diff)
downloadports-b4269a596c304047057aecbf747eab1807919a37.tar.gz
ports-b4269a596c304047057aecbf747eab1807919a37.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-1.0/Makefile6
-rw-r--r--editors/openoffice.org-1.0/Makefile6
-rw-r--r--editors/openoffice/Makefile6
3 files changed, 15 insertions, 3 deletions
diff --git a/editors/openoffice-1.0/Makefile b/editors/openoffice-1.0/Makefile
index 393128b98087..284eaaa6ed7c 100644
--- a/editors/openoffice-1.0/Makefile
+++ b/editors/openoffice-1.0/Makefile
@@ -330,7 +330,11 @@ mozilla:
-e 's|--enable-strip||' \
< ${WRKDIR}/mozilla/Makefile.new > ${WRKDIR}/mozilla/Makefile
.endif
- @cd ${WRKDIR}/mozilla && ${MAKE} build
+.if defined(USE_GCC)
+ cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+.else
+ cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
+.endif
@${CP} ${FILESDIR}/zipmoz.sh ${WRKDIR}
@${CHMOD} 755 ${WRKDIR}/zipmoz.sh
@${WRKDIR}/zipmoz.sh ${WRKDIR}/mozilla/work/mozilla/dist FREEBSDGCCI ${WRKDIR}
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index 393128b98087..284eaaa6ed7c 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -330,7 +330,11 @@ mozilla:
-e 's|--enable-strip||' \
< ${WRKDIR}/mozilla/Makefile.new > ${WRKDIR}/mozilla/Makefile
.endif
- @cd ${WRKDIR}/mozilla && ${MAKE} build
+.if defined(USE_GCC)
+ cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+.else
+ cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
+.endif
@${CP} ${FILESDIR}/zipmoz.sh ${WRKDIR}
@${CHMOD} 755 ${WRKDIR}/zipmoz.sh
@${WRKDIR}/zipmoz.sh ${WRKDIR}/mozilla/work/mozilla/dist FREEBSDGCCI ${WRKDIR}
diff --git a/editors/openoffice/Makefile b/editors/openoffice/Makefile
index 393128b98087..284eaaa6ed7c 100644
--- a/editors/openoffice/Makefile
+++ b/editors/openoffice/Makefile
@@ -330,7 +330,11 @@ mozilla:
-e 's|--enable-strip||' \
< ${WRKDIR}/mozilla/Makefile.new > ${WRKDIR}/mozilla/Makefile
.endif
- @cd ${WRKDIR}/mozilla && ${MAKE} build
+.if defined(USE_GCC)
+ cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build
+.else
+ cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build
+.endif
@${CP} ${FILESDIR}/zipmoz.sh ${WRKDIR}
@${CHMOD} 755 ${WRKDIR}/zipmoz.sh
@${WRKDIR}/zipmoz.sh ${WRKDIR}/mozilla/work/mozilla/dist FREEBSDGCCI ${WRKDIR}